mod_xml2enc not available

Bug #1405424 reported by Brian Candler on 2014-12-24
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

mod_xml2enc is not available in package repositories. apache2 now starts without it (see #1376002) but you still get the following warning:

[Wed Dec 24 13:35:57.142324 2014] [proxy_html:notice] [pid 7028:tid 140101697644416] AH01425: I18n support in mod_proxy_html requires mod_xml2enc. Without it, non-ASCII characters in proxied pages are likely to display incorrectly.

Googling around, it seems people are still building this module from source.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ocsinventory-server (Ubuntu):
status: New → Confirmed
Surfrock66 (surfrock66) on 2015-04-13
affects: ocsinventory-server (Ubuntu) → apache2 (Ubuntu)
Emi Bcn (emi) wrote :

This solves:

From: http://askubuntu.com/questions/368515/upgraded-to-ubuntu-13-10-apache-not-able-to-start

sudo apt-get install apache2-prefork-dev libxml2 libxml2-dev
mkdir ~/modbuild/ && cd ~/modbuild/
wget http://apache.webthing.com/svn/apache/filters/mod_xml2enc.c
wget http://apache.webthing.com/svn/apache/filters/mod_xml2enc.h
sudo apxs2 -aic -I/usr/include/libxml2 ./mod_xml2enc.c
cd ~
rm -rfd ~/modbuild/
sudo service apache2 restart

drashtik (drashtipandya37) wrote :

can anyone mark this as solved? Above solution is working

Brian Candler (b-candler) wrote :

Having to build the module yourself from source is not a proper solution. This module should be pre-built and included with apache2 (or in a separate package).

xml2enc is available in the packages:
 $ dpkg -S /usr/lib/apache2/modules/mod_xml2enc.so
   apache2-bin: /usr/lib/apache2/modules/mod_xml2enc.so

And it gets enabled automatically if needed:
$ a2enmod proxy_html
  Considering dependency proxy for proxy_html:
  Enabling module proxy.
  Considering dependency xml2enc for proxy_html:
  Enabling module xml2enc.
  Enabling module proxy_html.
  To activate the new configuration, you need to run:
    systemctl restart apache2

I don't know when this was resolved as I came by this bug parsing old non-updated bugs. But this seems resolved to me at least in Bionic and later.

Changed in apache2 (Ubuntu):
status: Confirmed → Fix Released
Brian Candler (b-candler) wrote :

Thank you. It looks like it was fixed in 16.04:

# dpkg-query -L apache2-bin | grep mod_xml
/usr/lib/apache2/modules/mod_xml2enc.so

The dependency isn't automatic in 16.04:

# a2enmod proxy_html
Considering dependency proxy for proxy_html:
Enabling module proxy.
Enabling module proxy_html.
To activate the new configuration, you need to run:
  service apache2 restart

But you can enable it manually:

# a2enmod xml2enc
Enabling module xml2enc.
To activate the new configuration, you need to run:
  service apache2 restart

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers