mod_xml2enc not available

Bug #1405424 reported by Brian Candler on 2014-12-24
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

mod_xml2enc is not available in package repositories. apache2 now starts without it (see #1376002) but you still get the following warning:

[Wed Dec 24 13:35:57.142324 2014] [proxy_html:notice] [pid 7028:tid 140101697644416] AH01425: I18n support in mod_proxy_html requires mod_xml2enc. Without it, non-ASCII characters in proxied pages are likely to display incorrectly.

Googling around, it seems people are still building this module from source.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ocsinventory-server (Ubuntu):
status: New → Confirmed
Surfrock66 (surfrock66) on 2015-04-13
affects: ocsinventory-server (Ubuntu) → apache2 (Ubuntu)
Emi Bcn (emi) wrote :

This solves:

From: http://askubuntu.com/questions/368515/upgraded-to-ubuntu-13-10-apache-not-able-to-start

sudo apt-get install apache2-prefork-dev libxml2 libxml2-dev
mkdir ~/modbuild/ && cd ~/modbuild/
wget http://apache.webthing.com/svn/apache/filters/mod_xml2enc.c
wget http://apache.webthing.com/svn/apache/filters/mod_xml2enc.h
sudo apxs2 -aic -I/usr/include/libxml2 ./mod_xml2enc.c
cd ~
rm -rfd ~/modbuild/
sudo service apache2 restart

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers