package apache2 (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Bug #1335606 reported by Sevenearths on 2014-06-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Apache wasn't restarting. I just got the following from the command line:

 * Starting web server apache2 /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/access_compat.load: Cannot load /usr/lib/apache2/modules/mod_access_compat.so into server: /usr/lib/apache2/modules/mod_access_compat.so: cannot open shared object file: No such file or directory
Action 'start' failed.
The Apache error log may have more information.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: apache2 (not installed)
ProcVersionSignature: Ubuntu 3.2.0-65.98-generic 3.2.60
Uname: Linux 3.2.0-65-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu17.6
AptOrdering:
 apache2: Purge
 apache2-mpm-prefork: Purge
 apache2.2-common: Purge
 apache2-utils: Purge
 apache2.2-bin: Purge
Architecture: amd64
Date: Sun Jun 29 12:22:50 2014
DpkgTerminalLog:
 Removing apache2 ...
 Purging configuration files for apache2 ...
 update-rc.d: /etc/init.d/apache2 exists during rc.d purge (use -f to force)
 dpkg: error processing apache2 (--purge):
  subprocess installed post-removal script returned error exit status 1
DuplicateSignature: package:apache2:(not installed):subprocess installed post-removal script returned error exit status 1
ErrorMessage: subprocess installed post-removal script returned error exit status 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
SourcePackage: apache2
Title: package apache2 (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Sevenearths (from-a-far) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers