mod_lua.so missing from 14.04 install (apache2-bin, 2.4.7-1ubuntu4))

Bug #1323930 reported by DG on 2014-05-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Canonical Server Team

Bug Description

mod_lua.so is not installed by apache2-bin (2.4.7-1ubuntu4):

http://packages.ubuntu.com/trusty/amd64/apache2-bin/filelist

however, it is referenced by lua.load in /etc/apache2/mod-available:

http://packages.ubuntu.com/trusty/amd64/apache2/filelist

mod_lua should be part of the release I believe, so perhaps it got left out packaging?

Robie Basak (racb) wrote :

Looks like lua wasn't built, because we're trying to build against 5.2, and it's only looking for 5.1.

https://launchpadlibrarian.net/175043407/buildlog_ubuntu-utopic-amd64.apache2_2.4.9-1ubuntu1_UPLOADING.txt.gz

checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking for lua.h in /usr/local/include/lua5.1... no
checking for lua.h in /usr/local/include/lua51... no
checking for lua.h in /usr/local/include... no
checking for lua.h in /usr/include/lua5.1... no
checking for lua.h in /usr/include/lua51... no
checking for lua.h in /usr/include... no
configure: WARNING: *** Lua 5.1 library not found.
configure: WARNING: Lua 5.1 library is required
checking whether to enable mod_lua... no (disabled)
  adding "-I$(top_srcdir)/modules/lua" to INCLUDES

Robie Basak (racb) wrote :

Looks like the regression was in 2.4.4-6ubuntu3. Prior to this, we had:

checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking for lua.h in /usr/local/include/lua5.1... no
checking for lua.h in /usr/local/include/lua51... no
checking for lua.h in /usr/local/include... no
checking for lua.h in /usr/include/lua5.1... yes
checking for luaL_newstate in -llua5.1... yes
configure: using '-L/usr/lib -llua5.1 -lm' for Lua Library
  setting MOD_INCLUDES to "-I/usr/include/lua5.1"
  setting MOD_LUA_LDADD to "-L/usr/lib -llua5.1 -lm"
checking whether to enable mod_lua... shared (all)
  adding "-I$(top_srcdir)/modules/lua" to INCLUDES

Matthias Klose (doko) on 2014-05-28
Changed in apache2 (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
Robie Basak (racb) wrote :

Bug 1324062 tracks the missing lua 5.2 support issue. In the meantime, I've uploaded a fix by reverting to building against lua 5.1 (as discussed in #ubuntu-devel just now).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.4.9-1ubuntu2

---------------
apache2 (2.4.9-1ubuntu2) utopic; urgency=medium

  * Revert 2.4.4-6ubuntu3 and build against lua 5.1 again, since Apache doesn't
    yet support building against lua 5.2 (LP: #1323930).
 -- Robie Basak <email address hidden> Wed, 28 May 2014 08:55:25 +0000

Changed in apache2 (Ubuntu):
status: New → Fix Released
Charles Bueche (j-charles) wrote :

Hi maintainers,

I'm victim of this bug, and need mod_lua. I can compile it myself, but as user of 14.04 LTS, I thought I can expect this bug to be fixed, e.g. being able to get the missing dependencies installed.

I'm not sure to really understand the release process here. Janitor says it's fixed, but apt-get update+upgrade does not install the missing mod_lua.so.

Is there something I have to do to get this fix applied to my server ?

TIA,
Charles

DG (dirk-8) wrote :

Charles,

I fixed this by getting the updated version of Apache can be downloaded from the following url:

https://launchpad.net/ubuntu/+source/apache2

You need the following packages:

apache2-bin_2.4.9-1ubuntu2_amd64.deb
apache2-data_2.4.9-1ubuntu2_all.deb
apache2-utils_2.4.9-1ubuntu2_amd64.deb
apache2_2.4.9-1ubuntu2_amd64.deb
apache2-mpm-worker_2.4.9-1ubuntu2_amd64.deb

(or apache2-mpm-prefork_2.4.9-1ubuntu2_amd64.deb)

and install in that order with sudo dpkg -i, first install liblua5.1

It's not in 14.04.1 - so I also would like to know if this fix perhaps will be in 14.04.2.

Best,

Dirk

Charles Bueche (j-charles) wrote :

Thanks Dirk for your help.

As I found no usable crypto lib in LUA available as Ubuntu LTA package, I reverted to mod_perl for my FixUp handler.
Sad thing, LUA would be a nice addition to my weapon-list to hack on Apache traffic, but it seems not very much used for such things.

Regs,
Charles

DG (dirk-8) wrote :

Hi Charles,

Is there nothing here: http://lua-users.org/wiki/CryptographyStuff?

Lua in Apache is fairly new, but it can do some cool stuff :)

Best,

Dirk

Kurt Huwig (k-huwig-f) wrote :

The problem still exists. I've opened bug 1432989 for that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions