Comment 4 for bug 1284641

Yes, that was a change in API in apache at some point, dav_fs had to be modified for that https://svn.apache.org/viewvc?view=revision&revision=1531505

dav_svn wasn't modified, so the change in the apache API broke dav_svn basically.

dav_fs ships with apache2 so it's easy for it to align with the new API, but dav_svn doesn't.

That means that dav_svn will work properly with older apache, and it may be up to ubuntu to adapt to the new apache API since ubuntu ships now ships with a newer apache.