Comment 0 for bug 1232469

Torsten Knodt (torsknod) wrote :

Hello,
after updating to saucy I got stuck with the above problem.
When both modules php5 and dbd are activated, apache2 dumps core. There is still the apache2 process running, but I cannot access a page.
I hope someone has an idea. Analyzing the core dump with gdb gave no useful results for me:

GNU gdb (GDB) 7.6-ubuntu
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/sbin/apache2...Reading symbols from /usr/lib/debug/usr/sbin/apache2...done.
done.
[New LWP 5384]

warning: Can't read pathname for load map: Input/output error.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/sbin/apache2 -k start'.
Program terminated with signal 11, Segmentation fault.
#0 0xb63a10e9 in ?? () from /lib/i386-linux-gnu/liblzma.so.5
(gdb) bt full
#0 0xb63a10e9 in ?? () from /lib/i386-linux-gnu/liblzma.so.5
No symbol table info available.
#1 0x00b69240 in ?? ()
No symbol table info available.
#2 0xbc000000 in ?? ()
No symbol table info available.
#3 0xe0bface8 in ?? ()
No symbol table info available.
#4 0x3cb69277 in ?? ()
No symbol table info available.
#5 0xc0b69240 in ?? ()
No symbol table info available.
#6 0x00b6858a in ?? ()
No symbol table info available.
#7 0x20000000 in ?? ()
No symbol table info available.
#8 0x21b90332 in ?? ()
No symbol table info available.
#9 0x00000000 in ?? ()
No symbol table info available.

Regards
     Torsten

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: apache2-bin 2.4.6-2ubuntu2
Uname: Linux 2.6.32-042stab078.27 i686
ApportVersion: 2.12.4-0ubuntu1
Architecture: i386
Date: Sat Sep 28 15:09:26 2013
MarkForUpload: True
ProcEnviron:
 LANGUAGE=de_DE.utf8
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: apache2
UpgradeStatus: No upgrade log present (probably fresh install)