Support custom DH parameter file in apache 2.4

Bug #1219804 reported by Christoph_vW on 2013-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Apache2 Web Server
Unknown
Unknown
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Support custom DH parameter file in apache 2.4:
https://issues.apache.org/bugzilla/show_bug.cgi?id=49559

This would allow for better Forward Secrecy Support without having a weak key Exchange (for DHE chiphers) .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
Robie Basak (racb) wrote :

The upstream bug says that this was fixed in 2.4.7. Since we're on 2.4.7-1ubuntu1 in Trusty now, I presume this is now fixed. If this is wrong, please comment and reopen this bug.

Note that since this is a feature, it will not be a candidate for inclusion after Trusty is released if it's not there already.

Changed in apache2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.