apache2 2.4.4-6ubuntu4 failed to upgrade: Cannot load /usr/lib/apache2/modules/libphp5.so into server: undefined symbol: unixd_config

Bug #1202653 reported by philinux on 2013-07-18
140
This bug affects 24 people
Affects Status Importance Assigned to Milestone
apache2 (Debian)
Fix Released
Unknown
apache2 (Ubuntu)
High
Robie Basak
Saucy
High
Robie Basak

Bug Description

Apport caught this during an update.

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: apache2 2.4.4-6ubuntu4
ProcVersionSignature: Ubuntu 3.10.0-2.9-generic 3.10.0
Uname: Linux 3.10.0-2-generic x86_64
Apache2ConfdDirListing: ['docvert']
Apache2Modules:
 Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: unixd_config
 Action '-D DUMP_MODULES' failed.
 The Apache error log may have more information.
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
Date: Thu Jul 18 13:19:25 2013
DuplicateSignature: package:apache2:2.4.4-6ubuntu4:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2012-09-18 (303 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120918.1)
MarkForUpload: True
SourcePackage: apache2
Title: package apache2 2.4.4-6ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to saucy on 2013-07-02 (15 days ago)
error.log: [Thu Jul 18 13:12:31 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.15-1ubuntu3 configured -- resuming normal operations

CVE References

philinux (philcb) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
Argenis Bolivar (abolivar) wrote :

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 apache2-mpm-prefork : Depends: apache2.2-common (= 2.2.22-6ubuntu5) but it is not installed
                       Depends: apache2.2-bin (= 2.2.22-6ubuntu5) but 2.4.4-6ubuntu4 is installed
 libapache2-mod-php5 : Depends: apache2.2-common but it is not installed
 php5-cli : Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-curl : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-fpm : Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-gd : Depends: phpapi-20121212
           Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-imagick : Depends: phpapi-20121212
 php5-imap : Depends: phpapi-20121212
 php5-intl : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-mcrypt : Depends: phpapi-20121212
 php5-memcache : Depends: phpapi-20121212
 php5-ming : Depends: phpapi-20121212
 php5-mysql : Depends: phpapi-20121212
              Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-ps : Depends: phpapi-20121212
 php5-pspell : Depends: phpapi-20121212
               Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-recode : Depends: phpapi-20121212
               Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-snmp : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-sqlite : Depends: phpapi-20121212
               Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-tidy : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-xmlrpc : Depends: phpapi-20121212
               Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
 php5-xsl : Depends: phpapi-20121212
            Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is installed
E: Unmet dependencies. Try using -f.

philinux (philcb) wrote :

Already run fix broken many times from terminal synaptic and tried aptitude. Same errors.

tags: removed: need-duplicate-check
philinux (philcb) wrote :

Well seeing as this laptop is not my main machine and for the sake of it here's what I did.

Opened synaptic and brought up the 5 broken packages and marked them for removal one by one starting at the bottom,

Then marked all upgrade and it's sorted now.

I reinstalled docvert that got removed in the process.

I'm sure there's a more elegant solution to this bug.

Robie Basak (racb) wrote :

Steps to reproduce:

Start from raring.
apt-get install apache2-mod-php5
sed -i s/raring/saucy/ /etc/apt/sources.list
apt-get update
apt-get install apache2-mod-php5

My log is attached.

Jeremy Bicha (jbicha) on 2013-07-19
summary: - package apache2 2.4.4-6ubuntu4 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ apache2 2.4.4-6ubuntu4 failed to upgrade: Cannot load
+ /usr/lib/apache2/modules/libphp5.so into server: undefined symbol:
+ unixd_config
Changed in apache2 (Ubuntu):
importance: Undecided → High
Robie Basak (racb) wrote :
Robie Basak (racb) on 2013-07-19
Changed in apache2 (Ubuntu):
status: Confirmed → Triaged
tags: added: rls-s-incoming
Changed in apache2 (Debian):
status: Unknown → New
joshiss (joshiss) wrote :

The following extra packages will be installed:
  apache2-mpm-prefork libapache2-mod-php5 php5-cli php5-common php5-curl
Suggested packages:
  php-pear php5-json php5-user-cache
The following packages will be upgraded:
  apache2-mpm-prefork libapache2-mod-php5 php5-cli php5-common php5-curl
5 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
7 not fully installed or removed.
Need to get 0 B/5,870 kB of archives.
After this operation, 110 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up apache2 (2.4.4-6ubuntu5) ...
apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: unixd_config
 * Restarting web server apache2 [fail]
invoke-rc.d: initscript apache2, action "restart" failed.
dpkg: error processing apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)

joshiss (joshiss) wrote :

Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apache2-mpm-prefork : Depends: apache2.2-common (= 2.2.22-6ubuntu5.1) but it is not going to be installed
                       Depends: apache2.2-bin (= 2.2.22-6ubuntu5.1) but it is not going to be installed
 docvert : Depends: php5-xsl but it is not going to be installed
           Depends: php5-gd but it is not going to be installed
           Depends: php5-tidy but it is not going to be installed
           Depends: librsvg2-bin but it is not going to be installed
           Depends: libphp-pclzip but it is not going to be installed
           PreDepends: pwgen but it is not going to be installed
           Recommends: docvert-libreoffice but it is not going to be installed
           Recommends: optipng but it is not going to be installed
           Recommends: jpegoptim but it is not going to be installed
           Recommends: fckeditor but it is not going to be installed
 libapache2-mod-php5 : Depends: apache2.2-common but it is not going to be installed
 php5-cli : Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-curl : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-14ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-intl : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-15ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-ldap : Depends: phpapi-20121212
             Depends: php5-common (= 5.5.0+dfsg-15ubuntu1) but 5.4.15-1ubuntu3 is to be installed
 php5-mysql : Depends: phpapi-20121212
              Depends: php5-common (= 5.5.0+dfsg-15ubuntu1) but 5.4.15-1ubuntu3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Robie Basak (racb) on 2013-07-22
Changed in apache2 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Robie Basak (racb)
Changed in apache2 (Debian):
status: New → Fix Released
joshiss (joshiss) wrote :
Download full text (5.0 KiB)

Calculating upgrade... Done
The following NEW packages will be installed:
  libdvbpsi8 linux-headers-3.10.0-5 linux-headers-3.10.0-5-generic
  linux-image-3.10.0-5-generic linux-image-extra-3.10.0-5-generic
The following packages have been kept back:
  vlc-nox
The following packages will be upgraded:
  account-plugin-aim account-plugin-jabber account-plugin-salut
  account-plugin-yahoo apache2-mpm-prefork apache2-utils app-install-data
  apparmor apparmor-easyprof apparmor-easyprof-ubuntu check cups cups-bsd
  cups-client cups-common cups-daemon cups-ppdc cups-server-common dconf-cli
  dconf-editor dconf-gsettings-backend dconf-service dconf-tools dh-apparmor
  empathy empathy-common espeak espeak-data friends friends-dispatcher
  friends-facebook friends-twitter geoclue-ubuntu-geoip gir1.2-dee-1.0
  gir1.2-gnomedesktop-3.0 gir1.2-gudev-1.0 gir1.2-packagekitglib-1.0
  gnome-desktop3-data gnome-terminal gnome-terminal-data graphviz grub-common
  grub-pc grub-pc-bin grub2-common guile-2.0-libs gvfs gvfs-backends gvfs-bin
  gvfs-common gvfs-daemons gvfs-fuse gvfs-libs gwhere hud icedtea-6-jre-cacao
  icedtea-6-jre-jamvm indicator-sound isc-dhcp-client isc-dhcp-common
  isc-dhcp-server language-pack-gnome-sa language-pack-gnome-sa-base
  language-pack-sa language-pack-sa-base libapache2-mod-php5 libapparmor-perl
  libapparmor1 libcdt4 libcgraph5 libcups2 libcupscgi1 libcupsimage2
  libcupsmime1 libcupsppdc1 libdconf-dbus-1-0 libdconf1 libdee-1.0-4
  libespeak1 libgeoip1 libgmime-2.6-0 libgnome-desktop-3-7
  libgnome-desktop-3-dev libgraph4 libgsl0ldbl libgudev-1.0-0
  libgupnp-igd-1.0-4 libgvc5 libgvpr1 libhud-client2 libindicator3-7
  libindicator7 liblightdm-gobject-1-0 libpackagekit-glib2-14 libpam-systemd
  libpathplan4 libsasl2-2 libsasl2-modules libsystemd-daemon0
  libsystemd-journal0 libsystemd-login0 libtimezonemap1 libudev1 libvlc5
  libvlccore5 lightdm linux-generic linux-generic-pae linux-headers-generic
  linux-headers-generic-pae linux-image-generic linux-image-generic-pae
  linux-libc-dev mcp-account-manager-uoa nautilus-sendto-empathy openjdk-6-jre
  openjdk-6-jre-headless openjdk-6-jre-lib overlay-scrollbar
  overlay-scrollbar-gtk2 overlay-scrollbar-gtk3 packagekit
  packagekit-backend-aptcc packagekit-tools php5 php5-cli php5-common
  php5-curl php5-intl php5-ldap php5-mysql postgresql postgresql-client-common
  postgresql-common python-dnspython python-packagekit python-paramiko
  python-sip python-webob simple-scan software-center systemd-services
  transmission-common transmission-gtk udev udisks unity-lens-friends upstart
  vlc-data
149 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
7 not fully installed or removed.
Need to get 6,106 kB/144 MB of archives.
After this operation, 201 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ saucy/universe php5-intl i386 5.5.1+dfsg-1ubuntu1 [133 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ saucy/main php5-mysql i386 5.5.1+dfsg-1ubuntu1 [78.5 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ saucy/main php5-ldap i386 5.5.1+dfsg-1ubuntu1 [21.5 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ saucy/main libapache2-mod-php5...

Read more...

joshiss (joshiss) wrote :

146 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
7 not fully installed or removed.
Need to get 2,906 kB/144 MB of archives.
After this operation, 201 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ saucy/main libapache2-mod-php5 i386 5.5.1+dfsg-1ubuntu1 [2,821 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ saucy/main apache2-mpm-prefork i386 2.4.4-6ubuntu5 [1,438 B]
Get:3 http://archive.ubuntu.com/ubuntu/ saucy/main apache2-utils i386 2.4.4-6ubuntu5 [83.2 kB]
Fetched 2,906 kB in 55s (52.3 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up apache2 (2.4.4-6ubuntu5) ...
apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: unixd_config
 * Restarting web server apache2 [fail]
invoke-rc.d: initscript apache2, action "restart" failed.
dpkg: error processing apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@j0053-hp-probook-4420s:/home/j0053#

Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package apache2 - 2.4.6-2ubuntu1

---------------
apache2 (2.4.6-2ubuntu1) saucy; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/{control, rules}: Enable PIE hardening.
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
    - debian/control, debian/config-dir/mods-available/ssl.conf,
      debian/ask-for-passphrase, debian/apache2.install: Plymouth aware
      passphrase dialog program ask-for-passphrase.
    - debian/rules: Fix cross-building by passing DEB_{HOST,BUILD}_GNU_TYPE
      to configure.
    - debian/patches/086_svn_cross_compiles: Backport several cross fixes
      from upstream
  * Dropped changes:
    - debian/patches/CVE-2013-1896.patch: upstream
  * Fixed module dependencies (LP: #1205314)
    - debian/config-dir/mods-available/lbmethod_*: properly specify
      proxy_balancer, not mod_proxy_balancer.

apache2 (2.4.6-2) unstable; urgency=low

  [ Stefan Fritsch ]
  * Fix watch file
  * Don't pass --silent to libtool, allowing blhc to check the compiler
    options in the build logs.

  [ Arno Töll ]
  * Allow third party packages to use triggers if they use them in a
    maintainer script invoking apache2-maintscript-helper (Closes: #717610)

apache2 (2.4.6-1) unstable; urgency=low

  New upstream release:
  * CVE-2013-1896: mod_dav: Fix a denial of service via MERGE request
    (Closes: #717272)
  * New modules mod_cache_socache, mod_proxy_wstunnel.
  * mod_ssl: Add support for subjectAltName-based host name checking in proxy
    mode (SSLProxyCheckPeerName).
  * mod_lua: Many new functions.
  * mod_auth_basic: Add a generic mechanism to fake basic authentication
    using the ap_expr parser (AuthBasicFake).
  * mod_proxy: New BalancerInherit and ProxyPassInherit options.
  * mod_authnz_ldap: Allow using exec: calls to obtain LDAP bind password.

  [ Arno Töll ]
  * Document our security model in our NEWS file and highlight we do not allow
    access to /srv. Thanks to joeyh for pointing this out.
  * Allow the use of apache2-maintscript-helper from a sub-function. We rely
    on dpkg's arguments supplied in $1, $2 etc. This clashes with function
    arguments supplied to to sh sub-function. Allow manual override in such
    cases.
  * Mention that the dh_apache2 conditional must be present in postrm too
    (Closes: #716694)
  * Fix "dh_apache2 ignores alternative httpd on conf files" by correctly
    checking the supplied arguments, we were off by one (Closes: #717299).
  * Reinstall index.html also on upgrades as it is removed during upgrades.
  * Add mod_macro transitional package as it was promoted to core and does not
    exist as individual package anymore (Closes: #706962)

  [ Stefan Fritsch ]
  * Don't fail package upgrade or removal just because the configuration is in
    an inconsistent state (Closes: #716921, #717343, LP: #1202653).
  * Improve error output of init script.
  * Fix broken dependency information in several *.load files.
  * Add mod_authn_core as dependency of the mod_auth_* modules.
    (Closes: #717448)
 -- Marc Desla...

Read more...

Changed in apache2 (Ubuntu Saucy):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.