Apache Php Segfault crti.S

Bug #430189 reported by Mb on 2009-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache (Ubuntu)
Undecided
Unassigned

Bug Description

This is for, Ubuntu 6.06.2 LTS

Apache 1.3.34 and Php 5.2.10. The backtrace gives me:

(gdb) bt
#0 0x0000000000412dfe in ap_bflush ()
#1 0x0000000000422f71 in ap_rflush ()
#2 0x00002aaaab704875 in sapi_flush ()
   from /usr/local/apache/1.3.41/libexec/libphp5.so
#3 0x00002aaaab6fd19a in php_module_shutdown ()
   from /usr/local/apache/1.3.41/libexec/libphp5.so
#4 0x00002aaaab6fd239 in php_module_shutdown_wrapper ()
   from /usr/local/apache/1.3.41/libexec/libphp5.so
#5 0x0000000000415898 in ap_child_exit_modules ()
#6 0x000000000041c63c in clean_child_exit ()
#7 0x000000000041e6b3 in child_main ()
#8 0x000000000041eb46 in make_child ()
#9 0x000000000041fac2 in standalone_main ()
#10 0x000000000042083c in main ()

(gdb) l
1 /build/buildd/glibc-2.3.6/build-tree/amd64-libc/csu/crti.S: No such file or directory.
        in /build/buildd/glibc-2.3.6/build-tree/amd64-libc/csu/crti.S

So i assume libc-dev issue.

What can i do to fix this ? Thanks alot.

Kees Cook (kees) wrote :

This looks more like an Apache issue (ap_bflush). How is the bug reproduced?

affects: glibc (Ubuntu) → apache2 (Ubuntu)
Changed in apache2 (Ubuntu):
status: New → Incomplete
Chuck Short (zulcss) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Mb (mb-insidetheweb) wrote :

Well, if i knew what the cause is, i wouldn´t report it.

So i dunno how to reproduce it. It just happens from time to time (large site).

So far i see, something is missing, and it looks like a libc-dev issue.

If you want something special; feel free to ask.

Mb (mb-insidetheweb) wrote :

Well guys, could you point me in some direction. Maybe i can reproduce it then. Currently i´m not able the find the cause.

Mb (mb-insidetheweb) wrote :

And i made a mistake. Its of course 1.3.41 for apache.

Mb (mb-insidetheweb) wrote :

Well so far i get this. There is a call via php and that in invalid. Question is why.

Chuck Short (zulcss) wrote :

Hi Mb,

If you can follow the instructions at: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=256510

That would be great.

Thanks
chuck

Chuck Short (zulcss) on 2009-11-22
affects: apache2 (Ubuntu) → apache (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.