[SRU] mitaka point releases

Bug #1591248 reported by David Della Vecchia on 2016-06-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aodh (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
neutron (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
neutron-vpnaas (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

New point releases for misc openstack components for the mitaka release:

aodh 2.0.1
horizon 9.0.1
neutron 8.1.2
neutron-vpnaas 8.1.2

The following components have new upstream releases, but don't actually contain any new functionality, so we'll skip for Ubuntu:

neutron-fwaas 8.1.2
neutron-lbaas 8.1.2

Changed in aodh (Ubuntu):
status: New → Invalid
Changed in horizon (Ubuntu):
status: New → Invalid
Changed in keystone (Ubuntu):
status: New → Invalid
Changed in neutron (Ubuntu):
status: New → Invalid
Changed in neutron-fwaas (Ubuntu):
status: New → Invalid
Changed in neutron-lbaas (Ubuntu):
status: New → Invalid
Changed in neutron-vpnaas (Ubuntu):
status: New → Invalid
description: updated
description: updated
no longer affects: neutron-lbaas (Ubuntu)
no longer affects: neutron-fwaas (Ubuntu)

Hello David, or anyone else affected,

Accepted neutron into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:8.1.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in aodh (Ubuntu Xenial):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted aodh into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/aodh/2.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron-vpnaas (Ubuntu Xenial):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted neutron-vpnaas into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron-vpnaas/2:8.1.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Corey Bryant (corey.bryant) wrote :

Dropping keystone from this SRU as the packaging is not complete for it and I don't want that to block the release of the other packages.

no longer affects: keystone (Ubuntu)
no longer affects: keystone (Ubuntu Xenial)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu Xenial):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aodh - 2.0.1-0ubuntu2

---------------
aodh (2.0.1-0ubuntu2) yakkety; urgency=medium

  [ David Della Vecchia ]
  * New upstream point release for OpenStack Mitaka (LP: #1591248).
  * d/control: Align (Build-)Depends with upstream.

  [ Corey Bryant ]
  * d/p/catch-driverloadfailure.patch: Cherry picked from master aodh to
    fix DriverLoadFailure causing test_get_transport_optional() failure.

 -- Corey Bryant <email address hidden> Tue, 14 Jun 2016 13:32:00 -0400

Changed in aodh (Ubuntu):
status: Invalid → Fix Released
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted horizon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/2:9.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Xenial):
status: Confirmed → Fix Committed
Corey Bryant (corey.bryant) wrote :

Hello Chris,

These packages (minus horizon) have all been verified successfully. Note: 2:9.0.1-0ubuntu2 has since been uploaded and fixes horizon 2:9.0.1-0ubuntu1. See: https://bugs.launchpad.net/cloud-archive/+bug/1594249.

Thanks,
Corey

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aodh - 2.0.1-0ubuntu1

---------------
aodh (2.0.1-0ubuntu1) xenial; urgency=medium

  * New upstream point release for OpenStack Mitaka (LP: #1591248).
  * d/control: Align (Build-)Depends with upstream.

 -- David Della Vecchia <email address hidden> Fri, 10 Jun 2016 12:05:12 -0400

Changed in aodh (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for aodh has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron-vpnaas - 2:8.1.2-0ubuntu1

---------------
neutron-vpnaas (2:8.1.2-0ubuntu1) xenial; urgency=medium

  [ James Page ]
  * d/p/*: Drop - no longer needed as patch upstream.

  [ David Della Vecchia ]
  * New upstream point release for OpenStack Mitaka (LP: #1591248).

  [ Corey Bryant ]
  * d/rules: Switch to using ostestr for unit test execution to avoid races.

 -- Corey Bryant <email address hidden> Fri, 10 Jun 2016 14:47:09 -0400

Changed in neutron-vpnaas (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:8.1.2-0ubuntu1

---------------
neutron (2:8.1.2-0ubuntu1) xenial; urgency=medium

  * New upstream point release for OpenStack Mitaka (LP: #1591248).

 -- David Della Vecchia <email address hidden> Fri, 10 Jun 2016 12:17:08 -0400

Changed in neutron (Ubuntu Xenial):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Setting back to v-needed for horizon.

tags: added: verification-needed
removed: verification-done
Martin Pitt (pitti) wrote :

ah, horizon verified in bug 1594249 -- this is very confusing, can you please decide how you want to track SRUs (in one meta-bug like here or in one bug per package, like for bug 1594249)?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2:9.0.1-0ubuntu2

---------------
horizon (2:9.0.1-0ubuntu2) xenial; urgency=medium

  * d/theme/ubuntu_theme.py: When setting UBUNTU_THEME for AVAILABLE_THEMES,
    use the symlinked path that already exists under
    /usr/share/openstack-dashboard/openstack_dashboard (LP: #1594249).

 -- Corey Bryant <email address hidden> Tue, 21 Jun 2016 13:41:09 -0400

Changed in horizon (Ubuntu Xenial):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

Martin,

Horizon was a bit confusing because the version uploaded for this bug failed testing in proposed. We should have included this bug number (LP: #1591248) in the fixed version's changelog and that would have avoided the confusion.

But we still need to track SRUs in both ways: point release SRUs for multiple packages and individual package SRUs for actual failures hit by users. So I don't see how we could just do one or the other.

Thanks,
Corey

Corey Bryant (corey.bryant) wrote :

What I meant to say was:

Horizon was a bit confusing because the version uploaded for this bug
failed testing in proposed, and a user opened a bug for the failure hit in proposed (LP: #1594249).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers