[MIR] ant1.7, ant1.7-optional (source: ant1.7)

Bug #614000 reported by Michael Bienia on 2010-08-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ant1.7 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ant1.7

"ant" (already in main) moved to the new upstream version 1.8. For those packages that don't work with ant 1.8, the package got forked to "ant1.7":

* Rename source package to ant1.7 to provide an ant version for packages that
     are not compatible with 1.8.
[changelog entry for ant1.7 1.7.1-5 (the first revision after the fork)]

Rationale:
ant1.7, ant1.7-optional is needed as a build-dependency:
- axis is in DEPWAIT on ant1.7-optional
- libservlet2.4-java is in DEPWAIT on ant1.7

Michael Bienia (geser) on 2010-08-05
summary: - [MIR] ant1.7
+ [MIR] ant1.7, ant1.7-optional (source: ant1.7)
Thierry Carrez (ttx) wrote :

Since ant-1.7 used to be in main, ant1.7-1.7 should be a no-brainer

Note that libservlet2.4-java is getting deprecated, so it shouldn't have anything in main depending on it anymore.

Kees Cook (kees) wrote :

This is fine. +1

Changed in ant1.7 (Ubuntu):
status: New → In Progress
Colin Watson (cjwatson) wrote :

 o ant1.7: ant1.7 ant1.7-gcj ant1.7-optional ant1.7-optional-gcj
   [Reverse-Depends: Rescued from ant1.7, ant1.7-optional-gcj]
   [Reverse-Build-Depends: libservlet2.4-java]

Promoted.

Changed in ant1.7 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers