ant fix to correctly build JAX-WS

Bug #600272 reported by Matthias Klose on 2010-06-30
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ant (Ubuntu)
Undecided
Unassigned
Jaunty
High
Unassigned
Karmic
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: ant

currently openjdk-6 6b18 is misbuilt in jaunty, karmic and lucid:

https://issues.apache.org/bugzilla/show_bug.cgi?id=43114
https://issues.apache.org/bugzilla/show_bug.cgi?id=43114#c23

Matthias Klose (doko) wrote :

fixed in maverick (1.8)

Changed in ant (Ubuntu):
status: New → Fix Released
Changed in ant (Ubuntu Jaunty):
importance: Undecided → High
milestone: none → jaunty-updates
status: New → In Progress
Changed in ant (Ubuntu Karmic):
importance: Undecided → High
milestone: none → karmic-updates
status: New → In Progress
Changed in ant (Ubuntu Lucid):
importance: Undecided → High
milestone: none → lucid-updates
status: New → In Progress

Accepted ant into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ant (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in ant (Ubuntu Karmic):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted ant into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ant (Ubuntu Lucid):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted ant into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Matthias Klose (doko) wrote :

confirmed that the jtreg test results look good. Steve, please check the TCK test results.

Steve Beattie (sbeattie) wrote :

I've confirmed that, for lucid, the openjdk you built with the ant in lucid-proposed corrects the failing devtools testcases in the sample testcases; I'm now running the full testsuite against the jdk and will report back the results here.

Steve Beattie (sbeattie) wrote :

I have run the full JCK testsuites (in non-interactive mode) on the openjdk packages Matthias provided that were built with the version of ant in lucid-proposed. I can confirm that with this version, both the devtools and the compiler testsuites pass with no failures. The runtime tests still have a few failures (21 failed, 5 errors); these appear to be in three areas:

  * java_net/URL_Connection, due possibly to sun.com redirecting to oracle.com
  * secure random tests: timeout due to insufficent entropy
  * javax_management/remote/ JMX and RMI bits: not sure why these are failing; however, these do not appear to be failures introduced by building the openjdk with the version of ant in -proposed (I get them with the openjdk from lucid also).

Can we also do test builds of other packages that build depend on ant? I'd like to ensure no FTBFS were introduced by this proposed fix.

Thanks!

Matthias Klose (doko) wrote :

checked that eucalyptus and OOo do build with the updated packages

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ant - 1.7.1-4ubuntu1

---------------
ant (1.7.1-4ubuntu1) lucid-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden> Wed, 30 Jun 2010 23:56:15 +0200

Changed in ant (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ant - 1.7.1-4ubuntu0.1

---------------
ant (1.7.1-4ubuntu0.1) karmic-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden> Wed, 30 Jun 2010 22:44:07 +0000

Changed in ant (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ant - 1.7.1-0ubuntu2.1

---------------
ant (1.7.1-0ubuntu2.1) jaunty-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden> Wed, 30 Jun 2010 22:57:00 +0000

Changed in ant (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers