Ubuntu

[new-upstream]Anki 2.0.x

Reported by Guybrush88 on 2012-10-14
140
This bug affects 29 people
Affects Status Importance Assigned to Milestone
anki (Ubuntu)
Wishlist
Unassigned

Bug Description

"The old AnkiWeb was shut down on Feb 7 2013. Anki 1 will no longer be able to sync, or download shared decks/plugins from within the program." (http://ankisrs.net/anki2.html)

In practice, this results in sync error messages at the start and exit of the official Ubuntu version of Anki (1.2.x) for people using decks that used to sync before:

"There was a connection error. If it persists, please try disabling your
firewall software temporarily, or try again from a different network.

Debugging info: HTTPError()"

On upstream, a number of stable releases of Anki 2.0.x have already been published.

Source code:
https://github.com/dae/anki

The official .deb package can be downloaded from:
http://ankisrs.net/anki2.html

Latest changes:
http://ankisrs.net/docs/changes.html#latest

tags: added: upgrade-software-version
Guybrush88 (guybrush) on 2012-10-14
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in anki (Ubuntu):
status: New → Confirmed
Michael (mnichau) wrote :

Anki 2.0.3 is now available: http://ankisrs.net/anki2.html

Upstream Ubuntu/Debian package: http://ankisrs.net/download/mirror/anki-2.0.3.deb

Is there any chance this will be added to the official Ubuntu repositories in the near future?

Changed in anki (Ubuntu):
importance: Undecided → Wishlist
dino99 (9d9) wrote :

As its a major built, it might be set better than whishlist, and pushed into Raring at least.

http://ankisrs.net/docs/dev/changes.html

tags: added: needs needs-packaging
tags: removed: needs
tags: added: amd64 i386 raring
dino99 (9d9) on 2013-01-04
tags: removed: needs-packaging
Michael (mnichau) wrote :

In 10 days, the supported version of Anki on Ubuntu will stop syncing cards, resulting in error messages and reduced functionality. IMO this qualifies as a bug now, and not merely a feature request.

From the official Anki page:
"The old AnkiWeb will shut down on Feb 4 2013. After it is shut down, Anki 1 will no longer be able to sync, or download shared decks/plugins from within the program."

Source:
http://ankisrs.net/anki2.html

Michael (mnichau) on 2013-01-25
description: updated
Michael (mnichau) on 2013-01-25
summary: - [new-upstream]Anki 2.0.0
+ [new-upstream]Anki 2.0.x
Michael (mnichau) on 2013-02-10
description: updated
Michael (mnichau) on 2013-02-10
description: updated
dino99 (9d9) on 2013-04-26
tags: added: saucy
Paul Kishimoto (khaeru) wrote :

According to https://launchpad.net/ubuntu/+source/anki , anki 2.0.11+dfsg-3 was uploaded to saucy on 2013-07-21.

tags: removed: saucy
Logan Rosen (logan) on 2013-08-14
Changed in anki (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers