crashes with assertion failure on startup

Bug #651678 reported by Nigel Cundy on 2010-09-30
210
This bug affects 42 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
High
Inkscape
High
Jon A. Cruz
OpenShot Video Editor
High
Unassigned
Shutter
Undecided
Unassigned
anjuta (Ubuntu)
Undecided
Unassigned
gtk+2.0 (Ubuntu)
Low
Unassigned
oxygen-molecule (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: anjuta

Running Kubuntu Maverick

$ dpkg -l | grep anjuta
ii anjuta 2:2.30.1.0-0ubuntu2 A GNOME development IDE, for C/C++
ii anjuta-common 2:2.30.1.0-0ubuntu2 A GNOME development IDE, for C/C++ - data files
ii anjuta-dev 2:2.30.1.0-0ubuntu2 A GNOME development IDE, for C/C++ - development files

When I run, the splash flashes for a moment, then the program exits with the following message

$ anjuta &
Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)

I attach the crash file

Nigel Cundy (nigel-cundy) wrote :
Schiwi (mschiwi) wrote :

I get the same message when i try to start inkscape

Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)

Benjamin Wohlwend (piquadrat) wrote :

I get the same error when starting inkscape, too, also on Kubuntu 10.10. I attached a gdb backtrace with as many dbg-packages installed as I could find in the inkscape dependency tree. But obviously I missed a few, so feel free to ask for another backtrace with additional dbg-packages installed.

idyllic (idyllic) wrote :

I get the same error when starting comix, on Kubuntu 10.10 Release Candidate.

 gtk.RecentChooserMenu.__init__(self, self._manager)
**
Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

Stefan Skotte (screemo) wrote :

I get exactly same error for inkscape..... any solutions yet ?

Stefan Skotte (screemo) wrote :

If you rename ~/.gtkrc-2.0, it works.

It has something to do with qtcurve's theming... not sure exactly what part.

Benjamin Wohlwend (piquadrat) wrote :

Renaming .gtkrc-2.0 or deinstalling qtcurve doesn't fix inkscape for me. But both comix and anjuta start without issues here, even with qtcurve activated. Perhaps these crashes aren't as related as the final error message makes them appear...

Renaming ~∕.gtkrc-2.0 worked for me (on ubuntu maverick).

Thank you.

Schiwi (mschiwi) wrote :

Renaming ~/.gtkrc-2.0 did not work for me too, but rename ~/.gtkrc-2.0-kde4 helps, inkscape is starting now :)

su_v (suv-lp) wrote :

related report (crash triggered by certain icon sets (Oxygen, Hycons)):
Bug #658055 in Inkscape: “inkscape crashes when opening document properties”
<https://bugs.launchpad.net/inkscape/+bug/658055>

su_v (suv-lp) on 2010-10-11
Changed in inkscape:
importance: Undecided → High
tags: added: crash ui

I am experiencing this too with Inkscape on Kubuntu Maverick, having a nonstandard icon theme. If I change the
gtk theme to something different from QtCurve or if I set the icon theme to Oxygen everything works ok.
The only combination which doesn't work for me is QtCurve+Faenza Icon theme.

Got almost exactly the same backtrace as Benjamin Wohlwend.

Interestingly the gtk-file icon exists in the Faenza icon theme, while oxygen does not have it.

su_v (suv-lp) on 2010-10-13
Changed in inkscape:
status: New → Confirmed
Balazs Major (balazsmajor-ben) wrote :

I have the same bug in Arch Linux with KDE 4.5.2:

Gtk:ERROR:gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)

Emergency save activated!
Emergency save completed. Inkscape will close now.

Matthias Klumpp (ximion) on 2010-10-20
Changed in anjuta (Ubuntu):
status: New → Confirmed
Tomáš Myšík (gapon) wrote :

The same for homebank...

I had same crashes with error 'Gtk:ERROR:gtkrecentmanager.c:1942:get_icon_fallback:'
on inkscape and evolution (not mypaint) with the Oxygen icons on kubuntu 10.10.
Choosing the GNOME theme solved the evolution bug, not the inkscape one.
I do not have ~/.gtkrc-2.0
renaming both my ~/.gtkrc-2.0-kde and ~/.gtkrc-2.0-kde4 folders solved the problem (and now I can put the Oxygen theme back)

My crashes were not related to the issue that led the developers to disable the floating toolbar in inkscape under kde:
http://wiki.inkscape.org/wiki/index.php/Release_notes/0.48#Floating_Toolbars
(meaning, I can have floating toolbars). I'm writing this since it may help triage bug reports.

Edit on my post #14:
When restarting (relogingg?), a *file* ~/.gtkrc-2.0-kde4 is created with the following text inside:
include "/usr/share/themes/QtCurve/gtk-2.0/gtkrc"
If you delete it, it will be recreated on reboot.
The workaround I temporary use:
in the menu editor, replace the "evolution" command by the following:

rm -f ~/.gtkrc-2.0-kde4 && evolution

Balazs Major (balazsmajor-ben) wrote :

On Arch Linux and using KDE 4.5.2 I was able to solve the problem by copying ~/.gtkrc-2.0 to ~/gtkrc-2.0-kde4

Gerfaut (henri-bauer) wrote :

I had the same problem with Inkscape in Maverick Meerkat after having installed the textext extension !
I use a Ubuntu server without Gnome/KDE/Xfce. I only use a light-weighted IceWM.
Here is the error i got :
Gtk:ERROR:gtkrecentmanager.c:1942:get_icon_fallback: assertion failed:
(retval != NULL)
Aborted

I solved it in two times, first by creating the ~/.gtkrc-2.0 with a tango theme definition :
echo 'gtk-icon-theme-name="Tango"' >> ~/.gtkrc-2.0

And, as it was not sufficient, I also installed the corresponding theme :
sudo apt-get install tango-icon-theme

Now, everything is running fine.

By the way, I also got back the icons that I had lost in avidemux2_gtk after the Maverick Meerkat dist-upgrade...

Hope this helps.

Pour les francophones : la même explication détaillée ici :http://gerfaut83.free.fr/index.php?post/2010/11/02/Probl%C3%A8me-au-lancement-d-Inkscape-sous-Ubuntu

Gökçen Eraslan (gkcn) wrote :

This is a bug of new GTK 2.22, since they removed old-named stock icons.[1] We use this gtk2 patch[2] in Pardus to workaround this.

Also there is an open bug in gnome[3] about that.

[1] http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-22&id=5c74a696d5c1593be0f6b801cb85a4baf1087883
[2] http://svn.pardus.org.tr/pardus/2011/devel/desktop/toolkit/gtk/gtk2/files/make-symlinks-for-old-icon-names.diff
[3] https://bugzilla.gnome.org/show_bug.cgi?id=629878

Matthias Klumpp (ximion) on 2010-11-02
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - anjuta crashes with assertion failure on startup
+ crashes with assertion failure on startup
Tomáš Myšík (gapon) wrote :

Guys, it would be great if anyone of you could fix this because we cannot even run some of our GTK applications (no work around works for me, no possibility to run e.g. HomeBank).

Thanks in advance,
Tomas

Janet (bugzilla-kerridis) wrote :

I also have the problem with inkscape in Kubuntu 10.10 when I use a custom icon theme. When I use Oxygen as icon theme inkscape starts fine. Very strange, because the used custom icon theme does inherit oxygen (among others, not in first place), so it shouldn't be any difference ...

Janet (bugzilla-kerridis) wrote :

The workaround to install and set the Tango icon theme in ~/.gtkrc-2.0-kde4 (I don't have a .gtkrc-2.0) does not work here. Inkscape doesn't want to work nonetheless.

su_v (suv-lp) wrote :

Also affects Inkscape 0.48 and current trunk on Mac OS X after upgrading to GTK+ 2.22 (via MacPorts).

Possible workaround with MacPorts: install the port 'gnome-icon-theme' and add the following line to '~/.gtkrc-2.0':
gtk-icon-theme-name = "gnome"

@~suv: This workaround fixed an issue with a MacPorts install of MyPaint 0.9.0.

Note that if '~/.gtkrc-2.0' does not exist, it can be created and the line can be added to the file.

Changed in gtk:
importance: Unknown → High
status: Unknown → New
tekkenlord (linuxfever) wrote :

I am also affected by this on my Kubuntu 10.10 64-bit with KDE 4.5.3. Two things have worked for me: comment #17 or running inkscape with sudo.

su_v (suv-lp) wrote :

See also related bug #665725 in Linux Mint:
“[mint-x] gtk+2.0-2.22.0 Error Gedit and Gnome panels crashing”:
<https://bugs.launchpad.net/linuxmint/+bug/665725>

Comment #11 has a script attached to test the current icon theme for the presence of for two icons (GTK_STOCK_DIRECTORY and GTK_STOCK_FILE) apparently used but not found as icon_fallback in gtkrecentmanager.c.

Hannes Coetzee (scorpking) wrote :

Same problem for me on Kubuntu 10.10 x64. Comment #17 worked but back to the same problem after recent updates. After removing ~/.gtkrc-2.0-kde4 comment #17 worked again. Running Inkscape as root also works.

fanda (fanda-vacek) wrote :

On Kubuntu 10.10 x64, i've just removed ~/.gtkrc-2.0-kde4 and Document properties worked again.

Hannes Coetzee (scorpking) wrote :

Inkscape not running again today. Fixed it by removing both ~/.grkrc-2.0 and ~/.gtkrc-2.0-kde4 and the setting the default icon theme to Oxygen and GTK+ Appearance to QtCurve in System Settings. Note that you might have to set the GTK theme to something else first if it is already on QtCurve so that the ~/.gtkrc-2.0-kde4 file can be created again.

doc81 (robby-engelmann) wrote :

I experienced the same problems like you all. As I regularly use inkscape I searched for a workaround other than changing the icon set each time I have to run Inkscape. I found one, that worked for me:

I looked into '/usr/share/themes/QtCurve/gtk-2.0/gtkrc' and wondered about one of the first lines:
gtk-fallback-icon-theme="gnome"

As I have not installed gnome, why the fallback should be gnome and not oxygen. Thus I changed to:
gtk-fallback-icon-theme="oxygen"

Now, all works fine with oxygen icons in Inkscape. Hopefully, that will work for you all too. Please let us know here.

Peter Mühlenpfordt (muehlenp) wrote :

@doc81: On my system (Kubuntu 10.10) there was no "gtk-fallback-icon-theme"-line.
After adding 'gtk-fallback-icon-theme="oxygen"' as first line to '/usr/share/themes/QtCurve/gtk-2.0/gtkrc', inkscape works again! :-)
Many thanks for this hint.

tekkenlord (linuxfever) wrote :

Thank you doc81, your workaround works for me too.

tekkenlord (linuxfever) wrote :

I guess I spoke too quickly... Same error occurs with inkscape even after doc81's workaround.

doc81 (robby-engelmann) wrote :

@tekkenlord: on what system do you run inkscape? Do you have installed the oxygen icon set, so do you have the folder 'usr/share/icons/oxygen' with icons in it?

I guess the problem is, that gtk/qtcurve fallback works only with icon sets installed in '/usr/share/icons/*' and do not look for icons in the users home folder.

tekkenlord (linuxfever) wrote :

I use Kubuntu 10.10 with KDE 4.5.3 on 64-bit. Oxygen icon theme is installed under "/usr/share/icons/oxygen"...

Peter Mühlenpfordt (muehlenp) wrote :

@tekkenlord: Is 'QtCurve' your active gtk-theme? You need to edit the gtkrc of your _active_ theme. I use Aurora, for which the rc file resides under /usr/share/themes/Aurora/gtk-2.0/gtkrc.

tekkenlord (linuxfever) wrote :

Thanks, but yes, QtCurve is indeed my active theme.

Jon A. Cruz (jon-joncruz) wrote :

I've checked the details of what is going on with the icon loading, and will have a work-around implemented for Inkscape. Since it registers itself as an icon factory, Inkscape will be able to provide fallbacks for those missing icons and be able to inject them before the recent manager can ask for them.

Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
status: Confirmed → In Progress
milestone: none → 0.48.1
Jon A. Cruz (jon-joncruz) wrote :

Simple work-around to get copies of the renamed file and directory icons in so that the recent manager will not crash.

Jon A. Cruz (jon-joncruz) wrote :

Fix committed in trunk revision 9939 and 0.48.x revision 9747.

Changed in inkscape:
status: In Progress → Fix Committed
Tomáš Myšík (gapon) wrote :

But this fix does not solve the main problem, right? I guess Homebank and perhaps other GTK applications won't still work...

tags: added: patch
su_v (suv-lp) wrote :

Fix tested and confirmed with Inkscape 0.48+devel r9941 on OS X 10.5.8 with gtk2 @2.22.1.
No regressions noticed with a separate build of r9941 using the older GTK+ version 2.20.1.

vedavata (vedavrata) wrote :

I have the some with evolution :

$evolution
** (evolution:23489): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed EI: MAIL PREFS**
Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

vedavata (vedavrata) wrote :

the same with evolution :

$evolution

** (evolution:23489): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed EI: MAIL PREFS**

Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

rm -f ~/.gtkrc-2.0-kde4 && evolution
-- This solution helped!!! Thank you very much!!!

vedavata (vedavrata) wrote :

I have the same problem with Evolution :

==========================
$evolution

** (evolution:23489): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed EI: MAIL PREFS**

Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted
==========================

And such solution helps:
==========================
rm -f ~/.gtkrc-2.0-kde4 && evolution
==========================
But why i should do this from time to time?..

Arnel A. Borja (kyoushuu) wrote :

This error shows up because icons for files recently opened are missing. A fix is to copy/link the missing mimetype icon from /usr/share/icons/gnome/*/mimetypes to /usr/share/icons/oxygen/*/mimetypes (or the icon theme you use). For Anjuta, it is gnome-mime-application-x-anjuta. The * means the sizes that the icon is available: you need to copy/link the icon from one size to the other. To find the files that needs to be linked, run this in terminalfind /usr/share/icons/gnome/* | grep gnome-mime-application-x-anjuta
replace gnome-mime-application-x-anjuta with the one you need.

Arnel A. Borja (kyoushuu) wrote :

Sorry the command is "find /usr/share/icons/gnome/* | grep gnome-mime-application-x-anjuta". The new lines were removed.

Matthias Klumpp (ximion) on 2011-02-07
Changed in oxygen-molecule (Ubuntu):
status: New → Confirmed
Changed in shutter:
status: New → Invalid
vedavata (vedavrata) wrote :

I have the same problem with Evolution :

Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

And such solution helps:
rm -f ~/.gtkrc-2.0-kde4 && evolution

But i am tired to do this from time to time... :-(

Thangalin (thangalin) wrote :

Change the Widget style from QtCurve to Raleigh:

1. System Settings
2. Click Application Appearance
3. Click GTK+ Appearance
4. Set Widget style to: Raleigh
5. Click Apply

Remove files:

cd $HOME
rm -rf .openshot
rm -rf .gtkrc-2.0-kde4

Install apps:

sudo aptitude install anjuta

Installed from PPA.

Kubuntu 10.10

I have tried every suggestion here, including a full reboot.

Nothing will get Openshot to save without crashing.

Thangalin (thangalin) wrote :

For what it's worth, The GIMP seems to suffer from a similar (if not exactly the same) issue. However, it does not crash:

(gimp:6718): Gtk-CRITICAL **: IA__gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

The software continues like nothing went wrong.

mypaint crashes each time I open it, started after first saving of a file (it crashed just after saving it and wont open again).
kde with 10.10

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released

I am also aflected by the anjuta version of this bug!

I am also afflicted by the anjuta version of this bug.

MrHaroldA (mrharolda) wrote :

Openshot 1.3 (from PPA) is also affected by this bug!

$ openshot
--------------------------------
   OpenShot (version 1.3.0)
--------------------------------
Process no longer exists: 17094. Creating new pid lock file.
state saved
**
Gtk:ERROR:/build/buildd/gtk+2.0-2.22.0/gtk/gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

Sasa (sasarakezic) wrote :

I don't know if it is ok but there is temporary solution for this bug which is simple, type in your Terminal

sudo mypaint

and it will work! At least i found that it works for some people. It seems like same error is repeating with some other programs and people solved that error by typing sudo in front of program. I tried that wil mypaint and it worked :)

I hope that i am not in breach of some rules but i wanted to share it with people who can not wait to see fix for it.

Matthias Klumpp (ximion) wrote :

The easiest workaround (and the cleanest hack) is to just add the line "Inherits=hicolor" to "/usr/share/icons/default.kde4/index.theme" (just open it as root via kdesudo kate), for example before the "Example=folder" line.
This will make all GNOME apps find the right icons if KDEs Oxygen style is used.

The /usr/share/icons/default.kde4/index.theme does not fix anything in my case. Anjuta and many other GTK-based apps are affected yet there doesn't seem to be much news about a fix, even upstream.

Nelson Menezes (nelson) wrote :

One more potential fix (i.e. "it works for me"): Start your offending application from the command line, like this:

GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc <appname>

For inkscape:

GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc inkscape

Changed in openshot:
status: New → Confirmed
Changed in openshot:
importance: Undecided → High
Thangalin (thangalin) wrote :

I was unable to use Gnome's Shutter (Perl-based) screen capture application under KDE because of this issue.

I have not yet verified whether the following fix will help with OpenShot:

1. Run: sudo aptitude install desktop-file-utils perl-modules libnet-dbus-glib-perl gnome-settings-daemon
2. Run: gnome-settings-daemon
3. Run: openshot

I have read elsewhere that you can edit "/usr/share/themes/QtCurve/gtk-2.0/gtkrc" and add a line to change the default fonts.

I think the problem for Kubuntu users is that OpenShot has a dependency on Gnome libraries, yet the KDE desktop does not come with Gnome libraries installed.

Hope it helps!

Thangalin (thangalin) wrote :

For Kubuntu users:

sudo aptitude install gnome-icon-theme

Jonathan Thomas (jonoomph) wrote :

With version 1.4.0 of OpenShot, our debian packaging was updated to depend on gnome-icon-theme, which prevents this error on OpenShot. So, I'm marking this as Fix Released. Thanks!

Changed in openshot:
status: Confirmed → Fix Released
Changed in gtk:
status: New → Fix Released
Shingi (shingi2009) wrote :

My Gedit was crashing on startup and giving the following error:-

Gtk:ERROR:/build/buildd/gtk+2.0-2.24.20/gtk/gtkrecentmanager.c:2116:get_icon_fallback: assertion failed: (retval != NULL)
Aborted

I fixed this by following these steps

1. Open terminal
2. Run the command: $ echo 'gtk-icon-theme-name="Tango"' >> ~/.gtkrc-2.0
3. Run the command: $ sudo apt-get install tango-icon-theme
4. Close terminal
5. Create a new text file on your desktop eg: random.txt
6. Double click on random.txt

Problem solved. Now you should be able to run Gedit by double clicking on a file or from the command line ( $ gedit random.txt ) with no problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.