Needs Conflicts: libgbf-1-2

Bug #338464 reported by Philip Muškovac
98
This bug affects 8 people
Affects Status Importance Assigned to Milestone
anjuta (Ubuntu)
Medium
Christophe Sauthier
Nominated for Jaunty by Evan Broder

Bug Description

Binary package hint: anjuta

Vorbereiten zum Ersetzen von anjuta 2:2.24.2-1ubuntu1 (durch .../anjuta_2%3a2.25.902-0ubuntu2_i386.deb) ...
Entpacke Ersatz für anjuta ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/anjuta_2%3a2.25.902-0ubuntu2_i386.deb (--unpack):
 Versuche, »/usr/bin/gbf-am-parse« zu überschreiben, welches auch in Paket libgbf-1-2 ist
dpkg-deb: Unterprozess paste mit Signal (Broken pipe) getötet

installed libgbf-1-2 version:
libgbf-1-2:
  Installiert: 2.24.1-1
  Kandidat: 2.24.1-1
  Versions-Tabelle:
 *** 2.24.1-1 0
        500 http://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Related branches

Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote :

Indeed.

Changed in anjuta:
status: New → Confirmed
Revision history for this message
Scott Sweeny (ssweeny) wrote : Re: [Jaunty] anjuta >2.25 needs Conflicts: libgbf-1-2

Since anjuta 2.25.4 gnome-build (libgbf) has been incorporated into anjuta itself[1]. Therefore anjuta should Conflict and Replace libgbf.

[1] http://sourceforge.net/forum/forum.php?forum_id=910256

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

I am preparing a new upload to fix that...

Changed in anjuta:
assignee: nobody → christophe.sauthier
status: Confirmed → In Progress
Revision history for this message
Martin Olsson (mnemo) wrote :
Download full text (3.2 KiB)

Today I got this weird broken package and it seems related. This is currently blocking me from installing lots of other apps like "elisa" etc. Is there a workaround I can use? I tried to remove anjuta (which I never use anyway) but the error seems to prevent me from even uninstalling the existing anjuta packages I have?

mnemo@kingfish:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  python-alsaaudio kpartx python-sqlalchemy python-utidylib timidity python-libvirt xvfb python-xlib python-feedparser libtidy-0.99-0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  anjuta
Suggested packages:
  libgtkmm2.0-dev libgnomemm2.0-dev
The following packages will be upgraded:
  anjuta
1 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.
Need to get 0B/2261kB of archives.
After this operation, 1937kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 274345 files and directories currently installed.)
Preparing to replace anjuta 2:2.24.2-1ubuntu1 (using .../anjuta_2%3a2.25.902-0ubuntu2_amd64.deb) ...
Unpacking replacement anjuta ...
dpkg: error processing /var/cache/apt/archives/anjuta_2%3a2.25.902-0ubuntu2_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/gbf-am-parse', which is also in package libgbf-1-2
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/anjuta_2%3a2.25.902-0ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
mnemo@kingfish:~$ sudo apt-get remove libgbf-1-2
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  anjuta: Depends: libgbf-1-2 but it is not going to be installed
          Depends: anjuta-common (= 2:2.24.2-1ubuntu1) but 2:2.25.902-0ubuntu2 is to be installed
  libgbf-1-dev: Depends: libgbf-1-2 (= 2.24.1-1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
mnemo@kingfish:~$ sudo apt-get remove anjuta
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gnome-devel: Depends: anjuta (>= 2:2.4.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
mnemo@kingfish:~$ sudo apt-get remove elisa
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package elisa is not installed, so not removed
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  anjuta: Depends: anjuta-common (= 2:2.24.2-1ubuntu1) but 2:2.25.902-0ubuntu2 is to be installed
E: Unme...

Read more...

Revision history for this message
Sandro Millien (rhass-deactivatedaccount) wrote :

Do this :
dpkg -r libgbf-1-2

Revision history for this message
Sandro Millien (rhass-deactivatedaccount) wrote :

If you face rebellion, then do this :
dpkg -r --force-remove-reinstreq libgbf-1-2

Revision history for this message
Martin Olsson (mnemo) wrote :

Thank you Sandro.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package anjuta - 2:2.26.0.0-0ubuntu1

---------------
anjuta (2:2.26.0.0-0ubuntu1) jaunty; urgency=low

  * New upstream version
  * debian/control.in:
    - Add Replaces/Conflicts for libgbf-1-common (LP: #338464).
  * Add libgda4-sqlite and exuberant-ctag as anjuta dependencies (LP: #339183).
  * Fix bdeps to match upstream configure checks:
    - Bump gdl to >= 2.26.0, gladeui to >= 3.6.0

 -- Christophe Sauthier <email address hidden> Sat, 07 Mar 2009 22:53:29 +0100

Changed in anjuta:
status: In Progress → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Not fixed yet:

Preparing to replace anjuta 2:2.24.2-1ubuntu1 (using .../anjuta_2%3a2.26.0.0-0ubuntu1_amd64.deb) ...
Unpacking replacement anjuta ...
dpkg: error processing /var/cache/apt/archives/anjuta_2%3a2.26.0.0-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/gbf-am-parse', which is also in package libgbf-1-2

Changed in anjuta (Ubuntu):
status: Fix Released → Triaged
summary: - [Jaunty] anjuta >2.25 needs Conflicts: libgbf-1-2
+ Needs Conflicts: libgbf-1-2
Changed in anjuta (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Evan Broder (broder) wrote :

The Conflicts/Replaces should have been with libgbf-1-2 instead of libgbf-1-common.

Here is a debdiff to fix the issue for Karmic.

Revision history for this message
Evan Broder (broder) wrote :

And here's one for a Jaunty SRU.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package anjuta - 2:2.26.0.0-0ubuntu3

---------------
anjuta (2:2.26.0.0-0ubuntu3) karmic; urgency=low

  * debian/control.in, debian/control:
    - Replace/Conflict libgbf-1-2 instead of libgbf-1-common (LP: #338464).
  * Thx to Evan Broder, sadly the debdiff was for an older package
    and didn't apply correctly

 -- Stephan Hermann <email address hidden> Mon, 15 Jun 2009 10:48:35 +0000

Changed in anjuta (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers