/usr/lib/libanjuta.so missing

Bug #191716 reported by Jonh Wendell on 2008-02-14
8
Affects Status Importance Assigned to Milestone
anjuta (Ubuntu)
Medium
Christophe Sauthier

Bug Description

Binary package hint: anjuta

The slink /usr/lib/libanjuta.so is missing in anjuta package. This causes lots of crashes in different places.

That slink is only available inside anjuta-dev package. This is weird.

Related branches

Jonh Wendell (wendell) wrote :
Sebastien Bacher (seb128) wrote :

you need to use replaces in the control

Maia Everett (linneris) wrote :

Is this really the right way to fix it? Maybe it would be better to fix the places that depend on libanjuta.so?

Changed in anjuta:
importance: Undecided → Medium
Changed in anjuta:
assignee: nobody → christophe.sauthier
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package anjuta - 2:2.3.5-0ubuntu1

---------------
anjuta (2:2.3.5-0ubuntu1) hardy; urgency=low

  * New upstream version
  * Remove *.so from anjuta-dev and put them in the anjuta binary
    (Fixes LP: #191716)

 -- Christophe Sauthier <email address hidden> Tue, 26 Feb 2008 17:54:12 +0100

Changed in anjuta:
status: New → Fix Released
Robert Bradford (robster) wrote :

This solution is wrong.

What does the submitter mean by "This causes lots of crashes in different places." Runtime crashes should not be caused by a missing symlink since the binary and plugins will be linked to the real name for the library.

The .so symlink is only used when linking a 3rd party plugin against Anjuta. A quick search through the Anjuta source code shows nothing to indicate that anything attempts to dlopen/g_module_open "libanjuta.so".

Where are the backtraces for these crashes?

Jonh Wendell (wendell) wrote :

What I remember is that the crash was caused by a plugin (or more than one plugin). Creating that slink fixed the problem.

Of course, I don't have the bt anymore...

Robert Bradford (robster) wrote :

Do you have a /usr/lib/glade3/modules/libgladeanjuta.so ?

And if so can you run "strings /usr/lib/glade3/modules/libgladeanjuta.so | grep libanjuta" against it. As well as dpkg -S.

Jonh Wendell (wendell) wrote :

No, this file doesn't exist...

Robert Bradford (robster) wrote :

I tracked this down to the subversion plugin's glade file. This has a <requires lib='anjuta' /> which then leads to libglade2 to try and open /usr/lib/libanjuta.so (through g_module_open)

So adding a symlink is a valid solution and at least we now know why ;-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers