anjuta crash when clicking on glade file

Bug #125343 reported by Jos Dehaes on 2007-07-11
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
anjuta (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: anjuta

I created a new C++ project with the wizard, I click on the generated glade file to change the GUI, and immediately anjuta crashes (happens every time) with following spewn on the console:

jos@hamerkeuh:~$ anjuta
** Message: Spawning script
Installing parsers: Asm, Asp, Awk, BETA, C, C++, C#, Fortran, Java, Lisp, Lua, Make, Pascal, Perl, PHP, Python, Ruby, Scheme, Sh, SML, SQL, Tcl, Vera, Verilog, Vim
    Asm:
    Asp:
    Awk:
    BETA:
    C:
    C++:
    C#:
    Fortran:
    Java:
    Lisp:
    Lua:
    Make:
    Pascal:
    Perl:
    PHP:
    Python:
    Ruby:
    Scheme:
    Sh:
    SML:
    SQL:
    Tcl:
    Vera:
    Verilog:
    Vim:
OPENING /home/jos/Projects/gtk-foobar/src/main.cc as C++ language file
*** glibc detected *** anjuta: double free or corruption (fasttop): 0x08eb5b68 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb71f98f1]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb71fcf50]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb737d8e1]
/usr/lib/libanjuta.so.0[0xb73285cb]
/usr/lib/libanjuta.so.0[0xb7329022]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x16c)[0xb7416a9c]
/usr/lib/libanjuta.so.0(anjuta_glue_factory_get_object_type+0x12f)[0xb73289af]
/usr/lib/libanjuta.so.0[0xb731ba7f]
/usr/lib/libanjuta.so.0(anjuta_plugin_manager_get_plugin_by_id+0xa2)[0xb731be52]
/usr/lib/anjuta/libanjuta-loader.so[0xb615dfe3]
/usr/lib/libanjuta.so.0(ianjuta_file_loader_load+0x72)[0xb7332792]
/usr/lib/anjuta/libanjuta-loader.so[0xb615c18f]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x49)[0xb7422179]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb7414742]
/usr/lib/libgobject-2.0.so.0[0xb7426695]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x823)[0xb7427af3]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb7427d99]
/usr/lib/libgtk-x11-2.0.so.0[0xb78c3c05]
/usr/lib/libgtk-x11-2.0.so.0(gtk_action_activate+0x51)[0xb78c4af1]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x49)[0xb7422179]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb7414742]
/usr/lib/libgobject-2.0.so.0[0xb7426695]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x823)[0xb7427af3]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb7427d99]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_activate+0x58)[0xb7b0ec38]
/usr/lib/libgtk-x11-2.0.so.0(gtk_menu_shell_activate_item+0x14a)[0xb79e03da]
/usr/lib/libgtk-x11-2.0.so.0[0xb79e245e]
/usr/lib/libgtk-x11-2.0.so.0[0xb79d791d]
/usr/lib/libgtk-x11-2.0.so.0[0xb79d0732]
/usr/lib/libgobject-2.0.so.0[0xb7412f59]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb7414742]
/usr/lib/libgobject-2.0.so.0[0xb7426cd3]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6d6)[0xb74279a6]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb7427d99]
/usr/lib/libgtk-x11-2.0.so.0[0xb7b09378]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0x1ae)[0xb79c863e]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x3c2)[0xb79c9a12]
/usr/lib/libgdk-x11-2.0.so.0[0xb7701c3a]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x17c)[0xb737610c]
/usr/lib/libglib-2.0.so.0[0xb737954f]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0xb73798f9]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xb79c9ea4]
anjuta(main+0x35d)[0x805493d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb71a6030]
anjuta[0x804e8e1]
======= Memory map: ========
08048000-08057000 r-xp 00000000 08:02 590998 /usr/bin/anjuta
08057000-08058000 rwxp 0000e000 08:02 590998 /usr/bin/anjuta
08058000-08eec000 rwxp 08058000 00:00 0 [heap]
b323f000-b3245000 r-xp 00000000 08:02 686182 /usr/lib/anjuta/libanjuta-language-cpp-java.so
b3245000-b3246000 rwxp 00005000 08:02 686182 /usr/lib/anjuta/libanjuta-language-cpp-java.so
b3246000-b3247000 rwxp b3246000 00:00 0
b3247000-b328b000 r-xp 00000000 08:02 784931 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
b328b000-b32d2000 r-xp 00000000 08:02 784934 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
b32d2000-b33fb000 r-xp 00000000 08:02 686119 /usr/lib/anjuta/libanjuta-editor.so
b33fb000-b33fe000 rwxp 00129000 08:02 686119 /usr/lib/anjuta/libanjuta-editor.so
b33fe000-b33ff000 rwxp b33fe000 00:00 0
b33ff000-b341e000 r-xp 00000000 08:02 1158830 /usr/share/fonts/truetype/msttcorefonts/Trebuchet_MS_Bold.ttf
b341e000-b3432000 r-xp 00000000 08:02 685514 /usr/lib/gnome-build-1.0/backends/libgbf-am.so
b3432000-b3433000 rwxp 00014000 08:02 685514 /usr/lib/gnome-build-1.0/backends/libgbf-am.so
b3433000-b3434000 ---p b3433000 00:00 0
b3434000-b3c34000 rwxp b3434000 00:00 0
b3c34000-b3c67000 r-xp 00000000 08:02 1143571 /usr/lib/firefox/components/libmork.so
b3c67000-b3c6a000 rwxp 00032000 08:02 1143571 /usr/lib/firefox/components/libmork.so
b3c6a000-b3cAborted (core dumped)
jos@hamerkeuh:~$

Jos Dehaes (jos-dehaes) wrote :

Looking in the plugins dialog with the only user activatable plugins checkbox off, I can see the glade plugin is not loaded. In /usr/lib/anjuta, there is an anjuta-glade.plugin, but not the .so file.

Maybe a packaging problem? I can see more of these plugins that are missing the .so.

Jos Dehaes (jos-dehaes) wrote :

Forgot to mention, this is anjuta 2.2.0 on gutsy.

Jos Dehaes (jos-dehaes) wrote :

seems indeed a packaging error. Anjuta should build-dep on some more stuff, like libsvn-dev, libapr1-dev, libaprutil1-dev, libneon26-dev, graphviz-dev, binutils-dev, libgladeui-1-dev

with these, the configure script agrees to compile all plugins.

Anjuta should also depend on glade-3, and maybe recommend some more things (devhelp springs to mind)

Jos Dehaes (jos-dehaes) wrote :

sorry, devhelp is already recommended. Anjuta package also recommends the autotools suite, but should it not really depend on it? Otherwhise, the project wizzard can not generate code. I had to install autogen by hand to get past the new project wizzard.

Jos Dehaes (jos-dehaes) wrote :

The glade plugin does not compile. I'm trying to figure out what the API change is to get this fixed.

Jos Dehaes (jos-dehaes) wrote :

After talking to one of the glade3 devs, it seems that the #if for the gladeui version is not correct, it refers to an API that is not yet in the gladeui in gutsy (it is not even released yet, will be in 3.3.2).

I have made a new -diff that corrects this problem and works here with the shipped gladeui (3.3.1).

Stefano Angeleri (weltall) wrote :

i can confirm the same problems experienced as you even the same double free or corruption

Vytas (vytas) wrote :

Same here

Changed in anjuta:
status: New → Confirmed
Rolex (rolex-ukr) wrote :

Confirm, i have exactly same problem when i try to create new glade file.

Ray W. Johnson (raywjohnson) wrote :
Download full text (20.6 KiB)

Greetings, I am adding the output of the crash as it happens on my system. This bug has something to do with the "default" app that Anjuta tries to run when you access a .glade file. If you double click the .glade file, right click and select Open, right click and select Open With->Glade interface designer (first item), you get the crash. BUT, if you select the second item: Open With-> Glade Interface Designer (note capitalization) it works as expected. (I attached a screen capture to illustrate).

anjuta
** Message: Spawning script
*** glibc detected *** anjuta: double free or corruption (fasttop): 0x08a00c28 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb726dd65]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb7271800]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb73f3961]
/usr/lib/libanjuta.so.0[0xb739e57b]
/usr/lib/libanjuta.so.0[0xb739efd2]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x16c)[0xb748eaec]
/usr/lib/libanjuta.so.0(anjuta_glue_factory_get_object_type+0x12f)[0xb739e95f]
/usr/lib/libanjuta.so.0[0xb7391a2f]
/usr/lib/libanjuta.so.0(anjuta_plugin_manager_get_plugin_by_id+0xa2)[0xb7391e02]
/usr/lib/anjuta/libanjuta-loader.so[0xb5da2fc3]
/usr/lib/libanjuta.so.0(ianjuta_file_loader_load+0x72)[0xb73a8742]
/usr/lib/anjuta/libanjuta-file-manager.so[0xb4b637c8]
/usr/lib/anjuta/libanjuta-file-manager.so[0xb4b65794]
/usr/lib/libgtk-x11-2.0.so.0(_gtk_marshal_VOID__BOXED_OBJECT+0x5d)[0xb7a2a49d]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb748c772]
/usr/lib/libgobject-2.0.so.0[0xb749d323]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x8c7)[0xb749e847]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb749ea09]
/usr/lib/libgtk-x11-2.0.so.0(gtk_tree_view_row_activated+0x61)[0xb7b25251]
/usr/lib/libgtk-x11-2.0.so.0[0xb7b355bd]
/usr/lib/libgtk-x11-2.0.so.0(_gtk_marshal_BOOLEAN__BOXED+0x5e)[0xb7a2c1de]
/usr/lib/libgobject-2.0.so.0[0xb748af89]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb748c772]
/usr/lib/libgobject-2.0.so.0[0xb749d973]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x68f)[0xb749e60f]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb749ea09]
/usr/lib/libgtk-x11-2.0.so.0[0xb7b4a498]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0x14f)[0xb7a2536f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x307)[0xb7a26587]
/usr/lib/libgdk-x11-2.0.so.0[0xb7772b9a]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x17c)[0xb73ec11c]
/usr/lib/libglib-2.0.so.0[0xb73ef55f]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0xb73ef909]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xb7a269e4]
anjuta[0x805413d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb721a050]
anjuta[0x804e101]
======= Memory map: ========
08048000-08056000 r-xp 00000000 08:06 16385849 /usr/bin/anjuta
08056000-08057000 rw-p 0000e000 08:06 16385849 /usr/bin/anjuta
08057000-08a9c000 rw-p 08057000 00:00 0 [heap]
b2c00000-b2c21000 rw-p b2c00000 00:00 0
b2c21000-b2d00000 ---p b2c21000 00:00 0
b2d20000-b2d2a000 r-xp 00000000 08:06 372747 /lib/libgcc_s.so.1
b2d2a000-b2d2b000 rw-p 0000a000 08:06 372747 /lib/libgcc_s.so.1
b2d3d000-b302a000 r--p 00000000 08:06 16634885 /usr/share/fonts/truetype/baekmuk/dotum.ttf...

Changed in anjuta:
importance: Undecided → Medium
Ricardo L. Febrero (rlfebrero) wrote :

I can confirm this bug on my machine, just as you told. Waiting for a patch, folks...

Ricardo L. Febrero (rlfebrero) wrote :

I can confirm this bug on my machine, just as you told. Waiting for a package upgrade, folks...

Stefano Angeleri (weltall) wrote :

it works on latest anjuta shipped with hardy so the gutsy package maybe should be fixed accordly

  • unnamed Edit (839 bytes, text/html; charset=ISO-8859-1)

Yes, it works on Hardy!!

2008/5/1 weltall <email address hidden>:

> it works on latest anjuta shipped with hardy so the gutsy package maybe
> should be fixed accordly
>
> --
> anjuta crash when clicking on glade file
> https://bugs.launchpad.net/bugs/125343
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Néstor Amigo Cairo
+34 687 96 74 81
<email address hidden>

Ray W. Johnson (raywjohnson) wrote :

Well, I guess it is not working for everyone.

After I upgraded to Hardy, the first thing I tried was Anjuta. I was very pleased to see it that Glade was a plugin! I started a new test project and double clicked the .glade file. I was presented with a dialog (attached) that asked which plugin to use. I selected Glade and continue to test. (I do not recall if I clicked "remember this selection"). I worked on my test project for a while without problems. Then close Anjuta.

The next time I launched Anjuta, I got the Open with: plugin dialog again. This time I did click "remember this selection" and selected Glade. Then Anjuta went bye bye. Now when I launch it, I get nothing (just a quick flash on the panel/window list).

I removed the references to the .glade file (from ~/.anjuta/sesson/anjuta.session and ~/Projects/gtk-test/.anjuta/session/anjuta.session, still broken. I removed both .anjuta directories, still broken. In removed Glade2 and Anjuta, then reinstalled Anjuta, still broken.

On a positive note: I can run Anjuta as root. So, I created a Test user and tried to run Anjuta (no options and with -f / -n / -f -n):
result:
No protocol specified
cannot open display:
Run 'anjuta --help' to see a full list of available command line options.

I also tried various combinations of the other command line options...

Still broken... :(

--RayJ

Ray W. Johnson (raywjohnson) wrote :

Update!

I just tried (on my regular user account): anjuta -c

And it worked!

Now I will see if I can break it again.

--RayJ

Vytas (vytas) wrote :

In Intrepid latest Anjuta is even more stable, I couldnt reproduce anything like this

Changed in anjuta:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers