Clicking on camera & microphone settings crashes app on mako & flo

Bug #1553657 reported by Michael Terry on 2016-03-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
John McAleely
android (Ubuntu)
Critical
Simon Fels
libhybris (Ubuntu)
Undecided
Simon Fels
webbrowser-app (Ubuntu)
Critical
Olivier Tilloy

Bug Description

On latest RC-proposed (255?) on my mako.

I go to Settings, Privacy & Permissions, then click on Camera & Microphone. Get a crash or freeze each time I've tried it. (but no crash file?)

Olivier Tilloy (osomon) wrote :

@Michael: anything of interest in the app’s log file? ($HOME/.cache/upstart/application-legacy-webbrowser-app-.log)

Can you still reproduce the issue? Unfortunately I don’t have a nexus 4, and the feature works well on my krillin and on my arale, so it might very well be a device-specific issue, in which case we’ll need someone with a device to look into it.

Changed in webbrowser-app (Ubuntu):
status: New → Incomplete
Michael Terry (mterry) wrote :

I can still reproduce. On two separate makos (both running rc-proposed, haven't tried OTA 9.1). Nothing at all is printed in the log when this happens. :(

Although this time, I saw a crash file being generated (and uploaded, though I don't see it in errors.u.c yet). So I'm attaching it. But it doesn't have a core dump or stack trace in it...

Changed in webbrowser-app (Ubuntu):
status: Incomplete → New
Andrew Hayzen (ahayzen) wrote :

I can confirm this issue on mako, therefore I have set this bug to confirmed.

Also when I go to a website that uses webrtc such as [0] I get the following output and then a crash, not sure if it is linked or a separate issue?
Received signal 4 <unknown> 0000b61138d8

FWIW the webrtc site [0] did used to work for the microphone on mako.

0 - https://test.webrtc.org/

$ system-image-cli -i
current build number: 260
device name: mako
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-03-13 11:52:42
version version: 260
version ubuntu: 20160312
version device: 20160304.2
version custom: 20160201-5-vivid

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) on 2016-03-15
Changed in webbrowser-app (Ubuntu):
importance: Undecided → Critical
Olivier Tilloy (osomon) wrote :

I am able to reproduce the crash on nexus 7 with the latest rc-proposed image.

summary: - Clicking on camera & microphone settings crashes app
+ Clicking on camera & microphone settings crashes app on mako & flo
Olivier Tilloy (osomon) wrote :

Backtrace:

#0 0x00000000 in ?? ()
#1 0xad081432 in android_camera_get_device_info (n1=0, n2=0x9acefaac, n3=<optimized out>) at camera.c:34
#2 0xada541c8 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#3 0xada54452 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#4 0xada8e872 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#5 0xadaa3d12 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#6 0xadaa3f8e in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#7 0xadaa437c in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#8 0xadaa55e8 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#9 0xadab175c in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#10 0xadaa3970 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#11 0xadac23de in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#12 0xadabff92 in ?? () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#13 0xb5bf5490 in start_thread (arg=0x0) at pthread_create.c:335
#14 0xb5c97c4c in ?? () at ../sysdeps/unix/sysv/linux/arm/clone.S:89 from /lib/arm-linux-gnueabihf/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Olivier Tilloy (osomon) on 2016-03-15
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2016-03-15
Changed in libhybris (Ubuntu):
assignee: nobody → Simon Fels (morphis)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libhybris (Ubuntu):
status: New → Confirmed
Richard Somlói (ricsipontaz) wrote :

Nexus 4, rc-proposed channel, the same issue.

.cache/upstart/application-legacy-webbrowser-app-.log:

Loading module: 'libubuntu_application_api_touch_mirclient.so.3.0.0'
libust[17814/17849]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17849]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17850]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17850]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:958)
Input device added: "keypad_8064" "/dev/input/event1" QFlags(0x1)
Input device added: "pmic8xxx_pwrkey" "/dev/input/event0" QFlags(0x1)
Input device added: "apq8064-tabla-snd-card Button Jack" "/dev/input/event3" QFlags()
Input device added: "apq8064-tabla-snd-card Headset Jack" "/dev/input/event4" QFlags(0x20)
Input device added: "touch_dev" "/dev/input/event2" QFlags(0x8)
Input device added: "hs_detect" "/dev/input/event5" QFlags(0x1|0x20)
ubuntumirclient: Got invalid serialized mime data. Ignoring it.
shm_open() failed: Permission denied
qml: Loaded 5 UA override(s) from file:///usr/lib/arm-linux-gnueabihf/qt5/qml/Ubuntu/Web/ua-overrides-mobile.js
[0318/143227:ERROR:layer_tree_host_impl.cc(2263)] Forcing zero-copy tile initialization as worker context is missing
libust[17814/17849]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17850]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17849]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17850]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17849]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:958)
libust[17814/17850]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:958)

maybe it will be useful

Simon Fels (morphis) wrote :

libhybris/android related problem. Nothing with camera-app

Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
Simon Fels (morphis) wrote :

We're clearly missing symbols in libcamera_compat_layer.so in the device tarball on the Android side but I don't have a clue yet why. A local build of the package we have in the overlay ppa show me that the symbols ends up in the .so. Doing a no-change rebuild in silo 38 (https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-038/) now.

Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in canonical-devices-system-image:
importance: Undecided → Critical
assignee: nobody → John McAleely (john.mcaleely)
milestone: none → ww08-2016
Simon Fels (morphis) on 2016-03-21
Changed in android (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Simon Fels (morphis)
Changed in libhybris (Ubuntu):
status: Confirmed → Invalid
Olivier Tilloy (osomon) wrote :

The bug seems to be affecting frieza as well (just tested on the latest rc-proposed image). Would the changes to the android package fix it on that device too, by any chance?

Simon Fels (morphis) wrote :

@Olivier: No, the android package doesn't have any effect on frieza. But we've just merged an upgrade for platform-api/libhybris for frieza, which should fix the same problem. Alfonso will release a new image on rc-proposed with this change included later today.

Simon Fels (morphis) wrote :
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Simon Fels (morphis) on 2016-04-04
Changed in android (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers