Ubuntu

adb shell not available on newly created image

Reported by Jamie Strandboge on 2014-01-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
android (Ubuntu)
Undecided
Unassigned

Bug Description

I installed 0.1+14.04.20140110-0ubuntu1 with ubuntu-emulator-runtime 20140115-0148-0ubuntu1 today, then ran the following commands:

$ sudo ubuntu-emulator create trusty-proposed
$ ubuntu-emulator run trusty-proposed

I waited until I saw unity8 in the emulator (ie, a long time) and then tried to do 'adb shell', but no devices were available. I tried re-running the image several times and never could get 'adb shell' to work.

Workaround:
I then restarted the adbd server on the host with: 'adb kill-server ; adb start-server'. After this, 'adb devices' shows the emulator and I can connect like normal.

description: updated
description: updated
David Planella (dpm) wrote :

I had this same problem and I noticed the following while booting:

init: cannot find '/sbin/adbd', disabling 'adbd'

It seems during early boot the adb daemon was running for a while in the emulator image, and then in stopped working:

$ adb devices
List of devices attached
emulator-5554 offline

$ adb devices
List of devices attached

Changed in goget-ubuntu-touch (Ubuntu):
status: New → Confirmed
Sergio Schvezov (sergiusens) wrote :

btw, this happens on real devices too ;-)

I'll look into root causing

Sergio Schvezov (sergiusens) wrote :

@dpm, I missed your comment wrt
init: cannot find '/sbin/adbd', disabling 'adbd'

that's perfectly fine, adbd is disabled in the lxc android container

@jdstand do you still see this issue?

affects: goget-ubuntu-touch (Ubuntu) → android (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers