Newer version of adb needed for nexus 5

Bug #1402195 reported by Ralf Hildebrandt on 2014-12-13
168
This bug affects 38 people
Affects Status Importance Assigned to Milestone
android-tools (Debian)
Fix Released
Unknown
android-tools (Ubuntu)
High
Unassigned
Vivid
High
Unassigned

Bug Description

When adb sideloading 5.0.0 -> 5.0.1, the recovery on a nexus 5 requires at least adb 1.0.32

$ adb version
Android Debug Bridge version 1.0.31

:(

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: android-tools-adb 4.2.2+git20130218-3ubuntu36
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Dec 13 14:47:38 2014
InstallationDate: Installed on 2014-02-07 (308 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: android-tools
UpgradeStatus: Upgraded to utopic on 2014-11-08 (34 days ago)

Revision history for this message
Ralf Hildebrandt (ralf-hildebrandt) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in android-tools (Ubuntu):
status: New → Confirmed
Changed in android-tools (Ubuntu):
importance: Undecided → High
Revision history for this message
Nicolae Istratii (tallman9) wrote :

As a temporary fix for those in need.
Download from official google source just the archived folder with adb https://skia.googlesource.com/skia/+archive/cd048d18e0b81338c1a04b9749a00444597df394/platform_tools/android/bin/linux.tar.gz
unarchive and use from inside that folder "./adb" or or copy to /usr/bin/adb .

Changed in android-tools (Ubuntu):
status: Confirmed → Triaged
tags: added: vivid
Revision history for this message
Norbert (asterix52) wrote :

The temporay fix dosen*t work for me (Ubuntu 15.04 x64):

~/google$ ./adb
./adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Revision history for this message
Alfredo Hernández (aldomann) wrote :

The workaround worked just fine to install nakasi LRX22G from LRX21P (Ubuntu GNOME 14.10 x64).

Revision history for this message
diverbelow (groovygravy10-gmail) wrote :

I download and untarred https://skia.googlesource.com/skia/+archive/cd048d18e0b81338c1a04b9749a00444597df394/platform_tools/android/bin/linux.tar.gz

Since I am running 14.04 x64, I kept getting: command not found: ./adb.

The workaround I found is to install the ia32-libs and now I have the updated version.

Revision history for this message
PHP Learner (learnerphp) wrote :

I downloaded and extracted https://skia.googlesource.com/skia/+archive/cd048d18e0b81338c1a04b9749a00444597df394/platform_tools/android/bin/linux.tar.gz
My system is running Ubuntu 14.04 x64. If I run adb (1.0.31) sideload filename.zip, it returns:
"You need adb 1.0.32 or newer to sideload to this device." on my device and "error: protocol fault (no status)" on my PC command line terminal.
and If run adb (1.0.32, downloaded version) it returns:
"Failed" on my device and "Total xfer: 0.00x" on my PC command line terminal.

Revision history for this message
Charwinger21 (holy-hell-h) wrote :

1.0.32 is also needed to upgrade from 5.0 or 5.0.1 to 5.1. Old version in apt-get repository is now preventing users from upgrading to the next full release of Android (unless they go hunting for ADB elsewhere or are running fully stock).

Is there anything technical holding up the update?

Revision history for this message
clickwir (clickwir) wrote :

Running Kubuntu 14.10 and only have adb 1.0.31. Can't update my Nexus 4 to 5.0.1 because it requires at least adb 1.0.32.

Changed in android-tools (Ubuntu Vivid):
status: Triaged → Won't Fix
summary: - Newer versions available
+ Newer version of adb needed for nexus 5
Revision history for this message
Theo Nolte (theo-nolte) wrote :

Thanks for the workaround. Extracting the above binary and installing libstdc++6:i386 did the trick for me on Ubuntu 15.04 x64.

As Lollipop becomes more and more widespread, it is a shame the package is not updated. Tracking down the problem and finding this thread took me half a day.

Revision history for this message
vinibali (vinibali) wrote :

Adb's sideload is a relly important function, please update the official packages.

Revision history for this message
Aaron Honeycutt (aaronhoneycutt) wrote :

We have the same version in wily right now and we really need this feature.

Revision history for this message
Eero (eero+launchpad) wrote :

I can't upgrade my phone to Marshmallow due to this error.

Revision history for this message
Eero (eero+launchpad) wrote :

Workaround in comment #3 worked for me.

Revision history for this message
H.-Dirk Schmitt (dirk-computer42) wrote :

A lot of recent devices are affected - for my the Samsung Note 8 with Team Win Recovery.

tags: added: trusty
Changed in android-tools (Debian):
status: Unknown → New
Changed in android-tools (Debian):
status: New → Fix Released
Revision history for this message
Austin (vidplace7) wrote :

I'd also really appreciate an official package update, until then I'm working on a PPA for this

Revision history for this message
Alex10336 (ap10336) wrote :

It's not « Nexus 5 » specific issue.
Looking official android sdk documentation: ( https://developer.android.com/tools/help/adb.html#Enabling )
quote:
----
Note: When you connect a device running Android 4.2.2 or higher to your computer, the system shows a dialog asking whether to accept an RSA key that allows debugging through this computer. This security mechanism protects user devices because it ensures that USB debugging and other adb commands cannot be executed unless you're able to unlock the device and acknowledge the dialog. This requires that you have adb version 1.0.31 (available with SDK Platform-tools r16.0.1 and higher) in order to debug on a device running Android 4.2.2 or higher.
----

And obviously, android 5.+/5.1.1 seem to need this 1.0.32 version of adb.

I've an android 5.1.1, and need adb 1.0.32 to show my device (not a nexus)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.