update to openjdk 11 in 18.04 LTS (android-tools packages)

Bug #1819448 reported by Matthias Klose on 2019-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
android-framework-23 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-art (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-build (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-dalvik (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-development (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-external-boringssl (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-external-libselinux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-external-libunwind (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-frameworks-base (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-frameworks-data-binding (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-frameworks-native (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-libcore (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-libnativehelper (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-system-core (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-system-extras (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-system-tools-aidl (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
android-platform-tools-apksig (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
android-sdk-meta (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
apktool (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
cava (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
dummydroid (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
enjarify (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
f2fs-tools (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
libscout (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
libsmali-java (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
wala (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Follow-up to Bug #1814133: update various android tools packages to openjdk 11 in 18.04 LTS

NOTE TO SRU MEMBERS: The packages are to be released into bionic-security ONLY. This will be done/decided by the security team.

description: updated
Changed in android-framework-23 (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-build (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-dalvik (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-development (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-external-libselinux (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-external-libunwind (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-frameworks-base (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-frameworks-data-binding (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-frameworks-native (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-libcore (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-libnativehelper (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-system-core (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-system-extras (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-system-tools-aidl (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-tools-apksig (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-sdk-meta (Ubuntu Bionic):
status: New → Fix Committed
Changed in apktool (Ubuntu Bionic):
status: New → Fix Committed
Changed in enjarify (Ubuntu Bionic):
status: New → Fix Committed
Changed in f2fs-tools (Ubuntu Bionic):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

All packages have been uploaded and approved for bionic-proposed.

Changed in libscout (Ubuntu Bionic):
status: New → Fix Committed
Changed in libsmali-java (Ubuntu Bionic):
status: New → Fix Committed
Changed in wala (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-art (Ubuntu Bionic):
status: New → Fix Committed
Changed in android-platform-external-boringssl (Ubuntu Bionic):
status: New → Fix Committed
Changed in cava (Ubuntu Bionic):
status: New → Fix Committed
Changed in dummydroid (Ubuntu Bionic):
status: New → Fix Committed
William Grant (wgrant) wrote :

I've removed android-sdk-meta 25.0.0+10~18.04 from bionic-proposed and cosmic-proposed, as it produced binaries with the same version as are already in disco, e.g. android-sdk-platform-tools-common 27.0.0+10.

Changed in android-sdk-meta (Ubuntu Cosmic):
status: New → Fix Committed
Changed in android-platform-tools-apksig (Ubuntu Cosmic):
status: New → Fix Committed
Amr Ibrahim (amribrahim1987) wrote :

Please, could android-platform-system-core 1:8.1.0+r23-5 be backported to 18.04 LTS, instead of 1:8.1.0+r23-4, it fixes two packaging bugs:

android-platform-system-core (1:8.1.0+r23-5) unstable; urgency=medium

  * Depends: android-platform-system-core-headers for symlinked headers
    (Closes: #924159)
  * fastboot Recommends: android-sdk-platform-tools for mke2fs
    (Closes: #924591)
  * add lintian-overrides for test data .so binaries

 -- Hans-Christoph Steiner <email address hidden> Mon, 18 Mar 2019 10:49:41 +0000

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-art - 8.1.0+r23-3~18.04

---------------
android-platform-art (8.1.0+r23-3~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-art (8.1.0+r23-3) unstable; urgency=medium

  * Put all LDFLAGS that link libraries at the end of the command line. This
    fixes FTBFS on Ubuntu because `--as-needed` is used by default.
    (Closes: #916250) Thanks to Logan Rosen.
  * ucontext.patch: Fix a type mismatch causing FTBFS on armhf
  * Use GCC to compile assembly code on armhf as Clang does not support the
    `ADRL` instruction. See <https://bugs.llvm.org/show_bug.cgi?id=24350>.

android-platform-art (8.1.0+r23-2) unstable; urgency=medium

  * Use my DD account in Uploaders
  * Disable libart and its users on MIPS as ART only supports MIPSr6 while
    Debian is by default MIPSr2
  * Fix FTBFS on i386
  * Use Clang only for libart and its users while GCC for the rest. This allows
    `dmtracedump` to be released on all architectures.

android-platform-art (8.1.0+r23-1) unstable; urgency=low

  * Initial release (Closes: #913785)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:28:32 +0100

Changed in android-platform-art (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-external-libselinux - 8.1.0+r23-2~18.04

---------------
android-platform-external-libselinux (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-external-libselinux (8.1.0+r23-2) unstable; urgency=medium

  * Release to unstable
  * Install README.android to /usr/share/doc

android-platform-external-libselinux (8.1.0+r23-1) experimental; urgency=medium

  * Install READMEs to the main packages rather than the dev ones

  [ Saif Abdul Cassim ]
  * Track new upstream platform/external/selinux in AOSP
  * Switch to Salsa Vcs

  [ Chandramouli Rajagopalan ]
  * Add myself to Uploaders
  * Track new upstream platform/external/selinux in AOSP

  [ Umang Parmar ]
  * Add myself to Uploaders
  * Build libsepol and libsepol-dev binary packages
  * Use 'debian/clean' to simplify the build scripts
  * Fix FTCBFS (thanks to Helmut Grohne) (Closes: #864563)

  [ Hans-Christoph Steiner ]
  * New Upstream release
  * d/rules: Remove get-orig-source

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:46:49 +0100

Changed in android-platform-external-libselinux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-frameworks-base - 1:8.1.0+r23-3~18.04

---------------
android-platform-frameworks-base (1:8.1.0+r23-3~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-frameworks-base (1:8.1.0+r23-3build1) disco; urgency=medium

  * No-change rebuild against latest protobuf

android-platform-frameworks-base (1:8.1.0+r23-3) unstable; urgency=medium

  * Release to unstable
  * Fix the install path of the headers of libandroidfw
  * Annotate all packages with Multi-Arch (Closes: #895820)

android-platform-frameworks-base (1:8.1.0+r23-2) experimental; urgency=medium

  * Properly declare target dependencies in d/rules, thus fixing a FTBFS when
    building binary-indep.
  * d/aapt2.mk: Remove macros that don't apply to aapt2

android-platform-frameworks-base (1:8.1.0+r23-1) experimental; urgency=medium

  * Standards-Version => 4.2.1
  * Mark the manpage of `split-select` outdated

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Do not exclude some test data during get-orig-source
  * Switch to Salsa

  [ Umang Parmar ]
  * Switch to aapt2 to compile framework-res.apk
  * Use debian/clean to simplify build scripts
  * Add myself to Uploaders

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:01:52 +0100

Changed in android-platform-frameworks-base (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-frameworks-data-binding - 2.2.2-3~18.04.1

---------------
android-platform-frameworks-data-binding (2.2.2-3~18.04.1) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.
  * Build-depend on libicu4j-java.

android-platform-frameworks-data-binding (2.2.2-3) unstable; urgency=medium

  * Team upload.
  * Added a dependency on JAXB to fix the build failure with Java 9
    (Closes: #894287)
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:08:21 +0100

Changed in android-platform-frameworks-data-binding (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-system-extras - 8.1.0+r23-2~18.04

---------------
android-platform-system-extras (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-system-extras (8.1.0+r23-2) unstable; urgency=medium

  * Release to unstable

android-platform-system-extras (8.1.0+r23-1) experimental; urgency=medium

  [ Hans-Christoph Steiner ]
  * New upstream release
  * d/copyright: Use HTTPS URLs
  * Switch to Salsa

  [ Saif Abdul Cassim ]
  * New package android-sdk-ext4-utils providing:
    * mkuserimg
    * ext4fixup
    * make_ext4fs
    * This package is replacing the obsolete android-tools-fsutils

  [ Kai-Chung Yan ]
  * Debhelper level => 11
  * d/rules: Use dh-auto-build instead of plain make thanks to Helmut Grohne
  * Fix the conflicting types errors (Closes: #892170)
  * Standards-Version => 4.2.1

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:45:19 +0100

Changed in android-platform-system-extras (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-tools-apksig - 0.8-2ubuntu1~18.04

---------------
android-platform-tools-apksig (0.8-2ubuntu1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-tools-apksig (0.8-2ubuntu1) disco; urgency=medium

  * Compile for Java 8: (LP: #1821235)
    - debian/rules: the parameter '-target 8' must be set to get got compiled
      for OpenJDK 8, setting '--release 8' is the best way as it guarantees
      that the whole '-source/-target/-bootclasspath' triad is correctly set.

android-platform-tools-apksig (0.8-2) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Removed the alternative build dependency on openjdk-8-jdk

  [ Kai-Chung Yan ]
  * Install Maven artifacts of `apksig.jar`
  * Standards-Version => 4.2.1
  * uscan: Watch for `gradle-*` tags instead of `android-*_r*`
  * Instal Maven artifacts for `apkgsig.jar`
  * Remove unused build-dependencies: antlr3 groovy maven-debian-helper
  * apksigner now requires JRE >= 8 since it is compiled on source level 8
  * Add myself to Uploaders
  * Install `apksigner` into Android SDK home

  [ Hans-Christoph Steiner ]
  * Use real URLs for Vcs-Git, not ones that redirect
  * Add autopkgtest for APK verification
  * Add GitLab CI support

 -- Tiago Stürmer Daitx <email address hidden> Sat, 23 Mar 2019 00:19:26 +0000

Changed in android-platform-tools-apksig (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-sdk-meta - 25.0.0+10~18.04.2

---------------
android-sdk-meta (25.0.0+10~18.04.2) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-sdk-meta (25.0.0+10) unstable; urgency=medium

  * drop packages with impossible arches from meta Depends

android-sdk-meta (25.0.0+9) unstable; urgency=medium

  [ Jeremy Bicha ]
  * android-sdk-platform-tools: Don't require adb or fastboot on mips*

  [ 殷啟聰 | Kai-Chung Yan ]
  * Update versions of SDK components to match upstream

  [ Hans-Christoph Steiner ]
  * fix missing idProduct values in udev rules
  * add autopkgtest for udev rules
  * add autopkgtest for `apt-get install android-tools-adb`
  * add debian/.gitlab-ci.yml to run tests on GitLab CI
  * update alternative Depends: for current Java versions (Closes: #922555)
  * purge dependencies not in buster

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 16:12:23 +0100

Changed in android-sdk-meta (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cava - 0.6.0-1~18.04

---------------
cava (0.6.0-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

cava (0.6.0-1) unstable; urgency=medium

  * Initial release

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:44:24 +0100

Changed in cava (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dummydroid - 1.2-2~18.04

---------------
dummydroid (1.2-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

dummydroid (1.2-2) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on junit (Closes: #871343)
  * Don't install the jar twice in the package
  * Build with the DH sequencer instead of CDBS
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Moved the .prop files to debian/props/

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:36:09 +0100

Changed in dummydroid (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f2fs-tools - 1.11.0-1.1~18.04

---------------
f2fs-tools (1.11.0-1.1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

f2fs-tools (1.11.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix "missing Breaks+Replaces: libf2fs-dev (<< 1.11)":
    add them in debian/control, thanks Andreas Beckmann.
    (Closes: #907975)

f2fs-tools (1.11.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #904286)
     - add sg_write_buffer for UFS firmware update in Android
     - wanted_sector_size to specify sector size explicitly
     - support fsverity feature bit
     - support lost+found feature
  * Install the library link files in /usr/lib where they belong
  * Replace the libf2fs0 package with libf2fs5 and libf2fs-format4
  * Fixed missing libblkid dependency in the shared library
  * Updated Standards compliance to 4.2.0
  * Added Theodore Ts'o as an uploader for the package

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:37:16 +0100

Changed in f2fs-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libscout - 2.3.2-1~18.04

---------------
libscout (2.3.2-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

libscout (2.3.2-1) unstable; urgency=medium

  * New upstream release (Closes: #876764)
  * use upstream's build.gradle
  * add new example file for building profiles of tracker libraries
  * convert to javahelper package
  * add smoke check autopkgtest
  * remove maven-repo-helper, this is a CLI tool, not a lib

libscout (2.1.0-1) unstable; urgency=medium

  * New upstream release

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:28:14 +0100

Changed in libscout (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsmali-java - 2.2.6-1~18.04

---------------
libsmali-java (2.2.6-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

libsmali-java (2.2.6-1) unstable; urgency=medium

  * New upstream version

libsmali-java (2.2.5-1) unstable; urgency=medium

  * New upstream version

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:24:34 +0100

Changed in libsmali-java (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-framework-23 - 6.0.1+r72-5~18.04

---------------
android-framework-23 (6.0.1+r72-5~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-framework-23 (6.0.1+r72-5) unstable; urgency=medium

  * Fix FTBFS with Java 9+ (Closes: #894285)
  * add basic autopkgtest to check that class files are in the JAR

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:29:21 +0100

Changed in android-framework-23 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-build - 1:8.1.0+r23-2~18.04

---------------
android-platform-build (1:8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-build (1:8.1.0+r23-2) unstable; urgency=medium

  * Move javahelper from Build-Depends-Indep to Build-Depends. Debhelper plugins
    must always be installed.
  * Pre-bake manpages using Pandoc during dev-time. Pandoc as a build-dependency
    is sometimes unreliable and unnecessary because Haskell uses static linking.

android-platform-build (1:8.1.0+r23-1) unstable; urgency=medium

  [ Kai-Chung Yan ]
  * New upstream release
  * Use dh_auto_build to invoke makefiles (thanks to Helmut Grohne)
  * Standards-Version => 4.2.1: Remove get-orig-source
  * Remove old package android-platform-build-headers (Closes: #908801)
  * Update manpages with new contents and more appropriate formatting
  * Build signapk with apksig
  * d/copyright: Exclude minified JavaScript

  [ Hans-Christoph Steiner ]
  * Switch to Salsa
  * d/copyright: Use HTTPS URLs

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:27:55 +0100

Changed in android-platform-build (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-dalvik - 8.1.0+r23-2~18.04

---------------
android-platform-dalvik (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-dalvik (8.1.0+r23-2) unstable; urgency=medium

  * Install manpages pre-baked by pandoc. Pandoc as a B-D is thus unnecessary.
  * Fix FTCBFS by using dh_auto_build to invoke makefiles
  * Remove unused build-dependency libjarajr-java

android-platform-dalvik (8.1.0+r23-1) unstable; urgency=medium

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Switch to Salsa
  * Remove get-orig-source
  * Fix missing-notice-file-for-apache-license

  [ Kai-Chung Yan ]
  * Standards-Version => 4.2.1
  * No longer build dmtracedump or dexdump in this package. They have been moved
    to android-platform-art.
  * Annotate Multi-Arch on all packages
  * Build hprof-conv on all architectures
  * dalvik-exchange:
    * Use the package upstream version as the JAR version
    * No longer build against dex.jar (Closes: #911103)
    * Fix some literal errors in the package description
    * Install mainDexClassesNoAapt.rules

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:29:31 +0100

Changed in android-platform-dalvik (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-libcore - 8.1.0+r23-2~18.04

---------------
android-platform-libcore (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-libcore (8.1.0+r23-2) unstable; urgency=medium

  * Upload to unstable
  * Standards-Version => 4.2.1

android-platform-libcore (8.1.0+r23-1) experimental; urgency=medium

  * New upstream release (Closes: #883894, #898705)
  * Remove the Javadoc package due to low popcon

  [ 殷啟聰 | Kai-Chung Yan ]
  * Upgrade to debhelper 11
  * Install the `NOTICE` file in every package
  * Remove `libandroid-dex-java`: Sources are moved to `android-platform-dalvik`

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:04:34 +0100

Changed in android-platform-libcore (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-libnativehelper - 8.1.0+r23-1~18.04

---------------
android-platform-libnativehelper (8.1.0+r23-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-libnativehelper (8.1.0+r23-1) unstable; urgency=medium

  * Standards-Version => 4.2.1
  * Fix FTCBFS by using dh_auto_build to invoke makefiles
  * Don't Build-Depends on android-platform-libcore-headers
  * Build on all architectures

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Switch to Salsa
  * Remove get-orig-source
  * Fix missing-notice-file-for-apache-license

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:39:07 +0100

Changed in android-platform-libnativehelper (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wala - 1.5.1-1~18.04

---------------
wala (1.5.1-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

wala (1.5.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream version
  * update Vcs tags to point to salsa.debian.org

wala (1.5.0-1) experimental; urgency=medium

  * Team upload.
  * New upstream version

wala (1.3.9-3) unstable; urgency=medium

  * Team upload.
  * Standards-Version: 4.3.0 remove get-orig-source
  * update Vcs URLs to salsa.debian.org

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:45:04 +0100

Changed in wala (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-development - 8.1.0+r23-1~18.04

---------------
android-platform-development (8.1.0+r23-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-development (8.1.0+r23-1) unstable; urgency=medium

  [ Saif Abdul Cassim ]
  * New upstream release
  * Fixed FTCBFS thanks to Helmut Grohne (Closes: #870766)
  * Switch to Salsa
  * Debhelper compat level => 11

  [ Kai-Chung Yan ]
  * Standards-Version => 4.2.1

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:30:21 +0100

Changed in android-platform-development (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-external-boringssl - 8.1.0+r23-2~18.04

---------------
android-platform-external-boringssl (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-external-boringssl (8.1.0+r23-2) unstable; urgency=medium

  * Update d/copyright:
    * Cover all copyright holders (Closes: #905820)
    * Point the Source to AOSP
  * Standards-Version => 4.2.1

android-platform-external-boringssl (8.1.0+r23-1) unstable; urgency=medium

  * Initial release (Closes: #823933)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:47:35 +0100

Changed in android-platform-external-boringssl (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-external-libunwind - 8.1.0+r23-2~18.04

---------------
android-platform-external-libunwind (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-external-libunwind (8.1.0+r23-2) unstable; urgency=medium

  [ Kai-Chung Yan ]
  * Release to unstable
  * Standards-Version => 4.2.1: Remove get-orig-source

  [ Hans-Christoph Steiner ]
  * Fix missing-notice-file-for-apache-license
  * Unify the maintainer name as "Android Tools Maintainers"
  * Add a smoke autopkgtest

android-platform-external-libunwind (8.1.0+r23-1) experimental; urgency=medium

  * New upstream release
  * Add myself to Uploaders
  * Update Standards-Version to 4.1.4.1
  * Fixes FTCBFS thanks to Helmut Grohne (Closes: #897062)
  * Move Vcs to Salsa

  [ 殷啟聰 | Kai-Chung Yan ]
  * Use `debian/clean` to simplify the build scripts
  * Use HTTPS URLs for `debian/copyright`
  * Update to debhelper compat level 11

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:44:33 +0100

Changed in android-platform-external-libunwind (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-frameworks-native - 1:8.1.0+r23-2~18.04

---------------
android-platform-frameworks-native (1:8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-frameworks-native (1:8.1.0+r23-2) unstable; urgency=medium

  * Release to unstable
  * Standards-Version => 4.2.1

android-platform-frameworks-native (1:8.1.0+r23-1) experimental; urgency=medium

  [ Saif Abdul Cassim ]
  * New upstream release
  * Update to debhelper 11
  * Update Standards-Version to 4.1.4.1
  * Exclude some files under SGI-B-v1.0
  * Move Vcs to Salsa

  [ 殷啟聰 | Kai-Chung Yan ]
  * Use `debian/clean` to simplify the build scripts

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:00:04 +0100

Changed in android-platform-frameworks-native (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-system-tools-aidl - 1:8.1.0+r23-1~18.04

---------------
android-platform-system-tools-aidl (1:8.1.0+r23-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-system-tools-aidl (1:8.1.0+r23-1) unstable; urgency=medium

  * Update manpages to include `-ninja` option
  * Install all files under `docs/`
  * Fix FTCBFS thanks to Helmut Grohne (Closes: #871599)
  * Standards-Version => 4.2.1
  * d/control: Remove the unused build-dependency android-libcutils-dev

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Switch to Salsa
  * d/copyright: Use HTTPS URLs
  * Fix missing-notice-file-for-apache-license

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:42:11 +0100

Changed in android-platform-system-tools-aidl (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apktool - 2.3.4-1~18.04

---------------
apktool (2.3.4-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

apktool (2.3.4-1) unstable; urgency=medium

  * New upstream version 2.3.4.
  * Use dh_missing instead of dh_install.
  * Declare compliance with Debian Policy 4.2.1.
  * Implement get-orig-source target because uscan and Files-Excluded does not
    work as expected.

apktool (2.3.3-2) unstable; urgency=medium

  * Add snakeyaml-1.21.patch and fix NoSuchMethodError error with Snakeyaml
    1.21. (Closes: #902666)

apktool (2.3.3-1) unstable; urgency=medium

  * New upstream version 2.3.3.

apktool (2.3.2-1) unstable; urgency=medium

  * New upstream version 2.3.2.
  * Refresh the patches.

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:32:52 +0100

Changed in apktool (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enjarify - 1:1.0.3-4~18.04

---------------
enjarify (1:1.0.3-4~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

enjarify (1:1.0.3-4) unstable; urgency=medium

  * Update policy compliance to 4.1.3.
    - change priority from extra to optional
  * Update homepage and watch file with new upstream location.
  * Bump debhelper dependency/compat to 11.
  * Update URLs in debian/copyright.
  * Move packaging VCS to salsa.
  * Add upstream metadata file.

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:34:11 +0100

Changed in enjarify (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-art - 8.1.0+r23-3~18.10

---------------
android-platform-art (8.1.0+r23-3~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-art (8.1.0+r23-3) unstable; urgency=medium

  * Put all LDFLAGS that link libraries at the end of the command line. This
    fixes FTBFS on Ubuntu because `--as-needed` is used by default.
    (Closes: #916250) Thanks to Logan Rosen.
  * ucontext.patch: Fix a type mismatch causing FTBFS on armhf
  * Use GCC to compile assembly code on armhf as Clang does not support the
    `ADRL` instruction. See <https://bugs.llvm.org/show_bug.cgi?id=24350>.

android-platform-art (8.1.0+r23-2) unstable; urgency=medium

  * Use my DD account in Uploaders
  * Disable libart and its users on MIPS as ART only supports MIPSr6 while
    Debian is by default MIPSr2
  * Fix FTBFS on i386
  * Use Clang only for libart and its users while GCC for the rest. This allows
    `dmtracedump` to be released on all architectures.

android-platform-art (8.1.0+r23-1) unstable; urgency=low

  * Initial release (Closes: #913785)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:28:32 +0100

Changed in android-platform-art (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.7 KiB)

This bug was fixed in the package android-platform-dalvik - 8.1.0+r23-2~18.10

---------------
android-platform-dalvik (8.1.0+r23-2~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-dalvik (8.1.0+r23-2) unstable; urgency=medium

  * Install manpages pre-baked by pandoc. Pandoc as a B-D is thus unnecessary.
  * Fix FTCBFS by using dh_auto_build to invoke makefiles
  * Remove unused build-dependency libjarajr-java

android-platform-dalvik (8.1.0+r23-1) unstable; urgency=medium

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Switch to Salsa
  * Remove get-orig-source
  * Fix missing-notice-file-for-apache-license

  [ Kai-Chung Yan ]
  * Standards-Version => 4.2.1
  * No longer build dmtracedump or dexdump in this package. They have been moved
    to android-platform-art.
  * Annotate Multi-Arch on all packages
  * Build hprof-conv on all architectures
  * dalvik-exchange:
    * Use the package upstream version as the JAR version
    * No longer build against dex.jar (Closes: #911103)
    * Fix some literal errors in the package description
    * Install mainDexClassesNoAapt.rules

android-platform-dalvik (7.0.0+r33-1) unstable; urgency=medium

  * New upstream release

android-platform-dalvik (7.0.0+r1-4) unstable; urgency=medium

  * depend on proguard-cli to avoid including GUI deps (Closes: #856407)

android-platform-dalvik (7.0.0+r1-3) unstable; urgency=medium

  * android-libdex-dev Breaks & Replaces android-libdex because libdex.so was
    moved from android-libdex to android-libdex-dev (Closes: #848037)

android-platform-dalvik (7.0.0+r1-2) unstable; urgency=medium

  * d/control:
    * dalvik-exchange Depends on proguard
    * Remove libandroid-jack-dx-java since Jack does not need it for now
  * No longer build shrinkedAndroid.jar but link to libandroid-23-java
    * dalvik-exchange Depends on libandroid-23-java (>= 6.0.1+r72-3~)
    * Remove the Built-Using field in dalvik-exchange
    * No loner Build-Depends on libandroid-23-java

android-platform-dalvik (7.0.0+r1-1) unstable; urgency=medium

  * New upstream release
  * d/copyright: Exclude *.class
  * Include the source of dmtracedump in debian/additionalSrc
  * d/control:
    * Build-Depends on default-jdk-headless | default-jdk
    * Remove the useless default-jdk-doc from Build-Depends
    * Unify the maintainer name to "Android Tools Maintainers"
  * Set the dynamic ${BUILD_TOOLS_VERSION} to "debian"
  * No longer requires AndroidConfig.h
  * Update to debhelper 10
  * Let gradle-debian-helper generate Maven POMs
    * Build-Depends on gradle-debian-helper (>= 1.4~)
  * Enable builds for ARM & MIPS
  * Move libdex.so from android-libdex to android-libdex-dev
  * Build shrinkedAndroid.jar

android-platform-dalvik (6.0.1+r55-1) unstable; urgency=medium

  [ Kai-Chung Yan ]
  * d/control:
    - Build-Depends of C/C++ libraries are limited to [amd64 i386]
    - Move some Build-Depends to Build-Depends-Indep
    - Change dependency: libdex-java => libandroid-dex-java
    - Mention that dexdump on amd64 will not work
    - Standards-Version => 3.9.8 (no changes)
  * Add multi-arch support (Closes: #828958)
    - Depends on package...

Read more...

Changed in android-platform-dalvik (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-external-libselinux - 8.1.0+r23-2~18.10

---------------
android-platform-external-libselinux (8.1.0+r23-2~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-external-libselinux (8.1.0+r23-2) unstable; urgency=medium

  * Release to unstable
  * Install README.android to /usr/share/doc

android-platform-external-libselinux (8.1.0+r23-1) experimental; urgency=medium

  * Install READMEs to the main packages rather than the dev ones

  [ Saif Abdul Cassim ]
  * Track new upstream platform/external/selinux in AOSP
  * Switch to Salsa Vcs

  [ Chandramouli Rajagopalan ]
  * Add myself to Uploaders
  * Track new upstream platform/external/selinux in AOSP

  [ Umang Parmar ]
  * Add myself to Uploaders
  * Build libsepol and libsepol-dev binary packages
  * Use 'debian/clean' to simplify the build scripts
  * Fix FTCBFS (thanks to Helmut Grohne) (Closes: #864563)

  [ Hans-Christoph Steiner ]
  * New Upstream release
  * d/rules: Remove get-orig-source

android-platform-external-libselinux (7.0.0+r1-2) unstable; urgency=medium

  * Upload to unstable
  * Update to debhelper 10
  * d/control: Unify the maintainer name to "Android Tools Maintainers"

android-platform-external-libselinux (7.0.0+r1-1) experimental; urgency=medium

  * New upstream release
  * Define NDEBUG for C binaries

android-platform-external-libselinux (6.0.1+r55-1) unstable; urgency=medium

  [ Chirayu Desai ]
  * New upstream release. (Identical to 6.0.1+r16)
  * debian: Add watch file for usage with uscan

  [ Kai-Chung Yan ]
  * d/rules: No need to enable all hardening features, pie + bindnow will be
    default in Stretch

android-platform-external-libselinux (6.0.1+r16-2) unstable; urgency=medium

  * Team upload.

  [ Kai-Chung Yan ]
  * Install libraries to DEB_HOST_MULTIARCH path
  * Update Standards-Version to 3.9.8 (no changes)
  * d/rules: export DEB_BUILD_MAINT_OPTIONS = hardening=+all

android-platform-external-libselinux (6.0.1+r16-1) unstable; urgency=medium

  * New upstream release

android-platform-external-libselinux (6.0.0+r26-3) unstable; urgency=medium

  * upload to unstable

android-platform-external-libselinux (6.0.0+r26-2) experimental; urgency=medium

  * Add version 0 to SONAME
  * Install docs for libselinux

android-platform-external-libselinux (6.0.0+r26-1) experimental; urgency=low

  * New upstream release
  * Remove version info from the library

android-platform-external-libselinux (5.1.1+r8-1) unstable; urgency=low

  [ Kai-Chung Yan ]
  * Initial release (Closes: #793611)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:46:49 +0100

Changed in android-platform-external-libselinux (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-libnativehelper - 8.1.0+r23-1~18.10

---------------
android-platform-libnativehelper (8.1.0+r23-1~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-libnativehelper (8.1.0+r23-1) unstable; urgency=medium

  * Standards-Version => 4.2.1
  * Fix FTCBFS by using dh_auto_build to invoke makefiles
  * Don't Build-Depends on android-platform-libcore-headers
  * Build on all architectures

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Switch to Salsa
  * Remove get-orig-source
  * Fix missing-notice-file-for-apache-license

android-platform-libnativehelper (7.0.0+r33-1) unstable; urgency=medium

  * New upstream release

android-platform-libnativehelper (7.0.0+r1-2) unstable; urgency=medium

  * android-libnativehelper-dev Breaks & Replaces android-libnativehelper
    because README is moved to android-libnativehelper-dev (Closes: #847710)

android-platform-libnativehelper (7.0.0+r1-1) unstable; urgency=medium

  * New upstream release
  * Update Standards-Version to 3.9.8:
    * Move documentations from android-libnativehelper to
      android-libnativehelper-dev
  * Update to debhelper 10
  * d/control:
    * Enable builds for ARM & MIPS
    * Unify the maintainer name as "Android Tools Maintainers"
    * Add android-platform-libcore-headers to Build-Depends

android-platform-libnativehelper (6.0.1+r55-1) unstable; urgency=medium

  [ Hans-Christoph Steiner ]
  * set Android Build-Depends: to have the same version as this package

  [ Chirayu Desai ]
  * New upstream release.
  * Add myself to Uploaders
  * debian: Add watch file for usage with uscan
  * Update android-platform-system-core Android Build-Depends to 6.0.1+r55

  [ Kai-Chung Yan ]
  * d/Makefile: Switch to use C++ compiler
  * Install libnativehelper to multiarch directory
    - d/control: Build-Depends on dh-exec
  * d/rules: Define NDEBUG for C++ binaries

android-platform-libnativehelper (6.0.1+r16-1) unstable; urgency=medium

  * Initial release (Closes: #813899)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:39:07 +0100

Changed in android-platform-libnativehelper (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-system-extras - 8.1.0+r23-2~18.10

---------------
android-platform-system-extras (8.1.0+r23-2~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-system-extras (8.1.0+r23-2) unstable; urgency=medium

  * Release to unstable

android-platform-system-extras (8.1.0+r23-1) experimental; urgency=medium

  [ Hans-Christoph Steiner ]
  * New upstream release
  * d/copyright: Use HTTPS URLs
  * Switch to Salsa

  [ Saif Abdul Cassim ]
  * New package android-sdk-ext4-utils providing:
    * mkuserimg
    * ext4fixup
    * make_ext4fs
    * This package is replacing the obsolete android-tools-fsutils

  [ Kai-Chung Yan ]
  * Debhelper level => 11
  * d/rules: Use dh-auto-build instead of plain make thanks to Helmut Grohne
  * Fix the conflicting types errors (Closes: #892170)
  * Standards-Version => 4.2.1

android-platform-system-extras (7.0.0+r33-1) unstable; urgency=medium

  * New upstream release

android-platform-system-extras (7.0.0+r1-2) unstable; urgency=medium

  * Upload to unstable

android-platform-system-extras (7.0.0+r1-1) experimental; urgency=medium

  * New upstream release
  * Enable builds for ARM & MIPS
  * Update to debhelper 10

android-platform-system-extras (6.0.1+r55-1) unstable; urgency=medium

  * New upstream release.
  * debian: Add watch file for usage with uscan
  * debian/watch: recompress using xz
  * Update Android Build-Depends to the latest version available

android-platform-system-extras (6.0.1+r16-2) unstable; urgency=medium

  * d/control:
    - Standards-Version => 3.9.8
    - Maintainer: Unify to "Android Tools Maintainers"
    - Add dh-exec to Build-Depends
  * Add multiarch android directory to RPATH (Closes: #826642)
  * Install the libraries to multiarch path
  * d/rules: Move some global compiler flags to here
  * Override binary-or-shlib-defines-rpath

android-platform-system-extras (6.0.1+r16-1) unstable; urgency=medium

  * New upstream release

android-platform-system-extras (6.0.0+r26-1) unstable; urgency=low

  * Initial release (Closes: #810596)

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 14:45:19 +0100

Changed in android-platform-system-extras (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-tools-apksig - 0.8-2ubuntu1~18.04

---------------
android-platform-tools-apksig (0.8-2ubuntu1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-tools-apksig (0.8-2ubuntu1) disco; urgency=medium

  * Compile for Java 8: (LP: #1821235)
    - debian/rules: the parameter '-target 8' must be set to get got compiled
      for OpenJDK 8, setting '--release 8' is the best way as it guarantees
      that the whole '-source/-target/-bootclasspath' triad is correctly set.

android-platform-tools-apksig (0.8-2) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Removed the alternative build dependency on openjdk-8-jdk

  [ Kai-Chung Yan ]
  * Install Maven artifacts of `apksig.jar`
  * Standards-Version => 4.2.1
  * uscan: Watch for `gradle-*` tags instead of `android-*_r*`
  * Instal Maven artifacts for `apkgsig.jar`
  * Remove unused build-dependencies: antlr3 groovy maven-debian-helper
  * apksigner now requires JRE >= 8 since it is compiled on source level 8
  * Add myself to Uploaders
  * Install `apksigner` into Android SDK home

  [ Hans-Christoph Steiner ]
  * Use real URLs for Vcs-Git, not ones that redirect
  * Add autopkgtest for APK verification
  * Add GitLab CI support

 -- Tiago Stürmer Daitx <email address hidden> Sat, 23 Mar 2019 00:19:26 +0000

Changed in android-platform-tools-apksig (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-sdk-meta - 25.0.0+10~18.04.2

---------------
android-sdk-meta (25.0.0+10~18.04.2) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-sdk-meta (25.0.0+10) unstable; urgency=medium

  * drop packages with impossible arches from meta Depends

android-sdk-meta (25.0.0+9) unstable; urgency=medium

  [ Jeremy Bicha ]
  * android-sdk-platform-tools: Don't require adb or fastboot on mips*

  [ 殷啟聰 | Kai-Chung Yan ]
  * Update versions of SDK components to match upstream

  [ Hans-Christoph Steiner ]
  * fix missing idProduct values in udev rules
  * add autopkgtest for udev rules
  * add autopkgtest for `apt-get install android-tools-adb`
  * add debian/.gitlab-ci.yml to run tests on GitLab CI
  * update alternative Depends: for current Java versions (Closes: #922555)
  * purge dependencies not in buster

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 16:12:23 +0100

Changed in android-sdk-meta (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cava - 0.6.0-1~18.04

---------------
cava (0.6.0-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

cava (0.6.0-1) unstable; urgency=medium

  * Initial release

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:44:24 +0100

Changed in cava (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dummydroid - 1.2-2~18.04

---------------
dummydroid (1.2-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

dummydroid (1.2-2) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on junit (Closes: #871343)
  * Don't install the jar twice in the package
  * Build with the DH sequencer instead of CDBS
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Moved the .prop files to debian/props/

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:36:09 +0100

Changed in dummydroid (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package f2fs-tools - 1.11.0-1.1~18.10

---------------
f2fs-tools (1.11.0-1.1~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

f2fs-tools (1.11.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix "missing Breaks+Replaces: libf2fs-dev (<< 1.11)":
    add them in debian/control, thanks Andreas Beckmann.
    (Closes: #907975)

f2fs-tools (1.11.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #904286)
     - add sg_write_buffer for UFS firmware update in Android
     - wanted_sector_size to specify sector size explicitly
     - support fsverity feature bit
     - support lost+found feature
  * Install the library link files in /usr/lib where they belong
  * Replace the libf2fs0 package with libf2fs5 and libf2fs-format4
  * Fixed missing libblkid dependency in the shared library
  * Updated Standards compliance to 4.2.0
  * Added Theodore Ts'o as an uploader for the package

f2fs-tools (1.10.0-1) unstable; urgency=medium

  * Acknowledge NMU, thanks to Adam Borowski!
  * New upstream release.
    - fsck.f2fs now supports "-y". (Closes: #883026)
  * Update Standards version to 4.1.3.
    - Change all priority: extra packages to be priority: optional.

f2fs-tools (1.7.0-1.1) unstable; urgency=medium

  * NMU with permission.
  * Make an udeb. (Closes: #848551)

f2fs-tools (1.7.0-1) unstable; urgency=medium

  * New upstream release.
    - Add new build-dep on libselinux1-dev.
  * Use triggers instead of manually calling update-initramfs on postinst.
  * Update Standards version to 3.9.8.

f2fs-tools (1.6.1-1) unstable; urgency=medium

  * New upstream release.
    - Fix segfault when executing "fsck.f2fs -a". (Closes: #813806)
  * Update Standards version to 3.9.7.

f2fs-tools (1.6.0-2) unstable; urgency=medium

  * Add multiarch support for libf2fs-dev and libf2fs0.

f2fs-tools (1.6.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #807411)
    - mkfs/Makefile.am: add a section to build libf2fs_fmt (Closes: #793863)
    - Add new binary packages for the above change: libf2fs0, libf2fs-dev.
      Based off of Kai-Chung Yan's patch, thanks!
    - Add appropriate Breaks/Replaces clauses to ensure smooth upgrades.
  * Add postinst to update the initramfs on install/upgrade. (Closes: #804241)
  * Update watch file.

f2fs-tools (1.4.1-1) unstable; urgency=medium

  * New upstream release.
    - Drop patch fix-big-endian-ftbfs.patch, applied upstream.
  * Add watch file.

f2fs-tools (1.4.0-2) unstable; urgency=medium

  * Fix FTBFS on big-endian archs. (Closes: #762411)
  * Update Standards version to 3.9.6.

f2fs-tools (1.4.0-1) unstable; urgency=medium

  * New upstream release.
    - Add auto_fix feature. (Closes: #757538)
  * Restrict arch to linux-any.

f2fs-tools (1.3.0-1) unstable; urgency=medium

  * New upstream release.

f2fs-tools (1.2.0-1) unstable; urgency=medium

  * Adopt package. (Closes: #723596)
  * New upstream release. (LP: #1261173)
  * Add build-dep on dh-autoreconf and pkg-config.
  * Install manpage for mkfs.f2fs(8).
  * Update Standards version to 3.9.5.
  * Add Vcs-* fields in debian/control.

f2fs-tools (1.1.0-3) unstable; urge...

Read more...

Changed in f2fs-tools (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libscout - 2.3.2-1~18.04

---------------
libscout (2.3.2-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

libscout (2.3.2-1) unstable; urgency=medium

  * New upstream release (Closes: #876764)
  * use upstream's build.gradle
  * add new example file for building profiles of tracker libraries
  * convert to javahelper package
  * add smoke check autopkgtest
  * remove maven-repo-helper, this is a CLI tool, not a lib

libscout (2.1.0-1) unstable; urgency=medium

  * New upstream release

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:28:14 +0100

Changed in libscout (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsmali-java - 2.2.6-1~18.04

---------------
libsmali-java (2.2.6-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

libsmali-java (2.2.6-1) unstable; urgency=medium

  * New upstream version

libsmali-java (2.2.5-1) unstable; urgency=medium

  * New upstream version

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:24:34 +0100

Changed in libsmali-java (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-frameworks-data-binding - 2.2.2-3~18.04.1

---------------
android-platform-frameworks-data-binding (2.2.2-3~18.04.1) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.
  * Build-depend on libicu4j-java.

android-platform-frameworks-data-binding (2.2.2-3) unstable; urgency=medium

  * Team upload.
  * Added a dependency on JAXB to fix the build failure with Java 9
    (Closes: #894287)
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:08:21 +0100

Changed in android-platform-frameworks-data-binding (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package android-platform-frameworks-base - 1:8.1.0+r23-3~18.10

---------------
android-platform-frameworks-base (1:8.1.0+r23-3~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-frameworks-base (1:8.1.0+r23-3build1) disco; urgency=medium

  * No-change rebuild against latest protobuf

android-platform-frameworks-base (1:8.1.0+r23-3) unstable; urgency=medium

  * Release to unstable
  * Fix the install path of the headers of libandroidfw
  * Annotate all packages with Multi-Arch (Closes: #895820)

android-platform-frameworks-base (1:8.1.0+r23-2) experimental; urgency=medium

  * Properly declare target dependencies in d/rules, thus fixing a FTBFS when
    building binary-indep.
  * d/aapt2.mk: Remove macros that don't apply to aapt2

android-platform-frameworks-base (1:8.1.0+r23-1) experimental; urgency=medium

  * Standards-Version => 4.2.1
  * Mark the manpage of `split-select` outdated

  [ Hans-Christoph Steiner ]
  * New upstream release
  * Do not exclude some test data during get-orig-source
  * Switch to Salsa

  [ Umang Parmar ]
  * Switch to aapt2 to compile framework-res.apk
  * Use debian/clean to simplify build scripts
  * Add myself to Uploaders

android-platform-frameworks-base (1:7.0.0+r33-1) unstable; urgency=medium

  * New upstream release (Closes: #859081)

android-platform-frameworks-base (1:7.0.0+r1-3) unstable; urgency=medium

  * include bash-completion for aapt (Closes: #856420)

android-platform-frameworks-base (1:7.0.0+r1-2) unstable; urgency=medium

  * Upload to unstable
  * Switch from using patchelf to chrpath for patchelf is unavailable on MIPS
  * d/rules: Set ANDROID_BUILD_TOOLS_VERSION since aapt.mk needs it

android-platform-frameworks-base (1:7.0.0+r1-1) experimental; urgency=medium

  [ Kai-Chung Yan ]
  * New upstream release
  * Build aapt2
  * Enable builds for ARM & MIPS
  * Remove package: aidl (moved to src:android-platform-system-tools-aidl)
  * Set the dynamic BUILD_TOOLS_VERSION to "debian"
  * Update to debhelper 10
  * Drop fix_expat_header_path.patch: Fixed in upstream

  [ Chirayu Desai ]
  * No longer manually invoke strip-nondeterminism
    (See: <https://tracker.debian.org/news/792561>)

android-platform-frameworks-base (1:6.0.1+r55-1) unstable; urgency=medium

  [ Chirayu Desai ]
  * New upstream release.
  * debian: Add watch file for usage with uscan
  * d/watch: recompress using xz
  * d/copyright:
    - Exclude "core/res/res/values-mcc310-mnc380": dpkg-source cannot handle
      symlinks to a directory
  * Update Android Build-Depends to the latest version available

  [ Kai-Chung Yan ]
  * d/copyright: No longer exclude
    - No longer exclude "*.zip": Not necessary
    - No longer exclude "packages": Contains codes required for building
      android.jar
    - Exclude "core/res/res/values-mcc310-mnc170": dpkg-source cannot handle
      symlinks to a directory

android-platform-frameworks-base (1:6.0.1+r43-1) unstable; urgency=medium

  * Team upload.

  [ Kai-Chung Yan ]
  * New upstream release
  * d/control:
    - Limit some BDs to [amd64 i386]
    - Change Maintainer to "Android Tools Maintainers"
    - Standards-...

Read more...

Changed in android-platform-frameworks-base (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wala - 1.5.1-1~18.04

---------------
wala (1.5.1-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

wala (1.5.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream version
  * update Vcs tags to point to salsa.debian.org

wala (1.5.0-1) experimental; urgency=medium

  * Team upload.
  * New upstream version

wala (1.3.9-3) unstable; urgency=medium

  * Team upload.
  * Standards-Version: 4.3.0 remove get-orig-source
  * update Vcs URLs to salsa.debian.org

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:45:04 +0100

Changed in wala (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-libcore - 8.1.0+r23-2~18.04

---------------
android-platform-libcore (8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-libcore (8.1.0+r23-2) unstable; urgency=medium

  * Upload to unstable
  * Standards-Version => 4.2.1

android-platform-libcore (8.1.0+r23-1) experimental; urgency=medium

  * New upstream release (Closes: #883894, #898705)
  * Remove the Javadoc package due to low popcon

  [ 殷啟聰 | Kai-Chung Yan ]
  * Upgrade to debhelper 11
  * Install the `NOTICE` file in every package
  * Remove `libandroid-dex-java`: Sources are moved to `android-platform-dalvik`

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:04:34 +0100

Changed in android-platform-libcore (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-framework-23 - 6.0.1+r72-5~18.04

---------------
android-framework-23 (6.0.1+r72-5~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-framework-23 (6.0.1+r72-5) unstable; urgency=medium

  * Fix FTBFS with Java 9+ (Closes: #894285)
  * add basic autopkgtest to check that class files are in the JAR

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 13:29:21 +0100

Changed in android-framework-23 (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package android-platform-build - 1:8.1.0+r23-2~18.04

---------------
android-platform-build (1:8.1.0+r23-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1819448.

android-platform-build (1:8.1.0+r23-2) unstable; urgency=medium

  * Move javahelper from Build-Depends-Indep to Build-Depends. Debhelper plugins
    must always be installed.
  * Pre-bake manpages using Pandoc during dev-time. Pandoc as a build-dependency
    is sometimes unreliable and unnecessary because Haskell uses static linking.

android-platform-build (1:8.1.0+r23-1) unstable; urgency=medium

  [ Kai-Chung Yan ]
  * New upstream release
  * Use dh_auto_build to invoke makefiles (thanks to Helmut Grohne)
  * Standards-Version => 4.2.1: Remove get-orig-source
  * Remove old package android-platform-build-headers (Closes: #908801)
  * Update manpages with new contents and more appropriate formatting
  * Build signapk with apksig
  * d/copyright: Exclude minified JavaScript

  [ Hans-Christoph Steiner ]
  * Switch to Salsa
  * d/copyright: Use HTTPS URLs

 -- Matthias Klose <email address hidden> Mon, 11 Mar 2019 15:27:55 +0100

Changed in android-platform-build (Ubuntu):
status: New → Fix Released
Changed in android-platform-development (Ubuntu):
status: New → Fix Released
Changed in android-platform-external-boringssl (Ubuntu):
status: New → Fix Released
Changed in android-platform-external-libunwind (Ubuntu):
status: New → Fix Released
Changed in android-platform-frameworks-native (Ubuntu):
status: New → Fix Released
Changed in android-platform-system-core (Ubuntu):
status: New → Fix Released
Changed in android-platform-system-tools-aidl (Ubuntu):
status: New → Fix Released
Changed in android-platform-tools-apksig (Ubuntu):
status: New → Fix Released
Changed in android-sdk-meta (Ubuntu):
status: New → Fix Released
Changed in apktool (Ubuntu):
status: New → Fix Released
Changed in enjarify (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.