RM: obsolete android tooling, FTBFS, python2, no longer needed

Bug #1892023 reported by Dimitri John Ledkov on 2020-08-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
android-platform-build (Ubuntu)
Undecided
Unassigned
android-platform-external-boringssl (Debian)
Confirmed
Unknown
android-platform-external-boringssl (Ubuntu)
Undecided
Unassigned
android-platform-external-libunwind (Debian)
New
Unknown
android-platform-external-libunwind (Ubuntu)
Undecided
Unassigned
android-platform-system-core (Debian)
New
Unknown
android-platform-system-core (Ubuntu)
Undecided
Unassigned
android-platform-system-extras (Debian)
New
Unknown
android-platform-system-extras (Ubuntu)
Undecided
Unassigned

Bug Description

RM: obsolete android tooling, FTBFS, python2, no longer needed

tags: added: ftbfs update-excuse
Changed in android-platform-build (Ubuntu):
status: New → Triaged
Changed in android-platform-external-boringssl (Ubuntu):
status: New → Triaged
Changed in android-platform-external-libunwind (Ubuntu):
status: New → Triaged
Changed in android-platform-system-core (Ubuntu):
status: New → Triaged
Changed in android-platform-system-extras (Ubuntu):
status: New → Triaged
Changed in android-platform-external-boringssl (Debian):
status: Unknown → Confirmed
Changed in android-platform-external-libunwind (Debian):
status: Unknown → New
Changed in android-platform-system-core (Debian):
status: Unknown → New
Changed in android-platform-system-extras (Debian):
status: Unknown → New
Steve Langasek (vorlon) wrote :

$ reverse-depends -R src:android-platform-build
Reverse-Depends
* android-sdk-build-tools (for zipalign)

Packages without architectures listed are reverse-dependencies in: amd64, arm64, armhf
$ reverse-depends src:android-platform-build -a source
Reverse-Testsuite-Triggers
* fdroidserver (for zipalign)

Reverse-Build-Depends
* android-framework-23 (for android-logtags-tools)

$

android-platform-build has unaddressed reverse-dependencies.

Changed in android-platform-build (Ubuntu):
status: Triaged → Incomplete
Steve Langasek (vorlon) wrote :

$ reverse-depends -R src:android-platform-system-core
Reverse-Depends
* aapt [amd64 arm64 armhf] (for android-libbase)
* aapt [amd64 arm64 armhf] (for android-libziparchive)
* aapt [amd64 arm64 armhf] (for android-libutils)
* aidl [amd64 arm64 armhf] (for android-libbase)
* android-libaapt [amd64 arm64 armhf]
* android-libaapt [amd64 arm64 armhf]
* android-libandroidfw [amd64 arm64 armhf]
* android-libandroidfw [amd64 arm64 armhf]
* android-libandroidfw [amd64 arm64 armhf]
* android-libandroidfw [amd64 arm64 armhf]
* android-libandroidfw-dev [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libart [amd64 arm64 armhf]
* android-libext4-utils [amd64 arm64 armhf]
* android-libf2fs-utils [amd64 arm64 armhf]
* android-libnativehelper [amd64 arm64 armhf ppc64el s390x]
* android-sdk-ext4-utils [amd64 arm64 armhf]
* android-sdk-platform-tools [amd64 arm64 armhf]
* android-sdk-platform-tools [amd64 arm64 armhf]
* dexdump [amd64 arm64 armhf] (for android-libbase)
* fdroidcl [amd64 arm64 armhf]
* libandroid-ddms-java (for adb)
* split-select [amd64 arm64 armhf]
* split-select [amd64 arm64 armhf]
* zipalign [amd64 arm64 armhf]
* zipalign [amd64 arm64 armhf]

Packages without architectures listed are reverse-dependencies in: amd64, arm64, armhf, i386, ppc64el, s390x
$

At least android-platform-frameworks-base is unaccounted for here as a revdep.

Changed in android-platform-system-core (Ubuntu):
status: Triaged → Incomplete
Jeremy Bicha (jbicha) wrote :

adb and fastboot from android-platform-system-core are really useful for people who like to use alternative Android ROMs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.