Ubuntu

aMule 2.1.3-1Ubuntu2 crashes while downloading IPfilter file

Reported by Hugin on 2007-04-01
8
Affects Status Importance Assigned to Milestone
amule (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: amule

aMule 2.1.3-1Ubuntu2 fails to read the IPfilter file from it's directory and crashes when downloading one from a webserver. Using aMule version 2.1.3-1 from the Debian repositories avoids both bugs, but that version eats a lot of CPU power in Feisty (way more then it does in Edgy).

While trying to read the IPfilter file from the the HD, the aMule log states:
2007-04-01 23:04:38: Loading ipfilter.dat files.
2007-04-01 23:04:39: Error: Failed to convert file "/home/tdr/.aMule/ipfilter.dat" to Unicode.
2007-04-01 23:04:39: Failed to load ipfilter.dat file '/home/tdr/.aMule/ipfilter.dat', could not open file.

Loading an IPfilter file from a webserver crashes aMule, generating this error report:

Host: ufpr.dl.sourceforge.net:80
URL: http://ufpr.dl.sourceforge.net/sourceforge/emulepawcio/ipfilter.zip
Response: 200 (Error: 0)
Download size: 2620888

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.1.3 using wxGTK2 v2.8.1 (Unicoded)
Running on: Linux 2.6.20-13-generic x86_64

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x447d15]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x2ba223c02e4c]
[4] ?? in /lib/libpthread.so.0 [0x2ba222485200]
[5] wxGIFDecoder::GetFrameSize(unsigned int) const in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ba22354ad1a]
[6] wxGIFDecoder::ConvertToImage(unsigned int, wxImage*) const in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ba22354ad72]
[7] wxTextCtrl::wxTextCtrl() in amule [0x5e72f6]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ba223bfee2f]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x2ba223bfefcf]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ba223bff119]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ba22358feb6]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x2ba2234877b4]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0x2ba225e7bf1b]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x2ba225e7ba14]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0x2ba225e7e85d]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x2ba225e7eb6a]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x2ba22643a023]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ba22347f27d]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ba22350fa0b]
[20] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x2ba223b9e5ec]
[21] CryptoPP::IteratedHash<unsigned int, CryptoPP::EnumToType<CryptoPP::ByteOrder, 0>, 64u, CryptoPP::HashTransformation>::~IteratedHash() in amule [0x4e9892]
[22] __libc_start_main in /lib/libc.so.6[0x2ba2246218e4]
[23] wxNotebook::SetPadding(wxSize const&) in amule[0x444569]

--------------------------------------------------------------------------------
Aborted (core dumped)

ProblemType: Bug
Architecture: amd64
Date: Sun Apr 1 23:08:20 2007
DistroRelease: Ubuntu 7.04
Uname: Linux tdr-64-main 2.6.20-13-generic #2 SMP Sat Mar 24 23:12:02 UTC 2007 x86_64 GNU/Linux

Dave Hall (skwashd) wrote :

This looks like a dupe of bug #90199

Workaround:
edit /home/<user>/.aMule/amule.conf
Change IPFilterAutoLoad=1 to IPFilterAutoLoad=0

Hugin (karsten-loh) wrote :

Yes looks like a duplicate of that error. The workaround however isn't feasible. Sure I can start aMule that way, but since aMule also crashes when loading an IPfilter file manually from the security tab that means currently aMule works only if IPfilters aren't used at all. That's not an option I'm afraid.

Changed in amule:
importance: Undecided → Medium
Emilio Pozuelo Monfort (pochu) wrote :

Can you test if installing libwxgtk2.8-0_2.8.3.0-0ubuntu1_i386.deb and libwxbase2.8-0_2.8.3.0-0ubuntu1_i386.deb from http://emilio.pozuelo.org/deb/ solves this issue?

Thanks
Emilio

Changed in amule:
status: Unconfirmed → Confirmed
Dave Hall (skwashd) wrote :

Still no good here using feisty final with the above debs

Hugin (karsten-loh) wrote :

Given that I run a 64 bit Feisty, installing those packages would require using the force option. I've some doubts that's a wise idea in this case.

Luca Aluffi (aluffilu) wrote :

I've tried too but it still doesn't works. Backed up to old libw*-

Emilio Pozuelo Monfort (pochu) wrote :

Could you please install the libwxgtk and libwxbase symbol packages from http://people.ubuntu.com/~pitti/ddebs/pool/universe/w/wxwidgets2.8/ and the amule one from http://people.ubuntu.com/~pitti/ddebs/pool/universe/a/amule/ and get a backtrace? You can follow this tutorial:

https://wiki.ubuntu.com/Backtrace

I would do it, but I can't reproduce this.

Thanks
Emilio

Hugin (karsten-loh) wrote :

Sorry for the delay, I was away during the week. The backtrace your requested is attached. Hope it helps.

Karsten

Robb Topolski (funchords) wrote :

I also had a crash while using "Update Now" and fetching the ipfilter from http://www.bluetack.co.uk/config/nipfilter.dat.gz. There were no error messages, the application simply spontaneously closed.

This occurred twice.

The first time, I went to Preferences - Security and did the following:
1. Checked "Enable IP-Filtering"
2. Checked "Auto-update ipfilter at startup"
3. Added the URL: http://www.bluetack.co.uk/config/nipfilter.dat.gz
4. Clicked Update Now
As the progress bar passed 50%, the active parts of the progress window went grey (the application color) and then the application simply disappeared from the screen. Upon re-opening the application and going back into Preferences, none of my changes were there (which is expected as I never pressed "OK."

The second time, I went to Preferences - Security and did the following:
1. Added the URL: http://www.bluetack.co.uk/config/nipfilter.dat.gz and pressed OK, then re-opened Preferences
2. Checked "Enable IP-Filtering"
3. Checked "Auto-update ipfilter at startup"
4. pressed OK, then re-opened Preferences
5. Clicked Update Now
Similar to before, as the progress bar passed 50%, the active parts of the progress window went grey (the application color) and then the application simply disappeared from the screen. Upon re-opening the application, the file apparently was successfully fetched. My log contains the comment that 166315 IP-ranges were loaded from ipfilter.dat.

Subsequent restarts of the application are also successful.

I don't know if this additional note is useful, but I do not have "Autoconnect on startup" checked. This means that I was connected when I was in the Preferences dialog and getting the crash on "Update Now," but I was not connected when the list was successfully fetched.

I hope this helps reproduce the problem and/or provides a workaround.

-- Robb

Alberto (albertop) wrote :

The same problem still occurs with Gutsy and amule 2.1.3-3ubuntu1.

Hugin (karsten-loh) wrote :

I really think it might be the best if the Ubuntu specific changes are undone. I'm not sure what they are supposed to achieve, but it appears that they do more damage then good.

Up till Gutsy I used the normal Debian version of aMule, which worked well (during Feisty Beta it eat a lot of CPU power, but that problem went away after some update before the Feisty went live). Every once in a blue moon it crashed (simply closing itself), but that was the only problem.

Now with Gutsy the version form the Debian repositories does not work any longer. It complains about an unmet dependency (I forgot what it was, but Ubuntu has a newer version of that file which the Debian aMule won't accept). So I compiled an aMule 2.2 Version from a CVS. Despite being only development snapshoots this Version served me since the Gutsy release without a hitch.

So, for me at least, the only version of aMule that really causes problems with Ubuntu is the one in the Ubuntu repositories, the one modified by the Ubuntu developers, hmmmm. :)

Karsten

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

2007/11/5, Hugin <email address hidden>:
> I really think it might be the best if the Ubuntu specific changes are
> undone. I'm not sure what they are supposed to achieve, but it appears
> that they do more damage then good.

Well... I'm almost agree with you, especially for packages already
present into Debian in an updated version.
I switched from Debian to Ubuntu to get more support for new hardware in
a _stable_ distribution, but with Gutsy I'm very disappointed: I found
experienced 3 bugs in a week, too much for a _stable_ distribution (and
in addition I still have some problems not so understandable with the
network).

- --
AlbertoP
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iQIVAwUBRy9olH8GxaRYq2C+AQLg9w/7BqaxnDmYEIdsVfDdBwbZyEv51cUk+cOo
auq/ns1/dxxk4+YG3u3xVLWGVKwGPFAIuPGmiwU6yqDvztUsjHLsqV87iqUbINLC
okGvI4DH83wXOxv4MFOMogDntdeIgAtgRz09Qm8jbCbBYgW9PC2gjgitPdtDO+4L
8fh395pNSqQIst//MP5Chv0s5IWCKGxygna5HV5TvOLCksi8XTEuY+M3gxzat2Nu
BMcPC53g4r90glMpeIYRXvXVzEBDs0i+dGodW6VkvFbPV1wKeF+d597ikTSstOfy
czmUczmTDYI6wqBVs/aqgFD9cCHHCVsxZe9LjTw77YsIUpYP6mLYf4GohEFNlvD7
LIKog5ci9p4K77B1onvinRhRke2Ml52ODH/cmUcP8UcqrDLOTin7114HgeLZktA3
NQnyzO954GJy4AATg5C+cOxjG4g12LmNCsFBZKRq71ed3n3p8O3foecjs3wtI5bd
DhVF/JeMATIa/XOZAb9BBGRtylARFvtVQmEeL1OCM7NGJZVnNLnRTKv6Fl1XwbH6
1Rq1oG22WrMYd050tIKdchaWMIQUQGWG0aEXTELMa5TSllnCF8xjVbQdse6JWUqT
h1m9s9yNYQ8+qzPuCLN1x0Jhwqijfo3WbhAAGCku5JmZKYkQALs8zqNHyWfeuGTs
n7EGWHaupBQ=
=d8+u
-----END PGP SIGNATURE-----

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments