Ubuntu

amulegui does not start in Hardy Heron

Reported by erlguta on 2008-03-25
10
Affects Status Importance Assigned to Milestone
amule (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amule-utils-gui

Amulegui does not run in Kubuntu Hardy Heron beta 8.04

# dpkg -l amule*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nombre Versión Descripción
+++-======================-======================-============================================================
un amule-common <ninguna> (no hay ninguna descripción disponible)
ii amule-utils-gui 2.2.0~svn20080218-0ubu graphic utilities for aMule

When i start amulegui it prompt the login window (ip, port, user and password) because i have the core in one server and i does not start
# amulegui
Connecting...
Going to event loop...

and nothing happens in the console...

erlguta (gonzalomarcote) wrote :

I would like to rename the subject because it is not very descriptive. sorry.
For example:
"amulegui does not start in Hardy Heron"

Thank you.

Emilio Pozuelo Monfort (pochu) wrote :

You mean it starts but doesn't connect to the remote amule, right?

erlguta (gonzalomarcote) wrote :

Yes, because if i put another password (that i know is wrong), it is the same. I see in the console:

$ amulegui
Connecting...
Going to event loop...

In gutsy it worked ok, i have just upgrade to hardy beta, but i remember that we had the same problem caused by xserver-xorg-core:
http://forum.amule.org/index.php?topic=14258.0

PD: Can one admin to change the tittle to one more descriptive, please?

Georg Pichler (georgpichler) wrote :

Confirming this behaviour with current Hardy.

Anton Melser (melser-anton) wrote :

+1

isazi (isazi) wrote :

I'm running Ubuntu 8.04 and amulegui starts but do nothing.

Trying to strace I've found that:

gettimeofday({1212861480, 431953}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}], 2, 19) = 0
gettimeofday({1212861480, 451550}, NULL) = 0
read(5, 0x8340d3c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1212861480, 451640}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}], 2, 0) = 0
gettimeofday({1212861480, 451701}, NULL) = 0
read(5, 0x8340d3c, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1212861480, 451753}, NULL) = 0

josu (josu-onandia) wrote :

I run the amule daemon in a small embedded Debian box, and the amulegui in a PC with Ubuntu. It worked fine, but since I updated to 8.04 I had this same behavior: When I launch amulegui the dialog pops up but it never connects to the server.

I'm sorry but I don't have the time to actually run the code through a debugger, but reading the code I've learned this:

In the connection process amulegui exchanges some information with the target, including some 'protocol version'. If the client and server don't agree on this number the connection is rejected. The number interchanged is different in the SVN version. In the function ExternalConn::Authenticate it states that

            // For release versions, we don't want to allow connections from any arbitrary SVN client.

It seems that a SVN version gui cannot communicate with a 'release' version daemon.

I have installed by hand the package amule-utils-gui_2.1.3-1_i386.deb and now amulegui is working again.

I would suggest to re-generate the package as NON-SNV. And I would suggest too that in the gui, if a connection is rejected, a dialog box with a clear message pop up.

I hope this helps.

erlguta (gonzalomarcote) wrote :

Yes i confirm it. It you have installed both, amule-utils-gui and amule-daemon with the same version 2.2.1 and no svn, now it works, so it seems to be no a Hardy bug, isnt it?

erlguta (gonzalomarcote) wrote :

I explain it better.
I had the same situation as Josu. I have one embebed server with Debian and amule-daemon server running with version 2.1.3
In my laptop with kubuntu Hardy, amule-utils-gui upgraded to 2.2.1 version and there seems to be any kind of incompatibility with diferent versions.
So what i did, is upgrade the amule core daemon in my debian server to 2.2.1 ando now amule-utils-gui conects ok.
It seems not to be one ubuntu bug.
Should this bug be closed?
What do you think?

PD: excuse my bad English

josu (josu-onandia) wrote :

I don't agree, the bug cannot be closed.

First, you updated the package amule-utils-gui to 2.2.1. From where? Synaptic tells me that the latest version is 2.2.0~svn20080218-0ubuntu4. What I asked to the package maintainer is to update to a 'non-svn' version.

Second, you had to update the server too! I dont want to do this. In fact, I don't know if it will be possible. What I would like is for amule-gui to be compatible with ancient embedded versions of the daemon.

Although the second issue is not specific to Ubuntu, the first certainly is.

Best regards.

Anton Melser (melser-anton) wrote :

sudo apt-get update && apt-get dist-upgrade
will update your system to 2.2.1. It's been there for a while.

josu (josu-onandia) wrote :

Hi Anton,

Thanks for the tip, but it doesn't work in my PC. have still the 2.2.0~svn20080218-0ubuntu4 version.

Could be related to the system configuration. I don't master the package management system. Perhaps the new version is in the english repository, but not in the spanish one. I don't know. I've tried from synaptic, from the update-manager and from the command line you provided me, with no sucess.

Anton Melser (melser-anton) wrote :

how about the correct line (:-))
$ sudo apt-get update && sudo apt-get dist-upgrade
?
Can you post the output of that and your /etc/apt/sources.list?
Cheers

josu (josu-onandia) wrote :
Download full text (4.5 KiB)

Hi, this is the content of my /etc/apt/sources.list (comments removed for clarity):

# deb cdrom:[Ubuntu 8.04 _Hardy Heron_ - Beta i386 (20080319)]/ hardy main restricted

deb http://archive.ubuntu.com/ubuntu/ hardy main restricted

deb http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted

deb http://archive.ubuntu.com/ubuntu/ hardy universe
deb http://archive.ubuntu.com/ubuntu/ hardy-updates universe

deb http://archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://archive.ubuntu.com/ubuntu/ hardy-updates multiverse

# deb http://es.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

# deb http://archive.canonical.com/ubuntu hardy partner
# deb-src http://archive.canonical.com/ubuntu hardy partner

deb http://archive.ubuntu.com/ubuntu/ hardy-security main restricted
deb http://archive.ubuntu.com/ubuntu/ hardy-security universe
deb http://archive.ubuntu.com/ubuntu/ hardy-security multiverse
# deb http://wine.budgetdedicated.com/apt hardy main
==========================

The output of the command (yes, I've used the correct one :)

$ sudo apt-get update && sudo apt-get dist-upgrade
Obj http://archive.ubuntu.com hardy Release.gpg
Obj http://archive.ubuntu.com hardy/main Translation-es
Obj http://packages.medibuntu.org hardy Release.gpg
Ign http://packages.medibuntu.org hardy/free Translation-es
Obj http://wine.budgetdedicated.com hardy Release.gpg
Ign http://wine.budgetdedicated.com hardy/main Translation-es
Obj http://archive.ubuntu.com hardy/restricted Translation-es
Obj http://archive.ubuntu.com hardy/universe Translation-es
Obj http://archive.ubuntu.com hardy/multiverse Translation-es
Obj http://archive.ubuntu.com hardy-updates Release.gpg
Ign http://archive.ubuntu.com hardy-updates/main Translation-es
Ign http://archive.ubuntu.com hardy-updates/restricted Translation-es
Ign http://archive.ubuntu.com hardy-updates/universe Translation-es
Ign http://archive.ubuntu.com hardy-updates/multiverse Translation-es
Obj http://archive.ubuntu.com hardy-security Release.gpg
Ign http://packages.medibuntu.org hardy/non-free Translation-es
Obj http://packages.medibuntu.org hardy Release
Obj http://wine.budgetdedicated.com hardy Release
Ign http://archive.ubuntu.com hardy-security/main Translation-es
Ign http://archive.ubuntu.com hardy-security/restricted Translation-es
Obj http://packages.medibuntu.org hardy/free Packages
Ign http://wine.budgetdedicated.com hardy/main Packages
Ign http://archive.ubuntu.com hardy-security/universe Translation-es
Ign http://archive.ubuntu.com hardy-security/multiverse Translation-es
Obj http://archive.ubuntu.com hardy Release
Obj http://archive.ubuntu.com hardy-updates Release
Obj http://packages.medibuntu.org hardy/non-free Packages
Obj http://wine.budgetdedicated.com hardy/main Packages ...

Read more...

Fabrice Coutadeur (fabricesp) wrote :

version 2.2.1 will be in Intrepid (Not officially in Hardy).

Daniel T Chen (crimsun) on 2008-12-04
Changed in amule:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers