aMule makes bad hashlinks (ed2k://)

Bug #187041 reported by usr
2
Affects Status Importance Assigned to Milestone
AMule
Fix Released
Unknown
amule (Ubuntu)
Low
Unassigned

Bug Description

aMule can use eMule and aMule hashlinks. But eMule can not use aMule hashlinks.

Revision history for this message
usr (usrlp) wrote :

Tested with aMule 2.1.3.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

I don't have aMule/windows handy so I can't test this. Could you test if this ed2k link from aMule 2.2.0 svn works in eMule? (right clicked a file and selected "copy ed2k link to clipboard").

Thanks.

 ed2k://|file|[Linux] Ubuntu 7.10 desktop i386.iso|729608192|55733BA0811FF6D8F15DD39B0F40773C|/|/

Changed in amule:
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
usr (usrlp) wrote :

I go to try it. But, can you make a hashlink with AICH info too?

P.S: I tested the bug in Kubuntu 7.04 and 7.10.

Revision history for this message
usr (usrlp) wrote :

I have tried your hashlink. The results:
- aMule 2.1.3: No problem.
- eMule 0.48a: Error message: "Invalid link: This eD2K link is invalid (Not an eD2K server or file link)".

Revision history for this message
usr (usrlp) wrote :

aMule's bug-tracker report: http://bugs.amule.org/view.php?id=1260

Christian Reis (kiko)
Changed in amule:
importance: Undecided → Unknown
status: New → Unknown
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

The issue was that some characters weren't scaped properly.

This should be fixed now in Hardy. Could you check this link in eMule?
ed2k://|file|Linux%20Ubuntu%20Ita%20v.7.04%20desktop%20i386.iso|739139584|29E3D75C2E48E43218EB05B28459AA8B|/

Revision history for this message
usr (usrlp) wrote :

The last elink works OK in eMule and aMule.
You can close this bug.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Great, thanks for confirming.

Bug closed as fixed.

Changed in amule:
status: Incomplete → Fix Released
Revision history for this message
usr (usrlp) wrote :

Now the bug is not on aMule, but yes in the aMule 2.2.0 SVN old version of the Ubuntu 8.04 repository.

Changed in amule:
status: Fix Released → Fix Committed
Revision history for this message
Kevin (kevin64-deactivatedaccount) wrote :

You are referring to the current version of aMule in hardy repositories?

Revision history for this message
usr (usrlp) wrote :

Yes, it is.

Revision history for this message
usr (usrlp) wrote :

http://www.amule.org/: aMule 2.2.1 released!

Please, update for Ubuntu 8.04.1.

Revision history for this message
Kevin (kevin64-deactivatedaccount) wrote : Re: [Bug 187041] Re: aMule makes bad hashlinks (ed2k://)

We are working on it, but perhaps now it would be better to wait for a
possible bugfix release within one or at most 2 weeks.
At the moment I suggest you use repositories unofficial but in case you have
any problems with them do not report here, please

http://forum.amule.org/index.php?topic=15249.0

2008/6/16 usr <email address hidden>:

> http://www.amule.org/: aMule 2.2.1 released!
>
> Please, update for Ubuntu 8.04.1.
>
> --
> aMule makes bad hashlinks (ed2k://)
> https://bugs.launchpad.net/bugs/187041
> You received this bug notification because you are subscribed to amule
> in ubuntu.
>

Revision history for this message
Kevin (kevin64-deactivatedaccount) wrote :

Fix released in Intrepid (aMule 2.2.1)

Changed in amule:
status: Fix Committed → Fix Released
Changed in amule:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.