Unable to login to aMSN after latest updates

Bug #352814 reported by amw3465 on 2009-04-01
58
This bug affects 3 people
Affects Status Importance Assigned to Milestone
amsn (Ubuntu)
High
Adrien Cunin

Bug Description

Binary package hint: amsn

I'm using Ubuntu 9.04 beta, aMSN was working (but still no webcam fix) and after todays security ect updates I cannot log on, its been like that since this morning. All I get is a the aMSN screen trying to log on and it sticks like that. I can access the same msn account via webmessenger so I suggest that some thing in the updates has broken aMSN.

Related branches

Thank you for reporting this issue, it helps make Ubuntu better. Confirmed.

Changed in amsn:
status: New → Confirmed
Jorge Gustavo (jgr) wrote :

Hi,

My aMSN does not login anymore (amsn 0.97.2~debian-1ubuntu3, kernel 2.6.28-8-server, jaunty 9.04).
I don't know how to debug it.
I've just tried:
mv .amsn .amsn.old
to startup with all defaults, but the same problem: unable to login.
The networks seems ok.
Pidgin works.

Regards,

Jorge

JoelD (shadybeatle) wrote :

I've had the exact same issue. Since running updates Amsn continues to try to log in, but can't connect.
I tried other clients and they connected ok.

I did try to uninstall Amsn and reinstall through synaptic, but it didn't change anything.

Gerardo Contreras (gera-gera) wrote :

Confirmed. amsn doesn't connect.

Is somebody working on this issue?

Well I really hope so as not only can we now not connect to aMSN but the web
cam problem still hasnt been fixed either! I heard that there was a fix or
workaround about 4 weeks ago. I've recently moved from Windows and this is
now starting to annoy me. In my opinion this sort of thing may make some
windows users trying Ubuntu to move straight back to windows. Most windows
users use msn as their instant messenger client and for me personally amsn
is a super alternative in fact I'd go as far as to say it beats the current
windows live messenger and certainly easily beats all the other Linux msn
clones both in looks and features.

2009/4/2 Gerardo Contreras <email address hidden>

> Confirmed. amsn doesn't connect.
>
> Is somebody working on this issue?
>
> --
> Unable to login to aMSN after latest updates
> https://bugs.launchpad.net/bugs/352814
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “amsn” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: amsn
>
> I'm using Ubuntu 9.04 beta, aMSN was working (but still no webcam fix) and
> after todays security ect updates I cannot log on, its been like that since
> this morning. All I get is a the aMSN screen trying to log on and it sticks
> like that. I can access the same msn account via webmessenger so I suggest
> that some thing in the updates has broken aMSN.
>

Annabelle Van Gelder (waxje) wrote :

for the people who like to work with windows alike messengers, there is still emesene. or kmess as a temporary solution.

I tried installing amsn trough there autopackage to see if it also gives problems. It does, i got an error telling me tkcximage failed. After some research i found out this error happens when different versions of tcl are installed (8.4 and 8.5 in my case).
I deleted amsn-data and reinstalled amsn(tcl8.5) trough autopackage(did not touch tcl) and amsn installed but the problem remains. Not able to connect.

Nex thing i tried was installing amsn(tcl8.4 version) witch gave me a tk error, so i had to install tk8.4
it downloaded x86 version of msn protocol(amsn asks when starting up) and i am able to get online :D

i'm going to try install tk 8.5 and then install trough autopackage to see if it also works.

Annabelle Van Gelder (waxje) wrote :

update: tk8.5 + autopackage gives me the tcximage failed error again and a load of 'cp: not writing through dangling symlink ' errors when installing.
also tk8.5+amsn deb package won't work.

So to use amsn i needen to go to console and install

sudo apt-get install tk8.4

download distribution independent installer for those who already have Tcl/Tk 8.4

http://prdownloads.sourceforge.net/amsn/amsn-0.97.2-1.tcl84.x86.package

make the file executable in file properties

Install (this also installs autopackage wich you need to remove amsn when you want to use the deb version again(it can be found in applications=> system tools)

enjoy amsn untill deb package is fixed :)

Endless (vaillancourta34) wrote :

i've tried what wax suggested and i get this error message in a small box :

The autopackage support code could not be installed.

It can be manually downloaded and installed by running the
installation script located in the downloaded archive.

So in the end, i can't install aMSN with the tcl/tk8.04 and since aMSN refuse to install, i'm still can't use aMSN. By the way Plasma just closed unexpectingly. Must be because the last update (done less then 2 hours ago on april 2th) If the bug returns after i reboot i'll offically report it in a new bug topic.

Tx anyway for your efforts.

Annabelle Van Gelder (waxje) wrote :

@ endless,
make sure you meet dependencies of autopackage. If install fails, install trough your terminal, there you can mostly find more information about the difficulty you're facing.

 if your amsn does not want to install from synaptic, then you're probably facing some other difficulty.

I guess users must also be aware of the fact this bug is appearing in a BETA version of ubuntu witch is not a fully functional environment...

Just to make sure this is not a complete off topic post I'll post my kernel information
Linux ***-laptop 2.6.28-11-generic #39-Ubuntu SMP Thu Apr 2 03:00:35 UTC 2009 i686 GNU/Linux
 Ubuntu 9.04 - de Jaunty Jackalope

Jeff (jeffmart) wrote :

Same problem here, in a Intrepid to Jaunty upgrade (with upgrades by hour now!). And same temporary solution: tk 8.4, with autopackge install! I just lost one plugin, that needed tk 8.5. Oh, sure, and the smooth fonts, that was cool. But at least, now, it can connect! Thx!

Changed in amsn (Ubuntu):
assignee: nobody → motu
Adrien Cunin (adri2000) wrote :

The culprit is the recent tcl update.
I'm going to merge amsn from Debian unstable which has a fix for this bug.

Changed in amsn (Ubuntu):
assignee: motu → adri2000
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amsn - 0.97.2~debian-2ubuntu1

---------------
amsn (0.97.2~debian-2ubuntu1) jaunty; urgency=low

  * Merge from Debian unstable, fixes login issue with tcl 8.5.6 (LP: #352814)
    Remaining Ubuntu changes:
     - Added patch 04_use_xdg-open, added xdg-utils dependency
     - Added patch 08_use_aplay_for_sound
     - Added libv4l support: build-dep on libv4l, add -DHAVE_LIBV4L to CFLAGS,
       add patch 09_libv4l_svn10551
     - Added patches 10_svn10639 and 11_svn10867
     - debian/control: iceweasel -> firefox | abrowser, sox -> alsa-utils

amsn (0.97.2~debian-2) unstable; urgency=low

  * aMSN is now able to work with version 8.5.6 of tcl/tk8.5.
    (Closes: #517230, #460611)
  * debian/control: Dependency on libsnack2 was changed to libsnack2-alsa
    instead. (Closes: #512262)

 -- Adrien Cunin <email address hidden> Fri, 03 Apr 2009 23:03:03 +0200

Changed in amsn (Ubuntu):
status: In Progress → Fix Released
Endless (vaillancourta34) wrote :

Tx buti only have one question remaining, is this new package be aviable on unbuntu/kubuntu repositories or i'll hav to download it from the amsn website and compile it manually?

Endless (vaillancourta34) wrote :

Update ... I've downloaded the new package amsn 0.97.2~debian-2ubuntu1 from here :

http://packages.debian.org/squeeze/i386/amsn/download

i choose a server and dl the .deb file

then i've dl this file (because amsn will not install without it)

http://packages.debian.org/squeeze/all/amsn-data/download

again i've choose a server and dl the file

then i installed the amsn-data first with gdebi, then amsn

now eveything works fine

THANKS A LOT for your great efforts, i really apreciate it.

BTW, i had to uninstall the old amsn version(0.97.2~debian-1ubuntu3) before i could install amsn-data from the new package.

Gerardo Contreras (gera-gera) wrote :

it seems it's available through the normal repositories (universe, I guess)...
I'm gonna try that way...

On Friday 03 April 2009 17:55:30 Endless wrote:
> Update ... I've downloaded the new package amsn 0.97.2~debian-2ubuntu1
> from here :
>
> http://packages.debian.org/squeeze/i386/amsn/download
>
> i choose a server and dl the .deb file
>
> then i've dl this file (because amsn will not install without it)
>
> http://packages.debian.org/squeeze/all/amsn-data/download
>
> again i've choose a server and dl the file
>
> then i installed the amsn-data first with gdebi, then amsn
>
> now eveything works fine
>
> THANKS A LOT for your great efforts, i really apreciate it.
>
> BTW, i had to uninstall the old amsn version(0.97.2~debian-1ubuntu3)
> before i could install amsn-data from the new package.

Gerardo Contreras (gera-gera) wrote :

yup, that's right...

apt-get upgrade did the job

Thanks guys.

On Friday 03 April 2009 18:20:52 Gerardo Contreras wrote:
> it seems it's available through the normal repositories (universe, I
> guess)... I'm gonna try that way...
>
> On Friday 03 April 2009 17:55:30 Endless wrote:
> > Update ... I've downloaded the new package amsn 0.97.2~debian-2ubuntu1
> > from here :
> >
> > http://packages.debian.org/squeeze/i386/amsn/download
> >
> > i choose a server and dl the .deb file
> >
> > then i've dl this file (because amsn will not install without it)
> >
> > http://packages.debian.org/squeeze/all/amsn-data/download
> >
> > again i've choose a server and dl the file
> >
> > then i installed the amsn-data first with gdebi, then amsn
> >
> > now eveything works fine
> >
> > THANKS A LOT for your great efforts, i really apreciate it.
> >
> > BTW, i had to uninstall the old amsn version(0.97.2~debian-1ubuntu3)
> > before i could install amsn-data from the new package.

Vangelis Tasoulas (cyberang3l) wrote :

Today I upgraded my intrepid to jaunty and I still have this bug...

Did you do anything else instead of just an upgrade?

Jorge Gustavo (jgr) wrote :

Hi,

I have amsn version 0.97.2~debian-2ubuntu1 installed and it works.
Just the upgrade was necessary to get it work again.

Regards,

Jorge

Sáb, 2009-04-11 às 16:21 +0000, Vangelis Tasoulas escreveu:
> Today I upgraded my intrepid to jaunty and I still have this bug...
>
> Did you do anything else instead of just an upgrade?
>
--
jorge gustavo rocha
departamento de informática
universidade do minho
4710-057 braga
portugal
N 41º33'44,5" W 8º23'40,5"
tel +351 253604470 fax +351 253604471 cel +351 927210173

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers