Sync ampache 3.5.1-2 (universe) from Debian unstable (main)

Bug #480540 reported by Charlie_Smotherman on 2009-11-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ampache (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync ampache 3.5.1-2 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
the sql injection vulnerability has been included in Debian.
Debian is now using a patch system and is also using a shortened dh7
rules file.

Note that I have per-package upload permissions for ampache.

Changelog entries since current lucid version 3.5.1-1ubuntu2:

ampache (3.5.1-2) unstable; urgency=low

   * Added quilt to debian/control Build Depends section.
   * Added debian/patches
   * Added debian/patches/01_mysql_real_escape_string. mysql_escape_string() is
     depreciated and mysql_real_escape_string() should be used instead. This is
     needed to correct for a possible sql_injection vulnerability.
   * Changed debhelper to (>=7.0.50), this is needed for dh overrides.
   * Bumped Standards Version to 3.8.3 no changes needed.

 -- Charlie Smotherman <email address hidden> Sun, 18 Oct 2009 23:55:24 -0500

Changed in ampache (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Steve Kowalik (stevenk) wrote :

[Updating] ampache (3.5.1-1ubuntu2 [Ubuntu] < 3.5.1-2 [Debian])
 * Trying to add ampache...
  - <ampache_3.5.1-2.dsc: downloading from http://ftp.debian.org/debian/>
  - <ampache_3.5.1-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <ampache_3.5.1.orig.tar.gz: already in distro - downloading from librarian>
I: ampache [universe] -> ampache_3.5.1-1ubuntu2 [universe].

Changed in ampache (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers