amd64-microcode better initramfs hook

Bug #1840670 reported by Dimitri John Ledkov on 2019-08-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amd64-microcode (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

 * It is hard to generate initrd, with all microcodes included because the initramfs hook ignores
   preset defaults. Adjust hook to take preset defaults into account.

[Test Case]

 * Install new package, and check that initrd with default settings (i.e. modules=most) has amd64
   microcode included. And that with modules=dep|list it only does so, if one is on AMD cpu.

 * Install initramfs-tools-ubuntu-core from snap image PPA, the resulting initrd should contian
   both amd64 and intel microcode, despite using modules=list, due to the conf.d default settings
   it overrides.

[Regression Potential]

 * The hook default behaviour is not changed, only integration with custom conf.d's is improved.

Changed in amd64-microcode (Ubuntu):
status: New → Fix Released
Changed in amd64-microcode (Ubuntu Disco):
status: New → In Progress
Changed in amd64-microcode (Ubuntu Bionic):
status: New → In Progress
Changed in amd64-microcode (Ubuntu Xenial):
status: New → In Progress

Hello Dimitri, or anyone else affected,

Accepted amd64-microcode into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/amd64-microcode/3.20181128.1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in amd64-microcode (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Robie Basak (racb) wrote :

> It is hard to generate initrd, with all microcodes included because the initramfs hook ignores preset defaults.

How does this impact users: why might a user want to generate such an initrd and what breaks by not being able to do it?

If another SRU team member already understands then that's fine, but I don't think that I can accept an SRU unless I can understand why we're doing it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers