[regression] cyclic reboot caused by the amd microcode updater

Bug #1779092 reported by lvm on 2018-06-28
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
amd64-microcode (Ubuntu)
High
Steve Beattie

Bug Description

It happened like this:

using kernel 3.13.0-144 (14.04) - ok
jun 9: installed kernel 3.13.0-149 and rebooted - ok
jun 21: installed some updates including update to the cpu microcode which was set up to execute at the next boot
jun 28: rebooted to the same kernel 149 and the system went into cyclic reboot: shows grub screen, when the default kernel is selected reboots immediately with no messages and without creating any logs, nothing in /var/log with appropriate times
booted to 144 - no issues
tried upgrading to a new kernel (151) - same cyclic reboot
booted back to 144

I am not telling the microcode update is the culprit, but it is mighty suspicious. It cannot be uninstalled using standard tools without uninstalling the kernels packages (linux-generic, linux-image-generic, linux-generic-pae, linux-image-generic-pae). I have both intel-microcode and amd64-microcode installed (CPU is AMD phenom X4 975).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8.1
ProcVersionSignature: Ubuntu 3.13.0-144.193-generic 3.13.11-ckt39
Uname: Linux 3.13.0-144-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.29
Architecture: i386
Date: Thu Jun 28 13:04:38 2018
InstallationDate: Installed on 2011-08-18 (2505 days ago)
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to trusty on 2014-10-18 (1349 days ago)

lvm (lvm-royal) wrote :
lvm (lvm-royal) on 2018-06-28
affects: xorg (Ubuntu) → amd64-microcode (Ubuntu)
summary: - cyclic reboot with latest kernels possibly related to the cpu microcode
- updater
+ cyclic reboot caused by the amd microcode updater

I rolled back the amd64-microcode to the previous version (3.20180524.1~ubuntu0.14.04.1 to 2.20131007.1+really20130710.1) and it resolved the issue, I can now boot to 151, so it is definitely related to amd64-microcode. I am using AMD Phenom(tm) II X4 975 Processor

tags: added: regression-update
summary: - cyclic reboot caused by the amd microcode updater
+ [regression] cyclic reboot caused by the amd microcode updater
Changed in amd64-microcode (Ubuntu):
importance: Undecided → High
Tony Smith (v1i9v6a6) wrote :

FYI. I am hit by this problem too. Updated system in Synaptic on 26th which included
Upgrade: amd64-microcode:amd64 (2.20131007.1+really20130710.1, 3.20180524.1~ubuntu0.14.04.1)

Had previously installed (2 weeks ago) linux-image-extra-3.13.0-151-generic:amd64 (3.13.0-151.201)

Now system hangs with black screen. Running in recovery mode the last two lines are
x86: Booting SMP configuration:
.... node #0: CPUs #1

Booting back in 3.13.0-149 works fine.

smpboot: CPU0: AMD Athlon(tm) II X4 600e Processor (fam: 10, model: 05, stepping: 02)
Gigabyte Technology Co., Ltd. GA-MA785GM-US2H/GA-MA785GM-US2H, BIOS F12a 07/08/2010

Hope this helps.

Changed in amd64-microcode (Ubuntu):
assignee: nobody → Steve Beattie (sbeattie)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amd64-microcode (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Could you test the new version of amd64-microcode which has been uploaded to trusty-proposed?

Steve Beattie (sbeattie) wrote :

Thanks for the report, sorry for the problems you're experiencing. I have uploaded a revert update for the amd64-microcode package to the ubuntu-security-proposed ppa https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa ; it would be appreciated to confirm that upgrading to that version does not cause problems.

Tony Smith (v1i9v6a6) wrote :

Thank you Steve, that has resolved the problem.
Tony.

malbo (pique-sel) wrote :

The solution proposed by Steve in comment #6 works for me too (my processor is AMD Phenom 9500 and I was affected by this bug)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amd64-microcode - 3.20180524.1~ubuntu0.14.04.2+really20130710.1

---------------
amd64-microcode (3.20180524.1~ubuntu0.14.04.2+really20130710.1) trusty-security; urgency=medium

  * REGRESSION UPDATE: revert to 2.20131007.1+really20130710.1 due to
    3.20180524.1~ubuntu0.14.04.1 causing boot looping for some AMD
    processors (LP: #1779092)

 -- Steve Beattie <email address hidden> Tue, 03 Jul 2018 14:11:11 -0700

Changed in amd64-microcode (Ubuntu):
status: Confirmed → Fix Released
Tyler Hicks (tyhicks) wrote :

I wanted to shed some more light on this issue and our decision making after hearing of at least one person that saw this update and thought that this was a regression in the microcode provided by AMD. While we don't yet know the actual cause of this issue, a regression introduced in the microcode itself is not at the top of our list of suspicions. We haven't heard of any similar reports in Ubuntu 16.04 LTS, Ubuntu 17.10, or Ubuntu 18.04 LTS which all received the same microcode updates.

We suspect that it has something to do with the combination of 3.13 kernel's support for early microcode loading, the packaging for the amd64-microcode package, and/or the initramfs generation when injecting new AMD microcode. We're still investigating the cause and will release additional updates when we've tracked down the solution.

Steve Beattie (sbeattie) wrote :

To follow up on Tyler's comment, I have placed amd64-microcode 3.20180524.1~ubuntu0.14.04.3 in the ubuntu-security-proposed ppa (https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/) that keeps the packaging the same as before, but includes the 17h family microcode (along with an update for 16h family as well). It woul dbe great if people with various AMD processors could test this, both to confirm that things successfully boot and that the microcode is loaded (should be reported in dmesg).

Including the output of the 'lscpu' command in any feedback would especially be appreciated.

Thanks!

Serg (frast) wrote :

SB> It woul dbe great if people with various AMD processors could test this

CPU: 'AMD E-300 APU with Radeon(tm) HD Graphics'
dmesg and lscpu logs in attacchment

Thanks

Klaus Christiansen (kec2) wrote :

The latest update does not solve it for me.
Ubuntu server 18.04
I have a AMD 2300G processor.

I can start my server if I choose this kernel Linux 4.15.0-24-generic x86_64 but not the latest (linux-image-4.15.0-29-generic).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers