Ubuntu

amaya segmentation fault on launch

Reported by ushimitsudoki on 2008-12-02
6
Affects Status Importance Assigned to Milestone
amaya (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amaya

Ubuntu 8.10 amd64

Immediately after installing amaya, if trying to run it:
jason@apollo:~$ amaya
Segmentation fault

/usr/bin/amaya is a symlink to /usr/lib/Amaya/wx/bin/amaya. Editing the last line from:
env XLIB_SKIP_ARGB_VISUALS=1 $PREFIX/$AMAYA_INSTALLDIR/$AMAYAGUI/bin/amaya_bin ${1+$@}
to:
$PREFIX/$AMAYA_INSTALLDIR/$AMAYAGUI/bin/amaya_bin ${1+$@}

(Edited file attached)

Allows me to launch and use the program.

ushimitsudoki (ushimitsudoki) wrote :
stevepb (steveb-dude) wrote :

Same problem on Hardy 8.04.

The fix does not work for my setup, it has exactly the same result before the edit in the amaya script.

Lo_pescofi (corbieres) wrote :

I have the same problem on hardy 8.04 (x386).
The walkarround work for me. (replace "env XLIB_SKIP_ARGB_VISUALS=1 $PREFIX/$AMAYA_INSTALLDIR/$AMAYAGUI/bin/amaya_bin ${1+$@}" to "$PREFIX/$AMAYA_INSTALLDIR/$AMAYAGUI/bin/amaya_bin ${1+$@}" in /usr/lib/Amaya/wx/bin/amaya)

Thanks for the report. Amaya has been removed from debian and ubuntu in
Intrepid. I'm closing this report as "Won't Fix"

 status "Won't Fix"
 subscribe
 tag close-removed-intrepid

Changed in amaya (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments