Missing X-Spam-* headers (no local_domains defined)

Bug #55723 reported by Garrison Hoffman on 2006-08-08
10
Affects Status Importance Assigned to Milestone
amavisd-new (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: amavisd-new

amavisd-new does not produce X-Spam-Level and X-Spam-Status headers even when $sa_spam_report_header and $sa_spam_level_char are explicitly set in /etc/amavis/conf.d/50-user

X-Spam-* headers normally appear when X-Virus-Scanned does, that is, when the spam score surpasses $sa_tag_level_deflt

The default config fails to define @local_domains_maps, ergo no recipient is considered local. This is bad.

Adding either

@local_domains_acl = ( ".$mydomain" );

or

@local_domains_maps = ( [".$mydomain"] );

to the config will fix this problem.

Confirmed.

We could ask for a dapper-updates with bug #42076.

Changed in amavisd-new:
status: Unconfirmed → Confirmed
Ross Golder (ross-golder) wrote :

This is still happening for me on both a dapper and an edgy server.

I've set $sa_tag_level_deflt = -999 and added the the @local_domain_maps to /etc/amavis/conf.d/50-user, restarted amavisd and I'm still not getting these headers.

Ross Golder (ross-golder) wrote :

Scratch that. I hadn't RTFMed the README.Debian. I didn't understand that I was supposed to uncomment the 'bypass'_*_checks in /etc/amavis/conf.d/15-content_filter_mode, so SpamAssassin wasn't even running. Working now.

Jeff (legacyb4) wrote :

I've uncommented the necessary lines in 15-content_filter_mode and while I can verify that both clamav and spamassassin are running, I'm still not seeing the X-SPAM headers of any sort despite what my logs say is "passed SPAM".

Jul 19 11:15:34 ubuntu amavis[21586]: (21586-01) Passed SPAM, [127.0.0.1] <email address hidden> -> <email address hidden>, Message-ID: <email address hidden>, mail_id: eiZzhUxv+Jrn, Hits: 5.579, 318 ms

The message shows up but is not marked as "SPAM" nor does it have the headers.

20-debian_defaults is set to:

$sa_spam_subject_tag = '[SPAM] ';
$sa_tag_level_deflt = -50.0; # add spam info headers if at, or above that level
$sa_tag2_level_deflt = 3.31; # add 'spam detected' headers at that level
$sa_kill_level_deflt = 6.31; # triggers spam evasive actions
$sa_dsn_cutoff_level = 10; # spam level beyond which a DSN is not sent

Any ideas or suggestions to troubleshoot this?

Linux version 2.6.15-26-server (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP Thu Aug 3 04:09:15 UTC 2006
running latest upgraded packages required.

Jeff (legacyb4) wrote :

Okay, worked it out.

Added:

@local_domains_maps =read_hash("/etc/amavis/local_domains");

with a plain text file listing domain names that should be processed at /etc/amavis/local_domains

Thanks.

...or you could do as specified in the top post.

Adam Sommer (asommer) wrote :

Discussed on IRC with ScottK, and I'll add information concerning the @local_domains_* and $mydomain to the Server Guide for Intrepid.

Thanks,
Adam

Adam Sommer (asommer) wrote :

I've added some instructions to the Amavisd-new section of the Server Guide:

  http://doc.ubuntu.com/ubuntu/serverguide/C/mail-filtering.html#amavisd-new-configuration

I think that covers the issue? If anyone see any major issues with the instructions please let me know.

Thanks

Daniel Hahler (blueyed) on 2008-12-09
Changed in amavisd-new:
importance: Undecided → Low
status: Confirmed → Triaged
Alex Muntada (alex.muntada) wrote :

It's been more than 1 year since Adam documented the missing steps on the server guide. No more complaints since then, so I guess we can declare this bug as resolved.

Changed in amavisd-new (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers