Removal of the package does not remove the cron.daily script

Bug #428814 reported by James Clemence on 2009-09-13
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Medium
Thierry Carrez
amavisd-new (Ubuntu)
Low
Thierry Carrez

Bug Description

Ubuntu Jaunty,

When removing amavisd-new it does not remove its cron.daily script, which then gives errors every time it is run. This is easy to remove or disable manually, but makes sense for it to be removed when uninstalled,

Ilogr

Related branches

Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in amavisd-new (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
James Clemence (jvc26) wrote :

Well, it is reproducible (in my experience) - install it, then uninstall it.

To recreate. Install the package, remove the package, and then you will find the scripts in cron.daily.

Il

Mathias Gug (mathiaz) wrote :

The cron job should not be removed on package uninstallation, only on package purge as outlined in the debian policy - section 9.5:

    All files installed in any of these directories must be scripts (e.g., shell scripts or Perl scripts) so that they can easily be modified by the local system administrator. In addition, they must be treated as configuration files.

    [...]

    The scripts or crontab entries in these directories should check if all necessary programs are installed before they try to execute them. Otherwise, problems will arise when a package was removed but not purged since configuration files are kept on the system in this situation.

amavisd-new cron job should make sure that all its relevant binaries are available before running.

Changed in amavisd-new (Ubuntu):
status: Incomplete → Confirmed
Chuck Short (zulcss) on 2009-10-14
Changed in amavisd-new (Ubuntu):
status: Confirmed → Triaged
Thierry Carrez (ttx) on 2010-02-11
Changed in server-papercuts:
importance: Undecided → Medium
status: New → Confirmed
Thierry Carrez (ttx) on 2010-03-02
Changed in server-papercuts:
milestone: none → lucid-beta-2
Thierry Carrez (ttx) on 2010-03-29
Changed in amavisd-new (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Triaged → In Progress
Changed in server-papercuts:
assignee: nobody → Thierry Carrez (ttx)
status: Confirmed → In Progress
Thierry Carrez (ttx) on 2010-03-29
Changed in server-papercuts:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amavisd-new - 1:2.6.4-1ubuntu5

---------------
amavisd-new (1:2.6.4-1ubuntu5) lucid; urgency=low

  * debian/amavisd-new.cron.daily: Fail gracefully if package has been removed
    (LP: #428814)
 -- Thierry Carrez <email address hidden> Mon, 29 Mar 2010 12:05:32 +0200

Changed in amavisd-new (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers