amavisd-new missing dependency (libmail-dkim-perl)

Bug #320785 reported by Andreas Olsson on 2009-01-24
2
Affects Status Importance Assigned to Milestone
amavisd-new (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amavisd-new

This bug report is about the package amavisd-new in Intrepid

Installing amavisd-new, only using its dependencies, leaves amavisd-new in a state where it won't start.

Starting amavisd: Problem in Amavis::DKIM code: Can't locate Crypt/OpenSSL/RSA.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at (eval 82) line 25.
BEGIN failed--compilation aborted at (eval 82) line 25.
(failed).

Installing the Recommended package libmail-dkim-perl (and its dependencies) solves the problem.

Perhaps libmail-dkim-perl should be moved from Recommends to Depends?

Scott Kitterman (kitterman) wrote :

In Intrepid, the default is to install Recommends and so the default amavisd-new config assumes recommends are installed.

Just remove the activation of DKIM from the config file and it will work fine. libmail-dkim-perl is not a hard dependency for amaisd-new that we choose to support in our default configuration.

Changed in amavisd-new:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers