Splash screen hides KDE Wallet Service window

Bug #930277 reported by Daniel Hahler on 2012-02-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Amarok
Invalid
Medium
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Using Unity, the Amarok splash screen is in front of all other windows, especially the "KDE Wallet Service" window.

This makes the impression that Amarok is hanging, while it is just waiting for the password in the "KDE Wallet Service" dialog.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: amarok 2:2.5.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic-pae 3.2.5
Uname: Linux 3.2.0-15-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 10 18:15:42 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: amarok
UpgradeStatus: Upgraded to precise on 2011-12-16 (56 days ago)

Version: 2.5-git (using Devel)
OS: MS Windows

User needs to interact with dialog box when starting Amarok for the first time, but this dialog box cannot be seen or clicked on.

Reproducible: Always

Steps to Reproduce:
1. Start Amarok for the first time (Microsoft Windows)
2. The amarok splash screen appears.
3. Behind the amarok splash screen, an information dialog about submitting bugs / feedback appears . Amarok does not load until the user interacts with this dialog box and this dialog box cannot be seen because the Amarok splash screen is in front of it.
4. Drag the dialog box out from behind the splash screen.
5. Accept the dialog box
6. Amarok continues to load and the splash screen disappears.

 The dialog box pops up behind the splash screen every time Amarok loads unless you check the box telling it to not do so.

Actual Results:
Dialog box that user needs to interact with cannot be seen, but can be just barely dragged out from behind the splash screen by clicking on the border and dragging.

Expected Results:
Dialog box should be in front of Amarok splash screen or Amarok splash screen should disappear when bug reporting / feedback dialog box is displayed.

Windows Vista 64-bit.
Compiled from source. Emerge / git

Also note that if you don't run the post-install script like you're supposed to.. The error box that comes up also is behind the splash screen and cannot be seen.

It's not just the information dialog about submitting bugs/feedback that ends up behind the splash screen it's anything that pops up early when Amarok loads and the Splash screen does not go away until after the dialog boxes are taken care of so they need to be pulled out from behind the splash screen and taken care of before the splash screen will go away.

Problem continues to exist on Windows 7, running Amarok 2.5.

Setting status to confirmed.

Daniel Hahler (blueyed) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amarok (Ubuntu):
status: New → Confirmed
Changed in amarok:
importance: Unknown → Medium
status: Unknown → Confirmed

Could you please test with Amarok 2.6? Also Amarok 2.7 is now in the starting blocks for WIndows as well

Changed in amarok:
status: Confirmed → Incomplete

Closing for lack of feedback. Please feel free to reopen this report if you can reproduce this with Amarok 2.8 or later.

Changed in amarok:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.