amarok crash after 4sec of play

Bug #846709 reported by Sandra Karuving on 2011-09-10
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
High
QtWebKit
Fix Released
Medium
amarok (Ubuntu)
Critical
Michael Terry
Oneiric
Critical
Michael Terry
qtwebkit-source (Ubuntu)
Critical
Felix Geyer
Oneiric
Critical
Felix Geyer

Bug Description

Since yesterday (10th/sept) amarok crashed everytime after a short session of track (mostly 3 or 4 secounds. tried with flac, ogg and mp3 on a new user. the song wich came with amarok(dont know the name) playes without crash. than i scan my collection. after that i sekelct one track to play, click play and crash

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: amarok 2:2.4.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Sun Sep 11 01:23:11 2011
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
SourcePackage: amarok
UpgradeStatus: No upgrade log present (probably fresh install)

Sandra Karuving (lumks) wrote :
Sandra Karuving (lumks) wrote :
Gustaw Smolarczyk (wielkiegie) wrote :

I can confirm the crash.

Note that, removing wikipedia applet works around the crash.

Changed in amarok (Ubuntu):
status: New → Confirmed
Jonathan Riddell (jr) on 2011-09-12
Changed in amarok (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-11.10-beta-2
Myriam Schweingruber (myriam) wrote :

The problem is in Qt, as it only appears with Qt 4.7.4 or higher.

Changed in amarok:
importance: Unknown → High
status: Unknown → Confirmed

And they just fixed the mp3 seeking problem with GStreamer...

Felix Geyer (debfx) on 2011-09-14
tags: added: kubuntu
tags: added: rls-mgr-o-tracking
Márcio Carneiro (marciocr) wrote :

I confirm the behavior indicated by Gustaw. By removing the plug from wikipedia, the crash disappears.

Aurélien COUDERC (coucouf) wrote :

It’s a bug in libQtWebKit4.

https://bugs.webkit.org/show_bug.cgi?id=66016 has a patch !

Michael Terry (mterry) on 2011-09-19
Changed in amarok (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
Felix Geyer (debfx) on 2011-09-19
Changed in qtwebkit-source (Ubuntu Oneiric):
assignee: nobody → Felix Geyer (debfx)
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-2
status: New → In Progress
Michael Terry (mterry) wrote :

debfx will update qtwebkit which has a fix for this. I don't believe amarok needs to be patched, so marking invalid.

Changed in amarok (Ubuntu Oneiric):
assignee: Michael Terry (mterry) → nobody
assignee: nobody → Michael Terry (mterry)
status: Confirmed → Invalid
Changed in qtwebkit-source (Ubuntu Oneiric):
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtwebkit-source - 2.2~2011week36-0ubuntu1

---------------
qtwebkit-source (2.2~2011week36-0ubuntu1) oneiric; urgency=low

  * New upstream release (2.2.0 RC1).
    - Drop kubuntu_fix_jit_warnings_i386.diff, applied upstream.
    - Fixes crash in amarok wikipedia applet. (LP: #846709)
  * Add Vcs-Bzr control field.
 -- Felix Geyer <email address hidden> Mon, 19 Sep 2011 17:57:06 +0200

Changed in qtwebkit-source (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in amarok:
status: Confirmed → Incomplete
Changed in qtwebkit:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in amarok:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.