Wrong rendering of some elements of interface

Bug #786192 reported by Evgeny Brazgin on 2011-05-21
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
High
John M Marusa Jr
Natty
High
Unassigned
pkg-kde-tools (Ubuntu)
Medium
Unassigned
Natty
Medium
Felix Geyer

Bug Description

Testcase:
1) Install amarok
2) Open /usr/share/kde4/apps/amarok/images/default-theme-clean.svg with an editor
3) Look for "#66ffff" -> no match
4) Look for "#6ff" -> plenty of matches

Binary package hint: amarok

I have amarok-2.4.1.

SVG file default-theme-clean.svg is changed in (k)ubuntu and it is different from upstream.
That's why some elements of interface (now playing track) are rendered incorrectly: they have cyan colors while they should use system colors.

The color "#66ffff" is changed in this file to "#6ff" everywhere (I know, they're the same, but SvgTinter in Amarok doesn't provide a possibility to change "#6ff" to highlight color as it is implied).

There are some ways to correct this.
1. Restore the original default-theme-clean.svg.
2. Add "m_tintMap.insert( "#6ff", App::instance()->palette().highlight().color().name() );" to SvgTinter::init() in src/SvgTinter.cpp.
3. Replace all "#6ff" to "#66ffff" in svg.

Evgeny Brazgin (xapienz) wrote :
Harald Sitter (apachelogger) wrote :

On oneiric?

Changed in amarok (Ubuntu):
status: New → Incomplete
Harald Sitter (apachelogger) wrote :

Righto. This is very much a regression.

Essentially in Natty a special feature that runs by the name "scour" was introduced into the standard build process, this thingy tries to compress SVG files, somewhat unreliable I might say.

Unfortunately we were missing a crucial dependency of it (python-rsvg) which is used to ensure that the compression did not break anything. So sure enough scour broke something and since the dependency was missing the broken SVG instead of the working one was included in the package.

Changed in amarok (Ubuntu):
importance: Undecided → High
milestone: none → natty-updates
status: Incomplete → Triaged
Evgeny Brazgin (xapienz) wrote :

I use natty

Changed in pkg-kde-tools (Ubuntu):
status: New → Incomplete
status: Incomplete → Fix Released
Changed in amarok (Ubuntu):
milestone: natty-updates → oneiric-alpha-1
Changed in amarok (Ubuntu Natty):
milestone: none → natty-updates
Changed in pkg-kde-tools (Ubuntu Natty):
milestone: none → natty-updates
status: New → Triaged
Changed in amarok (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
Changed in pkg-kde-tools (Ubuntu Natty):
importance: Undecided → Medium
Changed in pkg-kde-tools (Ubuntu):
importance: Undecided → Medium
Changed in amarok (Ubuntu Natty):
assignee: nobody → Felix Geyer (debfx)
Changed in pkg-kde-tools (Ubuntu Natty):
assignee: nobody → Felix Geyer (debfx)
description: updated
Felix Geyer (debfx) on 2011-05-26
Changed in pkg-kde-tools (Ubuntu Natty):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.4.1-1ubuntu2

---------------
amarok (2:2.4.1-1ubuntu2) oneiric; urgency=low

  * Rebuild with scour disabled in pkg-kde-tools as it caused rendering
    bugs. (LP: #786192)
 -- Felix Geyer <email address hidden> Fri, 27 May 2011 10:17:43 +0200

Changed in amarok (Ubuntu):
status: Triaged → Fix Released
Felix Geyer (debfx) wrote :

Uploaded fix to natty-proposed, waiting for approval.

Felix Geyer (debfx) on 2011-05-27
Changed in amarok (Ubuntu Natty):
assignee: Felix Geyer (debfx) → nobody

Accepted amarok into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in amarok (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Kevin Funk (kfunk) wrote :

Yep, can confirm the package works correctly. The theme SVG is now identical with the repository version.

After updating to natty-proposed amarok package:
[17:56:39] <KRF> [krf@kerberos amarok 804K]% diff -u /usr/share/kde4/apps/amarok/images/default-theme-clean.svg src/images/default-theme-clean.svg
[17:56:39] <KRF> [krf@kerberos amarok 804K]%

Felix Geyer (debfx) on 2011-06-06
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.4.0-0ubuntu5.1

---------------
amarok (2:2.4.0-0ubuntu5.1) natty-proposed; urgency=low

  * Don't run dh_scour as it causes rendering bugs. (LP: #786192)
 -- Felix Geyer <email address hidden> Fri, 27 May 2011 11:26:33 +0200

Changed in amarok (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in amarok (Ubuntu):
assignee: nobody → John M Marusa Jr (jmm4278)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers