[Kubuntu and AMAROK] - Use of KIO SLAVES to open remote files (samba, nfs, etc)

Bug #738262 reported by André Madureira on 2011-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

Hello,

I tried to open a file via KIO SLAVES smb:// protocol (a MP3 file format) and AMAROK opened it and later, when I tried again, it didn't opened the file... When I mount the remote path with CIFS it always work...

Thanks for your help,

André M.

description: updated

STEPS TO REPRODUCE:

1 - Open a file in a remote path via KIO SLAVES SMB:// protocol in AMAROK for the second time (when opened for the first time, AMAROK CAN OPEN IT, BUT CAN'T SEEK IT)
2 - Amarok will show a lot of errors to the user, forcing him to delete the file from the playlist...

PS: I did a bug report in the LIBREOFFICE package (https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/730264) and Gnome Mplayer (https://bugs.launchpad.net/ubuntu/+source/gnome-mplayer/+bug/737201) and VLC (https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/737192) because all of them don't support KIO SLAVES or (in the case of AMAROK) don't handle it as well as it should (AMAROK is a program done to work on KDE and therefore should at least support KIO SLAVES because it is a characteristic of KDE)...

I did a bug report in the Dolphin package about this issue too (https://bugs.launchpad.net/ubuntu/+source/kubuntu-kde4-meta/+bug/730984) because I don't know if it's better to applications support KIO SLAVES or DOLPHIN auto mount via CIFS remote paths (samba, nfs, etc)...

Harald Sitter (apachelogger) wrote :

Hi André!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in amarok (Ubuntu):
status: New → Invalid

Bug report send to KDE Bug Reporting Official System (https://bugs.kde.org/show_bug.cgi?id=273881)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.