Ubuntu

Amarok UI doesn't display completed media device transfers correctly

Reported by Romain Despland on 2006-10-06
8
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: amarok

Hello,

There seems to be something wrong with the french translation, when transferring file to an ipod (I don't know about other media), is finished it still says something like "1 morceau en attente" even though everything has been transfered.

When the ipod is not connected at all, it says "1 Piste en attente" even though I don't have anything planned for transfer.

Andrew Ash (ash211) wrote :

Was that in Edgy final?

Changed in amarok:
status: Unconfirmed → Needs Info

Yes it is still there in edgy final.

Claude Paroz (paroz) wrote :

I don't see why this problem should be related to French translation. It seems to be an amarok problem.

Andrew Ash (ash211) wrote :

(I don't know what the quoted French means.)

Is the problem that the messages are incorrectly translated or that Amarok displays the messages at the wrong time?

Well it seems more likely to be a bug in amarok but then this should also be in the english version and more people should have seen it. There is also such a bug in akregator that looks a lot like this one. If I remember correctly this has to do with the translation because this happenend also before dapper final and was fixed.

https://launchpad.net/distros/ubuntu/+source/kdepim/+bug/64385

Andrew Ash (ash211) wrote :

Hmm, I've never seen this bug before, but I don't transfer files to my ipod a whole lot either. Was it a clean install of Edgy final?

Yes clean Edgy final install

Thank you for the bug report. Do you still have this problem on the official edgy release? Do you have a way I can reproduce it, I have never had iPod problems with Edgy.

Andrew Ash (ash211) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in amarok:
status: Needs Info → Rejected

Well,

I don't really know what to add. I did a clean install of feisty followed with the updates. I plugged my ipod (forgot to check before plugging the ipod for the first time) and now every time I open amarok even if my ipod is not connected I get "1 Piste en attente" in the peripheral tab. I did not transfer any files yet.

Andrew Ash (ash211) wrote :

Sorry for closing it early. We were waiting for confirmation that it was still a problem in edgy ( https://beta.launchpad.net/ubuntu/+source/amarok/+bug/64389/comments/8 )

I don't really speak french. What does '1 Piste en attente' mean? I think it has something to do with transferring files. Can you make sure that any pending transferrals are completed and make sure the message doesn't come up anymore?

Also, please try upgrading to Amarok 1.4.5 to see if that fixes the problem.
http://kubuntu.org/announcements/amarok-1.4.5.php

Changed in amarok:
status: Rejected → Needs Info
assignee: nobody → ash211

Like I said I just upgraded to Feisty Herd 5 with a clean install. So I have amarok 1.4.5.

The meaning of "1 piste en attente" is that there is still one music file to transfer.

Because it is a fresh install I did not do any file transfer so there are no pending transfers waiting to be done.

i can add another piece of information, if I remember correctly when I upgraded the amarok version using the repo provided above in your comment while using edgy this bug was gone. I don't know if the packages added on kubuntu.org use the same translation files or are from another source. If they are from another source then it would mean something I guess.

Andrew Ash (ash211) wrote :

I'm not sure this is as much a translation error as an error in the program itself. If you change language settings to english, what does the box say?

Tryed with english and I get " 0 tracks in queue"

Even the English version is not perfect, but at least it shows that there is a problem in the french translation

Andrew Ash (ash211) wrote :

I think the bug here is not so much in the translation as it is in Amarok giving a senseless statement or hanging on the last file. As such I'm changing the title to better reflect the bug.

Changed in amarok:
assignee: ash211 → nobody
status: Needs Info → Confirmed
Changed in amarok:
importance: Undecided → Low
Jonathan Thomas (echidnaman) wrote :

The transfer UI has undergone a complete reimplementation in Amarok 2, so this shouldn't be an issue any more. (Not to mention all the strings changed)

Changed in amarok:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers