Awkward text: "listening since 5 weeks ago"

Bug #59346 reported by Caroline Ford
6
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
Wishlist
amarok (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: amarok

Amarok 1.4.2 (dapper-backports)

Tools ->Statistics

Window entitled "Collection Statistics" - bottom item:

Newest Items
Listening since 5 weeks ago

"Listening since 5 weeks ago" doesn't make sense in this context and isn't grammatical English. It needs to be reworded.

Dean Sas (dsas)
Changed in amarok:
status: Unconfirmed → Confirmed
Changed in amarok:
status: Unknown → Unconfirmed
Revision history for this message
Andrew Ash (ash211) wrote :

What would you prefer to be the exact wording of that sentence?

Does this still occur in Amarok 1.4.4 ?

Changed in amarok:
status: Confirmed → Needs Info
Revision history for this message
lexual (lexhider) wrote :

It is still occuring in 1.4.4

Mine currently says:
"Newest Items
Listening since 56 minutes ago"

Perhaps it could be replaced with:
"Newest Items
Added in the past 56 minutes"

above example could be:
"Newest Items
Added in the past 5 weeks"

I'm guessing this is an upstream bug.

Revision history for this message
Andrew Ash (ash211) wrote :

Yes, this is an upstream bug.

http://websvn.kde.org/*checkout*/trunk/extragear/multimedia/amarok/src/statistics.cpp?content-type=text%2Fplain&rev=621458
Search for "Listening since" on the above page to find the exact code responsible.

I've created a patch that changes this to say "First played" instead, since that's closer to what information is actually being displayed. I'll attach here and at the tracked KDE bug.

I'll see if I can get it committed soon, but it is likely too late for Amarok 1.4.5, which recently went into a string freeze so translations could occur.

Changed in amarok:
assignee: nobody → ash211
importance: Undecided → Low
status: Needs Info → Confirmed
Revision history for this message
Andrew Ash (ash211) wrote :
Revision history for this message
Andrew Ash (ash211) wrote :

That patch should read "Listening Since -> First Played patch"

Revision history for this message
lexual (lexhider) wrote :

I'm now a bit confused as to what the "Newest Items" statistic is showing?
It doesn't appear to be the tracks played in that time period, because when I go into the "Newest Items" statistic, there are tracks showing up that I have never played.

Can anyone enlighten me?

Changed in amarok:
status: Unconfirmed → Fix Released
Revision history for this message
Andrew Ash (ash211) wrote :

I'm not exactly sure myself. I would think that it shows the tracks most recently added to the collection, along with the first time that they were played. That may be wrong.

The patch was committed upstream, so the wording change will be in effect when Amarok 1.4.5 is released.

Changed in amarok:
status: Confirmed → Fix Committed
Revision history for this message
Andrew Ash (ash211) wrote :

The change has been released in feisty with Amarok 1.4.5, and I believe an Edgy release is on the way. Yay!

Changed in amarok:
assignee: ash211 → nobody
status: Fix Committed → Fix Released
Changed in amarok:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.