Automatic collection rebuilds make system completely unusable for minutes or hours without warning

Bug #58716 reported by Dave Suffling on 2006-09-03
10
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Amarok appears to automatically rebuild it's collection periodically. Once this process is started, it is *extremely* difficult to stop, and all other work becomes impossible (because the hard disk is completely occupied, even running 'ps' from a non-X VT takes up to half a minute.)

The amarokcollectio---? process (which is responsible for this) has a nice value of '0'. Even increased, the problem persists because of the hard disk access issue.

dgf (dgf) wrote :

When Amarok rebuilds its collection it eats all my memory and my system becomes unusuable. I didn't wait a half hour to see if it will recover, I pressed after a few minutes the reset button. Here is a output from top just close before killing amarok, the memory usage of the amarokcollection programm will constantly go higher and higher.

top - 11:00:49 up 25 min, 2 users, load average: 1.12, 0.53, 0.40
Tasks: 114 total, 2 running, 111 sleeping, 0 stopped, 1 zombie
Cpu(s): 84.4%us, 15.6%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 1034908k total, 1005156k used, 29752k free, 56756k buffers
Swap: 465844k total, 240k used, 465604k free, 363448k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 7850 lutz 25 0 376m 351m 13m R 94.9 34.8 0:14.67 amarokcollectio
 7829 lutz 15 0 135m 40m 26m S 4.3 4.0 0:09.06 amarokapp
 3896 root 15 0 294m 15m 8468 S 0.7 1.5 0:24.26 Xorg

dgf (dgf) wrote :

I forgot to say: I'm using edgy with latest updates. Amarok is amarok_1.4.3-0ubuntu9_i386.deb

dgf (dgf) wrote :

I removed all my music from my collection in amarok, so that it is empty and the collection-update should be really fast. But the issue is still there and even with no files to scan the collection-update eats all my memory. When I close amarok it will become a zombie ( <defunct> ) for a few seconds.

RJ Marsan (rjmarsan) wrote :

Can you give some more info? how much songs do you have? how fast is your processor/computer?

Changed in amarok:
status: Unconfirmed → Needs Info

were you using mysql or sqlite as the engine?

Could be related to https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/58566 if using the sqlite engine (in which case, it's fixed in 1.4.5)

dgf (dgf) wrote :

yes I am using sqlite. I just added the specific folder with the music, which after removing it from the database amarok worked safe again. And now it works, but it could be that I probably just have deleted the file , which causes the problem, or recreating my hole amarok-profile did it.
There is no problem for me anymore :)

Andrew Ash (ash211) wrote :

Glad it's not a problem anymore. I'm closing the bug. Let us know if this comes up again.

Thanks for your contribution to Kubuntu.

Changed in amarok:
status: Needs Info → Rejected
grauscho (grauscho) wrote :

Recently I got a new notebook with quite a noisy harddisk. :(

Because of this, I noticed a pattern of periodical disk access when running Amarok. Approx. 30 secs silence, then 30 secs noise etc.

The 30 secs noise phase happened to be the update of the collection (1739 songs). When the progress bar reaches 100%, it immediately starts a second time beginning at 0%! When it has finished the second turn, the 30 secs silence phase starts.

I then monitored amarok with atop. I'm not sure whether I interpret the data the right way. The RDSK rate seems to be related to the songs sampling rate. E.g. when playing a 256kbps song, RDSK says 256K were read in the 10 second update interval, for a 128 kbps song it displays 128K. The read rate is constant over time. Fair enough.

The write rate (WRDSK) is 0K in the silent phases, but peeks at more than 30000K (in a period of 10 secs) in the collection update phase!
Overall disk usage (DSK busy rate) peeks at approx. 60%. It seems to me that amarok writes several Megs of data when updating (once a minute). Is this possible?

So I disabled "Scan folders recursively" and "Watch folders for changes". Read rate is exactly the same as before. Write rate dropped to 0K.

Amarok 1.4.10
Kubuntu Intrepid with KDE version 4.2
Kernel 2.6.27-12-generic x86_64 (dual core processor)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers