Crossfading option causes skipping

Bug #57789 reported by Dave Suffling on 2006-08-26
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
Medium
amarok (Ubuntu)
Low
Unassigned

Bug Description

When advancing from the end of one track, amarok will start to play the next track, but then go on to play the track which follows. This is detectable because of crossfading, and it known (or just more frequently noticed) when using queued tracks.

To aid in duplication, my usual usage pattern calls for the 'random' metaplaylist set to list 50 tracks. I repopulate the list, pick five or six tracks to queue, then repeat until my queue reaches a good size.

I should add that the effect occurs only some of the time. I haven't found any rationale as to why some tracks are skipped (skipped tracks can be requeued and will play the second time they come up.)

Dave Suffling (dsufflin) on 2006-08-26
description: updated
Risto H. Kurppa (risto.kurppa) wrote :

Same here, Amarok skips tracks or actually plays only some 2-3 first seconds of a (normal 2-3 minutes long) track and then starts playing the next that's on the playlist.

I haven't found any hints (except that almost every second track is skipped) when this happen, it seems to be totally random.

Thank you for the bug report, I need you to answer some questions. What release are you on? What version of Amarok? Is this still happening?

Changed in amarok:
status: Unconfirmed → Needs Info
l8storm (l8storm) wrote :

Hi there,
I have got the same problems with amarok. Sometimes, it skips a track after playing it some seconds. Also, I have no idea what's wrong - the files are not corrupted, as they are playing if I start them manually again.

My setup:
Debian Etch, Kernel 2.6.17.6
KDE 3.5.5 on XOrg 7.1.0-9

Amarok 1.4.4 (build date: Dec 12 2006)

Andrew Ash (ash211) wrote :

This is the Ubuntu bug tracker, so a fix here may not necessarily correlate to one in Debian. I would follow this page and see if it helps you figure out what's going on.

Let's see if we can take the randomness out of this bug. What kind of file are the tracks? Are they located remotely or locally? Does it happen when you aren't in random playlist? Does it happen when you drag the tracks in order instead of queuing them? Is it a certain artist, song letter, length of song, or file path? We can't do much about this until we can get more information about what's going on here.

Thanks

l8storm (l8storm) wrote :

So, I have had some time and tried to find out what is going on.

This is what I have done:
1. Created a playlist by draging an album into the empty playlist-window
2. Added some more random tracks, so that the playlist had a size of 35 tracks
3. Randomized the list by pressing "Ctrl+H"
4. Started to play the first track
5. Fast forward to approx. 10 secs before the end of the file
6. Checking if the automatic track change has really started the next track
7. Repeating 5+6 till end of playlist

32 times the track change was OK, but 3 times amarok skipped the next track. This seems to be independent from any file-information, because when I tried to reproduce it, there was nothing wrong.

Maybe that this has something to do with the crossover function I have activated and set to 2secs [on automatic track change only], but I have had no time to test this. It seems to be a problem with the automatic track change - so far, no skipping has occured by manual track change.

I'll test what happens when deactivating the crossover function. So long... :)

Andrew Ash (ash211) wrote :

Did you ever find out what was happening in this bug? What were the results of your test with crossover?

If it's still a problem, could you please try installing Amarok 1.4.5 ?

http://kubuntu.org/announcements/amarok-1.4.5.php

Changed in amarok:
assignee: nobody → ash211
Risto H. Kurppa (risto.kurppa) wrote :

I have Edgy & Amarok 1.4.5 and I haven't noticed skipping of tracks any more. I don't have crossover enabled but could try if that matters. Now sometimes Amarok starts playing podcast streams not from beginning but some 1min 30s from the start but that's another issue, and works OK if I start playing the stream again.

Will do crossover testing.

Risto H. Kurppa (risto.kurppa) wrote :

Seems to skip when crossover mixing of tracks is on.

Andrew Ash (ash211) wrote :

Hmm, looks like crossfading isn't entirely bug-free yet. What engine are you using in Amarok? `dcop amarok player engine`

Also, can you confirm that not using crossfading fixes the skipping bugs, Dave?

Risto H. Kurppa (risto.kurppa) wrote :

Using Xine & Amarok 1.4.5 and disabling the crossfading seems to stop skipping so I suppose crossfading is the reason for skipping.

Andrew Ash (ash211) on 2007-03-15
Changed in amarok:
assignee: ash211 → nobody
status: Needs Info → Confirmed
Timo Karhu (nalle-karhulitos) wrote :

Amarok 1.4.7 and exactly same issue. I'm to go to do some party DJ'ing but now I'm scared!
Crossfade at 1000ms, let system change song, it will start next song and play it about 3 seconds and skip to next one.

steffen (steffen-sobiech) wrote :

I can confirm this one.

Tomihotedavyndej (coolfighter) wrote :

I can confirm this behavior too. I run Kubuntu 7.10 (Gutsy Gibbon), Amarok 1.4.7 with libxine 1.1.7-1ubuntu1, crossfading set to 1000ms, but this bug was present in previous release, Fiesty Fawn, too.
Also, I found this bug report on other bugtrackers too (archlinux, osdir, even kde), so this issue is obviously not ubuntu only problem.

Léonard G (leonard-gerard) wrote :

same here, randomly skip track after 2 or 3 second played. It has been the case in previous versions too. I'm using crossfading and fadout both to some small amount ( 200 and 300 ) , using xine engine ans amarok 1.4.7 under kde 3.5.8 ( gutsy kubuntu ). Seems to disepear by removing the corssfading option, not sre if fadeout has anything to do with it.

Tom Owen (jimbowen) wrote :

Same problem here.. Debian Sid / Amarok 1.4.7
Except I am NOT using the crossfading option. Instead I have a complicated sqlite query in a smart playlist which in turn polulates a dynamic playlist. It's quite a lot of CPU thrashing to repopulate the list.
Perhaps it is the excessive CPU usage when switching tracks that is causing it to skip, rather than the crossfade or smart playlist specifically?

Harald Sitter (apachelogger) wrote :

Does this still happen in Hardy?

Changed in amarok:
importance: Undecided → Low
status: Confirmed → Incomplete

yes, the problem is still in hardy
amarok 2:1.4.9.1-0ubuntu3

i noticed the problem only when i use the "random mix" playlist and i have crossfading on (but i didn't try to disable it). it doesn't seem to be specific to certain songs. i'm using the xine engine + alsa (not pulseaudio). 5000 ms crossfading on automatic track change only.

it happens randomly and not so often.

I can confirm this behavior on Hardy with Amarok 1.4.9

This has happened to me when doing my own playlist by queuing songs (i don't do random playlists a lot). The behavior seems to be highly random, as i can play the same playlist two times without the same songs being skipped.
I also have crossfading enabled.

TimS (tim-slatcher) wrote :

I can confim this too, I had no problems under 7.10 as far as I could tell, but I am getting it now with cross fading enabled on Amarok 1.4.9.1.
I only ever play my music with it all in one playlist, random enabled. I have 1800 tracks, I am not sure if the amount effects the bug at all.

Oddly, I had cross fading on automatic change only as everyone else but it would happen with manual track changes too. I think this could be similar to Tom Owens problem, I have noticed the problem a lot worse when my CPU is busy and I have things like Compiz enabled and other intensive applications. I think the size of my playlist could be a factor as Amarok does seem to be using a lot of resources.

Same problem here, exactly as described by others.
Kubuntu 8.04
Amarok 1.4.9.1
Cross-fading turned on with crossover duration of 1000 ms.
Output engine is xine.

The skipping happens during normal playlist usage about every 10 tracks and appears to be random with respect to the song and the environmental conditions.

imitation (grinsi-sanladerer) wrote :

Confirming this bug, it only occurs with crossfding enabled.
Kubuntu 8.04
Amarok 1.4.9.1 / KDE 3.5.9
output through xine -> alsa -> nvidia / AD1986A HDaudio

Amarok updates its collection very often and then freezes for 5~10 sec, i don't know whether this is related or not.

Ramon Casha (rcasha) wrote :

Confirmed: Kubuntu 8.04, crossfading, Amarok 1.4.9.1
Xine output

I think it might have something to do with how busy the computer is at the time - possibly in disk I/O. Could it be that if a disk-intensive task is active when the track starts playing, Amarok thinks there's a problem with the file itself and auto-skips to the next track?

Changed in amarok:
status: Incomplete → Confirmed

+1

aschuring (aelschuring) wrote :

Has this ever been reported upstream? The closest I could come to an upstream report is http://bugs.kde.org/show_bug.cgi?id=110814 but that has been resolved (presumably it only fixed the issues with the crossfade length).

I'm using the dynamic playlists quite a lot, and have crossfading set to 4000ms. Amarok reliably skips every other song (plays one, skips one, etc). I can confirm that turning off crossfading makes the skipping go away, but skipping occurs in either dynamic or static playlists. Maybe another point of interest: my library is moderately sized (3000 songs), and I'm using mysql as database backend.

This is on Intrepid, current as of a few hours ago. Amarok 1.4.10, build 14-8-2008.

Changed in amarok:
status: Unknown → Fix Released
CoskiBukowski (julian87) wrote :

Hi. I can also confirm this bug.

I also think is somehow related to CPU and disk usage. When I'm using CPU and/or disk intensive applications, the skipping seems more frequent, but still random. (crossfading enabled).

Regards

thedanyes (thedanyes) wrote :

Same problem here. I'm using xine (version 1 framework version 21 is what it says in the 'about' screen). KDE version 3.5.9 on K ubuntu 8.04. Amarok version 1.4.9.1. I have crossfading enabled and set to 500 ms and 'always'.

It happens about maybe once every 5 or 6 tracks. It starts playing a track and then about 3-4 seconds in just skips to the next track for no apparent reason. Its really annoying.

deric (barton-tomas) wrote :

I can also confirm that. With allowed crossfading sometimes amarok starts playing first few seconds and then skips to another. When I press previous track button, amarok plays whole track, which skipped before

Kubuntu 8.04
Amarok 1.4.9.1
KDE 3.5.10

Fusili (fusili) wrote :

Same problem with crossfading. Tryed every combination of settings possible with fadeout, and crossfading. Turning fadeout off made no difforence in the problem. Turning crossfading off eliminated the problem. Tested on random playlists and ones that I put together myself. Checked with over 2500 songs. MP3 format. Simple and complex file names. It is completely random. System specs are: AMD Athlon 64 X2 Running in performance mode (1.9 GHz, Scaling disabled). 3 GB DDR2 Ram. 250GB HDD (29% used). Kubuntu 8.10, Amarok 1.4.10, KDE 4.1.2. Need any more info, just let me know.

Derek Kaye (kayedj) wrote :

I can confirm that this bug in still in Intrepid.

Interestingly, I only noticed it after doing an apt-get install kubuntu-desktop. I had been using amarok in GNOME with no problems, but the problems only started after switching to KDE.

CoskiBukowski (julian87) wrote :

This bug is from 2006!!

Is there SOMEBODY reading this who can do something about it?

Are we posting in the right place?

?

Is anyone having this issue on amarok 2.0? Marking as incomplete.

Changed in amarok:
status: Confirmed → Incomplete
aschuring (aelschuring) wrote :

You mean you can't reproduce it yourself? Besides, this bug is present Hardy as well, and since that is an LTS release it should have long been confirmed, even if it is fixed in 2.0.

Testing 2.0 would mean to try Jaunty, and I have no machines on Jaunty yet. Will report back when I have. But considering the fact that this bug has existed since at least 2006 and FAFAIK was never reported upstream, I have zero confidence that it is fixed in 2.0 (there is one possibility, though: if the error is triggered by the Xine engine, it might have been fixed by Phonon).

Amarok upstream here.
It was reported upstream as you can see in the bugwatch at the top of this page.
It should indeed be fixed in Amarok 2.

Jonathan Thomas (echidnaman) wrote :

Marking fixed then.

Changed in amarok:
status: Incomplete → Fix Released
aschuring (aelschuring) wrote :

> Amarok upstream here.
Welcome! Glad to know I was wrong about that.

>It was reported upstream as you can see in the bugwatch at the top of this page.
The link at the top refers to a bug report that is older than this one. To be exact, the upstream report was closed a month before this bug report was opened. Now I can appreciate some lag between an upstream release and inclusion in Ubuntu, but #110814 was fixed in 1.3-SVN by commit 451292 in August 2005. Since everyone here experiences this bug in 1.4, either this is a regression, or it was never really fixed, or it was fixed only on the 1.3 branch. Either way, I have not found a newer upstream bug report that deals with this issue.

>It should indeed be fixed in Amarok 2.
Let's hope so. Will a fix be backported to Hardy (Amarok 1.4)?

No it will not be possible to backport it to 1.4 as the code changed completely. Sorry.

Andrew Ash (ash211) wrote :

I'm a lurker on the amarok-devel list upstream, and also follow the Amarok bugs in Ubuntu. I don't actually do Amarok development myself, so take all of this with a grain of salt. It's my understanding of the current situation, and may be incorrect:

Over the past few years I've heard a number of issues with crossfading in 1.4, and the solution is always to disable crossfading. I don't think that a full fix has ever been implemented in 1.4, since there is a complicated inter-relationship with Amarok and the underlying sound engines that actually makes the crossfading work.

Part of the effort of Amarok 2 was to simplify the huge number of configuration issues so that the type of problem we're seeing here can be resolved more easily. Instead of 3 database backends (postgres, MySQL, SQLite), Amarok supports one (MySQLe) and instead of multiple audio backends (xine, gstreamer, pulseaudio, ...), there is one (I think phonon/xine).

Unfortunately, there is no further maintenance of the Amarok 1.4 codebase planned by Amarok upstream. Meaning, no Amarok developers are working on a fix, since they are so busy with what's going on in Amarok 2: already maintaining 2.0.0, getting ready to release 2.1, and planning on which features need to be pushed back for 2.2. In order to get a fix in 1.4, you will either need to personally find someone willing to take a look at the 1.4 codebase again or do it yourself. A bounty would probably help here :)

I hope that clears things up. Let me know if any of that needs clarification.

Hey Andrew :)
Yes that is basically it. Thanks for writing this down.
Just a small clarification: We support only Phonon as an engine now. But Phonon can use different backends like gstreamer and xine. This makes it a lot easier for us as we are no longer responsible for all the low level audio stuff but can concentrate on other things and let people who really understand it and want to make it work work on it.
About a bounty for Amarok 1.4's sound system: You could try it but honestly we tried to fix this in 1.4. And it is badly broken. So your time and money is really better spend on Amarok 2. Amarok 2.1 will add a lot of stuff you might be missing in 2.0.1 still.

aschuring (aelschuring) wrote :

>Testing 2.0 would mean to try Jaunty, and I have no machines on Jaunty yet
So I moved one of my machines over to jaunty (well, only kubuntu-desktop really) and guess what: there is no crossfade option in Amarok2! So it appears to be fixed, isn't it?

Or am I doing something terribly wrong here? In Amarok 2.0.1, build date Feb 27, I can find in the "Configure Amarok" menu, the following options: "Fadeout" and "Resume playback on start". Is the fadeout option supposed to enable crossfading as well?

José Tomás Atria (jtatria) wrote :

i can confirm this on intrepid, kde 4.2, amarok 2.0.1

Matt Whitlock (whitslack) wrote :

This is happening to me on Gentoo with KDE 4.2.2 and Amarok 2.0.90, so it's not limited to Ubuntu. Very aggravating, since not only does it skip every other song, but it tells Last.fm that I actually listened to the song it skipped, and it bumps up the score and play count of the skipped song as though I had listened to the whole thing. That's just mean.

Tiedemate (bjoerntiedemann) wrote :

I can confirm this alos, Kubuntu 9.04, amarok 2.0.2. At them moment I am listening to an album of the collection, mp3, and it happens about every second song. Fadeout is disabled. Cannot link it to any spec of the song, because they play fine manually. VERY annoying.

The problem still exists in Pana, a new fork of Amarok 1.4. Does anybody know, if it was fixed in amarok 2 so it can be backported? thanks!

Luke Hollins (lwh) on 2010-04-06
Changed in pana:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Luke Hollins (lwh)
Changed in amarok:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.