file overwrite bug in 9.10 -> 10.04

Bug #556535 reported by Michael Vogt on 2010-04-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
High
Alessandro Ghersi
Lucid
High
Alessandro Ghersi

Bug Description

Binary package hint: amarok

On a 9.10 -> 10.04 upgrade I get the following error:

...
[7.37883] amarok-common: Unpacking amarok-common
Preparing to replace amarok-utils 2:2.2.0-0ubuntu2 (using .../amarok-utils_2%3a2.3.0-0ubuntu3_i386.deb) ...
Unpacking replacement amarok-utils ...
dpkg: error processing /var/cache/apt/archives/amarok-utils_2%3a2.3.0-0ubuntu3_i386.deb (--unpack):
 trying to overwrite '/usr/bin/amarok_afttagger', which is also in package amarok 2:2.2.0-0ubuntu2
...

Michael Vogt (mvo) on 2010-04-06
Changed in amarok (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04
tags: added: iso-testing
Changed in amarok (Ubuntu Lucid):
assignee: nobody → Alessandro Ghersi (alessandro-ghersi)
Changed in amarok (Ubuntu Lucid):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.3.0-0ubuntu4

---------------
amarok (2:2.3.0-0ubuntu4) lucid; urgency=low

  [ Scott Kitterman ]
  * Add amarok replaces amarok-common (<< 2:2.0.2) for better upgrade support

  [ Alessandro Ghersi ]
  * amarok-utils replaces amarok (<= 2:2.2.0-0ubuntu2) (LP: #556535)

  [ Harald Sitter ]
  * In kubuntu/03_restricted_install.diff send the translated programName
    to the restrictedInstall interface instead of a hardcoded name
    + Get rid of unused var warning due to this patch
 -- Harald Sitter <email address hidden> Thu, 08 Apr 2010 18:04:54 +0200

Changed in amarok (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers