Amarok states malinformed url when started for the first time

Bug #540232 reported by Rohan Garg on 2010-03-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: amarok

Steps to reproduce crash :
1) Grab the daily live build ( amd64 )
2) Click on K in the bottom bar
3) Click on amarok
4) Amarok complains of malinformed URL
See : http://imagebin.ca/view/L6z5KuL.html

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 17 12:50:26 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100317)
Package: amarok 2:2.2.2.90-0ubuntu3
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: amarok
Uname: Linux 2.6.32-16-generic x86_64

Rohan Garg (rohangarg) wrote :
Changed in amarok (Ubuntu):
status: New → Confirmed
Jonathan Riddell (jr) wrote :

13:01 < shadeslayer> yeah only on first start
13:01 < JontheEchidna> (It does continue on fine normally afterwards)
13:01 < Riddell> yes, I wonder if it's just because the default music location isn't set, the next thing it does is ask if it can use ~/Music
13:02 < Riddell> which is daft, it should just use it no questions asked, it's a sensible default

Changed in amarok (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
tags: added: kubuntu
Jeff Mitchell (jefferai) wrote :

Can't reproduce here on Gentoo.

tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

I can reliably reproduce this bug by removing this entry from the amarokrc:

[File Browser]
Current Directory=/home/jonathan

Jonathan Thomas (echidnaman) wrote :

Looks like the readConfig() entry of the FileBrowser class doesn't suggest a default when reading the config. I'll see if adding /home as a default-if-nothing-is-there value fixes things.

Changed in amarok (Ubuntu Lucid):
assignee: nobody → Jonathan Thomas (echidnaman)
status: Confirmed → In Progress
Jonathan Thomas (echidnaman) wrote :

Yep, that was it. I haz patch. I'll see about sending it upstream, and commit it to our packages in the meantime.

tags: added: patch
Jonathan Thomas (echidnaman) wrote :

Whoa, my exact changes had already been made upstream for 2.3.0. O_O

This one will be fixed once 2.3.0 from bzr is uploaded.

Changed in amarok (Ubuntu Lucid):
assignee: Jonathan Thomas (echidnaman) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.3.0-0ubuntu1

---------------
amarok (2:2.3.0-0ubuntu1) lucid; urgency=low

  [ Mackenzie Morgan ]
  * New upstream release
    - LP: #395876, #438268, #447534, #456139, #466949, #343716, #521389, #540232
  * patches/kubuntu/06_mimetypes.diff: (LP: #191475)
    - Add x-content/audio-cdda and x-content/audio-player to src/amarok.desktop

  [ Jonathan Riddell ]
  * Update debian/patches/kubuntu/05_kstatusnotifieritem.diff from Aurelien Gateau

  [ Jonathan Thomas ]
  * Add kubuntu/07_dont_ask_music_dir.diff, since ~/Music is a sensible default
    that we set by, well, default (LP: #543463)
 -- Mackenzie Morgan <email address hidden> Thu, 11 Mar 2010 20:05:30 -0500

Changed in amarok (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers