Wrong POT template creation in some KDE packages

Bug #529483 reported by Yuri Chornoivan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
amarok (Ubuntu)
High
Harald Sitter
kde-style-qtcurve (Ubuntu)
High
Harald Sitter
kipi-plugins (Ubuntu)
High
Harald Sitter
konversation (Ubuntu)
High
Harald Sitter
pkg-kde-tools (Ubuntu)
High
Harald Sitter
plasma-widget-networkmanagement (Ubuntu)
High
Harald Sitter

Bug Description

Binary package hint: amarok

Rosetta scripts screw up Amarok translation. For example, LP results of .ui-files parsing loks like this:

           </property>
         </widget>
        </item>
       </layout>
      </item>
      <item>
       <widget class="QFrame" name="frame_info">
        <property name="frameShape">
         <enum>QFrame::StyledPanel</enum>
        </property>
        <property name="frameShadow">
         <enum>QFrame::Raised</enum>
        </property>
        <layout class="QVBoxLayout" name="verticalLayout">
         <item>
          <widget class="QLabel" name="label_Info">
           <property name="text">
            <string>Amarok expects the above database and user account to already exist. This user also requires full access to the database. You MUST restart Amarok after changing these settings.

           </property>
           <property name="flat">
            <bool>true</bool>
           </property>
           <layout class="QVBoxLayout" name="verticalLayout">
            <item>
             <widget class="QLabel" name="eqPreampValue">
              <property name="sizePolicy">
               <sizepolicy hsizetype="Minimum" vsizetype="Preferred">
                <horstretch>0</horstretch>
                <verstretch>0</verstretch>
               </sizepolicy>
              </property>
              <property name="font">
               <font>
                <pointsize>8</pointsize>
               </font>
              </property>
              <property name="text">
               <string>0

There are no "messages" like this in original Amarok pot file from upstream. "Translation" of this by LP Translation Teams can lead to unpredictable results (crashes, freezes, et al.)

The list of wrong parsed strings can be found here:

https://translations.launchpad.net/ubuntu/lucid/+source/amarok/+pots/amarok/uk/+translate?show=untranslated

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Problem most likely lies with the translation infastructure itself, and not with the amarok source package. I have opened tasks against the relevant projects and will close the Ubuntu amarok source package task.

Changed in amarok (Ubuntu):
status: New → Invalid
Revision history for this message
David Planella (dpm) wrote :

Jonathan,

Thanks for the heads up. Launchpad Translations, in general, only imports the PO files and POT templates from the packages, so it shouldn't be modifying or looking at .ui files. I think then, that the rosetta task might be invalid, but I'll leave the Launchpad developers decide on that.

While I think this could potentially cause untranslated strings, I believe it should not lead to unpredictable results or a crash.

The latest template update was on 2010-02-27 08:53:52.673668+00:00, so we should look at the upload that created that template.

* Was there any Amarok upload or security upload around that time?

Changed in ubuntu-translations:
status: New → Incomplete
importance: Undecided → High
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

There was an upload with a patch to port Amarok's tray icon to the new API, but I don't think it messed with any strings.

Revision history for this message
David Planella (dpm) wrote :

Every package upload of an translatable Ubuntu or Kubuntu package results in the translation template being generated and imported into Launchpad.

Jonathan, could you point us to the upload, so that we can have a look at the template imported into LP? Thanks!

Revision history for this message
Jonathan Thomas (echidnaman) wrote :
Revision history for this message
David Planella (dpm) wrote :

Ok, here is the uploaded tarball with the translations and the template: https://launchpadlibrarian.net/39821794/amarok_2.2.2.90-0ubuntu2_i386_translations.tar.gz

It seems that the template created by the package (in source/po/amarok.pot in the tarball) contains the invalid messages. I've had a quick look at the package, but I'm not very familiar with Kubuntu packaging. How is the template created?

Changed in rosetta:
status: New → Invalid
summary: - Wrong parsing of Amarok ui-files by Rosetta scripts
+ Wrong Amarok POT template creation
Revision history for this message
Yuri Chornoivan (yurchor-gmail) wrote : Re: Wrong Amarok POT template creation
Revision history for this message
David Planella (dpm) wrote :

That's definitely helpful, thanks yurchor.

This seems to be a more generalized problem, which might point to an issue in the POT template generation scripts.

* plasma-widget-networkmanagement/libknetworkmanager
** Last POT template update (import date): 2010-01-18 02:36:27.995248+00:00
** Template (translations upload): https://launchpadlibrarian.net/38013350/plasma-widget-networkmanagement_0.9%7Esvn1075616-0ubuntu1_sparc_translations.tar.gz

* kdeplasma-addons/plasma-applet-bubblemon
** Last POT template update (import date): 2010-02-22 15:27:41.051013+00:00
** Template (translations upload): https://launchpadlibrarian.net/39527265/kdeplasma-addons_4.4.0-0ubuntu2_i386_translations.tar.gz

* In Konversation I cannot see this problem, are you perhaps referring to another issue?

Do these particular packages have anything in common? Or is it something affecting all Kubuntu packages? Have extract-message.sh or Message.sh changed recently?

If it's a general issue, perhaps we should open another task for whatever is responsible for creating the POT templates?

More info at https://wiki.ubuntu.com/Translations/Upstream/KDE/KubuntuTranslationsLifecycle

[1] https://translations.launchpad.net/ubuntu/lucid/+source/konversation/+pots/konversation/uk/+translate?start=0&batch=10&show=untranslated&field.alternative_language=&field.alternative_language-empty-marker=1&old_show=all

summary: - Wrong Amarok POT template creation
+ Wrong POT template creation in some KDE packages
Changed in ubuntu-translations:
status: Incomplete → Triaged
David Planella (dpm)
Changed in pkg-kde-tools (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Revision history for this message
Yuri Chornoivan (yurchor-gmail) wrote :

I filed another bug report against Konversation ( Bug #530103 ). You are right, these bugs can be unrelated.

Changed in pkg-kde-tools (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
status: New → Triaged
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkg-kde-tools - 0.6.4ubuntu4

---------------
pkg-kde-tools (0.6.4ubuntu4) lucid; urgency=low

  * Add syncing of l10n scritps with KDE SVN to debian/rules (syncl10n)
    + this can be invoked via make -f debian/rules syncl10n
    + sync scripts, to fix POT creation (LP: #529483)
 -- Harald Sitter <email address hidden> Mon, 01 Mar 2010 15:21:23 +0100

Changed in pkg-kde-tools (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Harald Sitter (apachelogger) wrote :

Amarok needs binary rebuild against new pkg-kde-tools

Changed in amarok (Ubuntu):
status: Invalid → Triaged
importance: Undecided → High
assignee: nobody → Harald Sitter (apachelogger)
Revision history for this message
David Planella (dpm) wrote : Re: [Bug 529483] Re: Wrong POT template creation in some KDE packages

El dl 01 de 03 de 2010 a les 21:27 +0000, en/na Harald Sitter va
escriure:
> Amarok needs binary rebuild against new pkg-kde-tools

Here's the list of packages which might need a rebuild. The two files
show the potentially affected source packages in all series against the
staging database and then for Lucid only against the production
database. I think the Lucid list should be a good start, bearing in mind
that there are also false positives which should be ignored (gcc, gdb,
binutils, gnome-doc-utils, OO.org, etc.)

Perhaps you'd like to add a task for every affected Kubuntu package
here, whichever way it's easy for you to track.

Changed in kde-style-qtcurve (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → High
status: New → Triaged
Changed in konversation (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → High
status: New → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package konversation - 1.2.3-1ubuntu2

---------------
konversation (1.2.3-1ubuntu2) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden> Tue, 02 Mar 2010 22:54:20 +0100

Changed in konversation (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-style-qtcurve - 1.0.2-1ubuntu2

---------------
kde-style-qtcurve (1.0.2-1ubuntu2) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden> Tue, 02 Mar 2010 23:22:29 +0100

Changed in kde-style-qtcurve (Ubuntu):
status: Triaged → Fix Released
Changed in plasma-widget-networkmanagement (Ubuntu):
status: New → Triaged
Changed in kipi-plugins (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in plasma-widget-networkmanagement (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Changed in kipi-plugins (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Changed in plasma-widget-networkmanagement (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kipi-plugins - 1.0.0-1ubuntu2

---------------
kipi-plugins (1.0.0-1ubuntu2) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden> Tue, 02 Mar 2010 23:34:25 +0100

Changed in kipi-plugins (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plasma-widget-networkmanagement - 0.9~svn1075616-0ubuntu2

---------------
plasma-widget-networkmanagement (0.9~svn1075616-0ubuntu2) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden> Tue, 02 Mar 2010 23:38:13 +0100

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.2.2.90-0ubuntu3

---------------
amarok (2:2.2.2.90-0ubuntu3) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden> Tue, 02 Mar 2010 23:56:33 +0100

Changed in amarok (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Harald Sitter (apachelogger) wrote :

All other core KDE packages should have been rebuilt in course of the 4.4.1 upload.
I am not sure if openoffice needs a new upload, need to look into that.

Revision history for this message
Harald Sitter (apachelogger) wrote :

From looking at the openoffice.org buildlog it does not seem to generate templates using the affected tools, so that is probably a false-positive, otherwise final upload will sort the issue anyway.

I think that all packages should now have fixed templates uploaded/in queue.

Revision history for this message
David Planella (dpm) wrote :

A quick inspection at the templates shows that they are ok now, thus marking it as Fix Released for ubuntu-translations as well.

If any strings became untranslated because of this, we might just have to wait for the next Lucid language pack to be generated to see the fix.

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers