amarok is not able to show flac tags anymore

Bug #497147 reported by gene on 2009-12-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

Recently, perhaps with some updates, amarok does not show metaflac info for some flac files.
E.g., I got using the lltag commad:
 lltag -S /media/MyBook/musyka/Schubert/Schubert_piano_sonatas/CD1/0[12]*flac
/media/MyBook/musyka/Schubert/Schubert_piano_sonatas/CD1/01_track.flac:
  ARTIST=Alfred Brendel (Klavier)
  TITLE=Schubert - Klaviersonate D-dur, op.53, D850: 1. Allegro
  ALBUM=Schubert - Klaviersonaten D850, D784 - Brendel
  NUMBER=1
  TRACKTOTAL=7
  PERFORMER=Alfred Brendel (Klavier)
/media/MyBook/musyka/Schubert/Schubert_piano_sonatas/CD1/02_track.flac:
  ARTIST=Alfred Brendel (Klavier)
  TITLE=Schubert - Klaviersonate D-dur, op.53, D850: 2. Con moto
  ALBUM=Schubert - Klaviersonaten D850, D784 - Brendel
  NUMBER=2
  TRACKTOTAL=7
  PERFORMER=Alfred Brendel (Klavier)
Amarok just shows the name of the file 0[12].flac

I remember no problems before with these particular files.

Amarok's support of tags has not been very good before. In case if (flac) tags would use some non ACSII characters, amarok does not play a file in question at all. This issue is different from the current one though

ProblemType: Bug
Architecture: i386
Date: Tue Dec 15 15:31:50 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: amarok
Uname: Linux 2.6.31-16-generic i686

gene (eugenios) wrote :
gene (eugenios) wrote :

Oops, turns out amarok does not show metaflac info anymore. Gotta change the bug title

summary: - amarok is not able to show some flac tags
+ amarok is not able to show flac tags anymore
Myriam Schweingruber (myriam) wrote :

This works perfectly well here with Amarok 2.2.1 and 2.2.2 beta, I guess you have some missing dependencies or an incompatible taglib version. Current should be libtag1ca-1.6.2ubuntu2 in KDE 4.3.4 (available in the updates PPA, see also http://kubuntu.org) which would be 1.6.1 at least in KDE 4.3.2. FYI, Amarok needs both libtag1 and libtag-extras1 to have full file format support.

Changed in amarok (Ubuntu):
status: New → Invalid
gene (eugenios) wrote :

Thanks Myriam,
Mine is 2.2.0
amarok -v
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)
Amarok: 2.2.0
As far as the libtag* stuff, here's what I have

dpkg-query -l libtag*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
un libtag-extras0 <none> (no description available)
ii libtag-extras1 1.0.1-0ubuntu1 TagLib extras library - support for more fil
un libtag1-rusxmm <none> (no description available)
ii libtag1-vanill 1.6-2ubuntu2 TagLib Audio Meta-Data Library (Vanilla flav
ii libtag1c2a 1.6-2ubuntu2 TagLib Audio Meta-Data Library
rc libtagc0 1.5-3 TagLib Audio Meta-Data Library (C bindings)

If there is any broken dependency, it was broken by the aptitude, not me.

gene (eugenios) wrote :

Well, the weird thing is that, amarok used to read all flac tags for me a few weeks ago. Now it does not for the most, however not all. For example,
Amarok does not read now this tag
ltag -S /media/MyBook/musyka/Schubert/Schubert_piano_sonatas/CD1/01_track.flac
/media/MyBook/musyka/Schubert/Schubert_piano_sonatas/CD1/01_track.flac:
  ARTIST=Alfred Brendel (Klavier)
  TITLE=Schubert - Klaviersonate D-dur, op.53, D850: 1. Allegro
  ALBUM=Schubert - Klaviersonaten D850, D784 - Brendel
  NUMBER=1
  TRACKTOTAL=7
  PERFORMER=Alfred Brendel (Klavier)
But it will read this one
lltag -S /media/MyBook/musyka/Haydn/cd21\ -\ string\ quartets\ op.\ 76\,\ nos.\ 4\,\ 5\,\ 6/01.flac
/media/MyBook/musyka/Haydn/cd21 - string quartets op. 76, nos. 4, 5, 6/01.flac:
  ARTIST=Kodály Quartet
  TITLE=String Quartet in B Flat Major Op. 76 No. 4 'Sunrise' - Allegro con spirito
  ALBUM=Haydn - String Quartets Op. 76 Nos. 4-6
  NUMBER=1
  TRACKTOTAL=12
  PERFORMER=Kodály Quartet

And this is even more strange! Hence, I noticed that, amarok used not to play a (flac) file with some non-ASCII characters in tags. So, before, I thought the problem was in the "Kodály". Now it plays and reads it???

gene (eugenios) wrote :

Why do you change it to "invalid"? This is kind'a rude, I guess.
I will try to explain something.
THe intent was to help the community by reporting this bug. With all the plethora of media player outthere. I would use mplayer and/or xmms (which is not included into any *buntu anymore) . These are the most efficient and stable and versatile players. mplayer right now does show flac tags, xmms uses twice as much cpu to play it. I gave a try to amarok again, it could both play flac as efficiently as mplayer and read tags. Now it does not do the second. So I will not use it.

Changed in amarok (Ubuntu):
status: Invalid → Confirmed
Changed in amarok (Ubuntu):
status: Confirmed → New
gene (eugenios) wrote :

This is very weird. I experimented with some of the files amarok has trouble reading. I copied them to a different directory and had amarok load them ... and it now reads their tags. However, just symlinking does not help. If you want me to investigate any further I could. 'Cause, neither of audacius2, nor xmms do that...

Lari Natri (larva) wrote :

I seem to have the same problem, except that for me it manifests only with BPM tags in those FLAC files, which are located in the collection directories. All the other tags are fine, and even the BPM is displayed correctly for tracks added to the playlist from a directory not in the collection. BPM tags for mp3 and ogg files work correctly always.

Distribution: Ubuntu 9.10
Qt: 4.6.0
KDE Development Platform: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Amarok: 2.2.2 final (2.2.2-0ubuntu1~karmic1~ppa1)

For example, "metaflac --list ./01_-_Troll_Scientists_-_Disco_Doctor.flac" outputs:
METADATA block #2
  type: 4 (VORBIS_COMMENT)
  is last: false
  length: 163
  vendor string: reference libFLAC 1.2.1 20070917
  comments: 7
    comment[0]: ALBUM=Sir Eel
    comment[1]: ARTIST=Troll Scientists
    comment[2]: DATE=2009
    comment[3]: GENRE=psyish
    comment[4]: TITLE=Disco Doctor
    comment[5]: TRACKNUMBER=1
    comment[6]: BPM=142

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE
program itself, and not with our KDE packages. While we appreciate your issue,
it would be better if it was tracked at https://bugs.kde.org, so that the KDE
developers can deal with this speedily and have direct communication with you
as the reporter for more effective debugging.

Thanks!

 status invalid

Changed in amarok (Ubuntu):
status: New → Invalid
gene (eugenios) wrote :

Sorry I guess this bug was fixed for me after one of the updates. Amarok is pretty nice - it does not seem to eat as much resources as audacious for me, and gets close to mplayer.

Lari Natri (larva) wrote :

Apparently this bug has now been fixed upstream, though the patch possibly didn't make it into amarok 2.3.2; at least the version currently in Maverick (2.3.2-0ubuntu1) doesn't contain the fix. Link to the bug report in question: https://bugs.kde.org/show_bug.cgi?id=234166

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.