Amarok 2.2.0 Does Not Play Music in Ubuntu 9.10 with phonon-backend-gstreamer and phonon-backend-xine

Bug #494851 reported by rusivi2
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: amarok

1) lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

2) apt-cache policy amarok
amarok:
  Installed: 2:2.2.0-0ubuntu2
  Candidate: 2:2.2.0-0ubuntu2
  Version table:
 *** 2:2.2.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

 apt-cache policy ubuntu-restricted-extras
ubuntu-restricted-extras:
  Installed: 36
  Candidate: 36
  Version table:
 *** 36 0
        500 http://us.archive.ubuntu.com karmic/multiverse Packages
        100 /var/lib/dpkg/status

apt-cache policy phonon-backend-gstreamer
phonon-backend-gstreamer:
  Installed: 4:4.3.1-4ubuntu1
  Candidate: 4:4.3.1-4ubuntu1
  Version table:
 *** 4:4.3.1-4ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

apt-cache policy phonon-backend-xine
phonon-backend-xine:
  Installed: 4:4.3.1-4ubuntu1
  Candidate: 4:4.3.1-4ubuntu1
  Version table:
 *** 4:4.3.1-4ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

3) What I expected to happen was that after adding the directory of music files, the music would play with no problem.

4) What happens instead is that no music plays, nor does Amarok reflect a song playing in the song playing bar.

ProblemType: Bug
Architecture: i386
Date: Wed Dec 9 23:09:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.52-generic
SourcePackage: amarok
Uname: Linux 2.6.31-16-generic i686

********* (bug information from post install of phonon-backend-gstreamer and phonon-backend-xine)

ProblemType: Bug
Architecture: i386
Date: Mon Dec 14 20:45:31 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: amarok
Uname: Linux 2.6.31-16-generic i686
XsessionErrors:
 (gnome-settings-daemon:2283): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2283): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2412): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2408): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (nautilus:4466): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :
Changed in amarok (Ubuntu):
status: New → Confirmed
Revision history for this message
Myriam Schweingruber (myriam) wrote :

Make sure to install the appropriate codecs, available in kubuntu-restricted-extras package (ubuntu restricted-extras if you use phonon-backend-gstreamer, but we recommend the use of the phonon-backend-xine for Amarok to have better results).

Changed in amarok (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Installing Ubuntu restricted-extras package, as well as phonon-backend-gstream, then phonon-backend-xine did not allow for Amarok to play AAC/mp4 files. Please see following bug for more information: https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/496811

Changed in amarok (Ubuntu):
status: Invalid → Confirmed
description: updated
summary: - Amarok 2.2.0 Does Not Play Music in Ubuntu 9.10
+ Amarok 2.2.0 Does Not Play Music in Ubuntu 9.10 with phonon-backend-
+ gstreamer and phonon-backend-xine
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Please ignore 496811 bug reference, it's a duplicate bug.

tags: added: phonon-backend-gstreamer phonon-backend-xine
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :
description: updated
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

You need libxine1-ffmpeg too.

Changed in amarok (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Install of libxine1-ffmpeg got it playing flawlessly.

Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Was not allowed to convert this bug to a question, so posted related question here:

https://answers.launchpad.net/ubuntu/+source/amarok/+question/94402

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers