amarok stopped scrobbling to last.fm

Bug #355308 reported by Kieran Hogg on 2009-04-04
234
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
Medium
amarok (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by Tom Chiverton

Bug Description

Binary package hint: amarok

Amarok has recently stopped scrobbling to last.fm.

Related branches

Changed in amarok:
status: Unknown → Confirmed
Changed in amarok (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Johannes Maibaum (jmaibaum) wrote :

Official patch for this was released recently by the Amarok developers. See: http://websvn.kde.org/?view=rev&revision=949421 and https://bugs.kde.org/show_bug.cgi?id=188678#c26

Mindphaser (mindo83) wrote :

yo lovely devs, please include this tiny patch, lotsa people miss their scrobblin experience ^^

clickwir (clickwir) wrote :

If it helps, I can also confirm that I'm seeing this in Jaunty right now. Amarok 2.0.2.

Everything else seems to work fine, just not last.fm portion.

Changed in amarok:
status: Confirmed → Fix Released
Valentin Rocher (bishiboosh) wrote :

Apparently the bug is resolved in version 2.1...Will this version appear in Jaunty ?

zdenek.zikan (zdenek-zikan) wrote :

You changed the status to "Fix released" few days ago but the current version in Jaunty is unpatched. Does this mean that you will incorporate Amarok 2.1 to Jaunty as soon as it is released or that the patched 2.0.2 will appear in repository before Jaunty release?

FWIW, compiling Amarok from scratch, as per their wiki was easy enough (exclude the 'cd build' step) and 'make install' put the working Amarok over the top of the broken one from the distro. fine.

Jonathan Thomas (echidnaman) wrote :

Here's a fixed source package. Attaching for sponsorship.

Jonathan Thomas (echidnaman) wrote :
Changed in amarok (Ubuntu):
assignee: nobody → echidnaman
status: Triaged → In Progress
Jonathan Thomas (echidnaman) wrote :

Btw, it's just the bug at bugs.kde.org that has been marked fixed.

Jonathan Thomas (echidnaman) wrote :

Uploaded, but the fix won't arrive until after the Release Candidate is released.

Changed in amarok (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.0.2mysql5.1.30-0ubuntu3

---------------
amarok (2:2.0.2mysql5.1.30-0ubuntu3) jaunty; urgency=low

  * Add kubuntu_07_lastfm_scrobble.diff from upstream to fix Last.fm
    scrobbling (LP: #355308)

 -- Jonathan Thomas <email address hidden> Wed, 15 Apr 2009 15:20:56 -0400

Changed in amarok (Ubuntu):
status: Fix Committed → Fix Released
OmniWired (omniwired) wrote :

After updating: It still doesn't work. It still says "testing" when you click in the test login button.
I already tried deleting /home/{USER}/.kde4/share/apps/amarok and /home/{USER}/.kde/share/apps/amarok.

Please I need help, and looking forward to have everything working properly for the rest of the users.

Me too, It still doesn't scrobbling to last.fm. I remove amarokrc, apps/amarok without success :(

Thomas Hellermann (izarael) wrote :

Me too. Just got the update (on Jaunty) it still doesn't work.

Valentin Rocher (bishiboosh) wrote :

Same thing here. The message given is still that the signature is wrong.

Kieran Hogg (xerosis) wrote :

Setting back to confirmed, this doesn't fix it for me either.

Changed in amarok (Ubuntu):
status: Fix Released → Confirmed
zdenek.zikan (zdenek-zikan) wrote :

I have tried Amarok 2.1 beta from unofficial repository kubuntu-experimental (line for sources.list: "deb http://ppa.launchpad.net/kubuntu-experimental/ubuntu jaunty main") and the problem is fixed there.

zdenek.zikan (zdenek-zikan) wrote :

As a beta, it has some stability issues, but it's already quite usable.

Phil Krämer (man0riax) wrote :

I have tried Amarok 2.1 beta from unofficial repository kubuntu-experimental (line for sources.list: "deb http://ppa.launchpad.net/kubuntu-experimental/ubuntu jaunty main") and the problem is fixed there.

Working, but this one gives some error messages related to some scripts that are installed.

Myriam Schweingruber (myriam) wrote :

@man0riaX: Scripts are third party software, so you should check with the respective authors of those scripts. This is not an Amarok bug.

not quite sure... these scripts are the default ones and work fine on fedora 10..

i'm talking about the Lyricwiki and Librivox.org on amarok 2.0.90 from kubuntu-experimental.. I think they depend on qtscriptgenerator...

klarsen (kroylar) wrote :

I just upgraded to Jaunty today and I too am experiencing this bug. Can we get an updated ubuntu package for Amarok 2.0.2 with the patch applied?

ahmy (ahmy135) wrote :

I try the Jaunty and instaled the 2:2.02mysql5.1.30-0ubuntu3 (jaunty) but this bug still persist

uhniuef8787 (bbfc66) wrote :

Installed Amarok 2.1beta (2.0.90) from the unofficial repository kubuntu-experimental (mentioned by zdenek.zikan). Besides some stability issues, scrobbling to last.fm seems to work again without problems. Thanks for the fix, hope to see the update in the official repositories soon :)

I've gone back to 1.4 using this article: http://nomad.ca/blog/2009/apr/3/amarok-14-jaunty-ubuntu-904/

I'll re-visit 2.02+ from time to time as it is updated.

James Purl (fabulous) wrote :

It seems that kubuntu_07_lastfm_scrobble.diff in the debian/patches-amarok directory fails. I have created one that worked for me doing the following:
1) apt-get source amarok
2) replaced the mentioned diff with mine
3) Used pbuilder to rebuild (i bumped mine to version ubuntu4 so that it would update when placed on my local repository).

Hope this helps--I couldn't live without my amarok and scrobbling!

James Purl (fabulous) wrote :

For those that want to, I've uploaded my version to my ppa:
https://launchpad.net/~fabulous/+archive/ppa

(It's still building as I write this, but assuming it completes, you can follow the instructions at the link to install it).

Phil Krämer (man0riax) wrote :

Very nice, thanks man.

James Purl (fabulous) wrote :
Changed in amarok (Ubuntu):
assignee: echidnaman → fabulous
status: Confirmed → In Progress
James Purl (fabulous) on 2009-04-29
Changed in amarok (Ubuntu):
assignee: fabulous → nobody
status: In Progress → Confirmed
Seyfer (seyferseed) wrote :

I can't build amarok src. Cmake need, but it's not working with gnome.
Please tell me, how can i fix this bug in gnome? Or how build amarok in gnome?

 James Purl wrote on 2009-04-29: (permalink)
For those that want to, I've uploaded my version to my ppa

This version's not for my architecture..

Seyfer (seyferseed) wrote :

Go to System > Administration > Software Sources, on the Third-Party Software tab click "Add" and add these repositories:

    code:deb http://ppa.launchpad.net/kubuntu-ex...ntal/ppa/ubuntu jaunty main
    deb-src http://ppa.launchpad.net/kubuntu-ex...ntal/ppa/ubuntu jaunty

And update your sources:

    code:sudo apt-get update

Then, to only update Amarok (since this is an experimental repository and it's not recommended using it), go to
System > Administration > Synaptic Package Manager

and search for "
Amarok

", right click and select "
Mark for upgrade

", apply changes and after Amarok is upgraded, I suggest removing the 2 repositories I wrote above in this post.

sandos (sandos) wrote :

I tried james' PPA repo, but that didn't fix it for me??

@sandos: worked here, does the account work OK when you press the test button in the preferences panel ? What is output when you run Amarok from the console ?

sandos (sandos) wrote :

It says this, among other things (I removed what looked like secrets):

amarok(6460) KNetworkAccessManager::createRequest: GetOperation: QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=xxx&authToken=yyy&method=auth.getMobileSession&sk=&username=sandos&api_sig=zzz" )
QNetworkReply::ConnectionRefusedError
":"
  QUrl( "" )
 ""

I'm not sure the ConnectionRefusedError is connected to the last.fm functionality, because if I paste the URL into firefox it returns a XML with no errors in it, and this error message is printed a few times before I press "test" in the preferences panel. The button just says "Testing..." and is greyed out, as before. And no songs are scrobbled.

James Purl (fabulous) wrote :

Did I need to say that my debdiff was posted for sponsorship? I forgot that step.

@Sandos: Could it be proxy related (so Amarok is or is not using the same one as your web browser) ?
@James: I have no idea what you said, even though most of the words I recognise. Are you saying you want money to fix this bug or something ?

James Purl (fabulous) wrote :

@Tom: I don't want anything except for a member of the Amarok team to apply my patch to the official repository package since it fixes the reported bug. I used the word sponsorship because I read somewhere on the Launchpad/Ubuntu-Dev docs that if you aren't a member of the team for a package, then you post a debdiff fixing the reported bug so that someone who is a member can apply it.

@James I thought that's what 'nominate' did - I've already used it once, want to try it yourself ?

Severe bug that isn't fixed for me either with the latest update.

Martin Henze (martin-henze) wrote :

This a severe bug for which the developers already released a fix. This should make it into the repositorys as soon as possible.

Myriam Schweingruber (myriam) wrote :

Folks, this is fixed since ages and a fix has been released, check out the jaunty-backports.

@James: please submit any patches regarding the Amarok code to https://bugs.kde.org to make sure it finds it's way in the general code. Don't forget to start the title with [PATCH] so the devs can see it fast and test it ASAP.

Myriam Schweingruber (myriam) wrote :

New package is available in teh jaunty-backports since quite some time

Changed in amarok (Ubuntu):
status: Confirmed → Fix Released
David Zumbrunnen (zumbrunnen) wrote :

Myriam, when it has been fixed for ages and it is in the jaunty-backports, why it didn't reach jaunty? I think, users don't want to switch to the backports for just an update...

Myriam Schweingruber (myriam) wrote :

David: that is not current policy. When Jaunty was released, it shipped Amarok 2.0.2, which unfortunately is already very old. To include a newer version, Amarok 2.1 should have been released before the feature freeze for Jaunty. As this was not the case, it goes to the backports.

FYI, there is absolutely nothing we can do about that, it is the feature policy for Kubuntu, and happens to a lot of other applications too who do not release at the same time as Kubuntu does. And that's what the backports are for: backporting newer versions of applications.

If you don't want to get the newer package from the backports, you will have to wait for Karmic Koala aka Kubuntu 9.10 to be released.

@Myriam: But surely bug fixes can be ported back to the same version - there was a patch submitted to do just that.

James Purl (fabulous) wrote :

@Myriam: My patch is based on one from upstream KDE/amarok--what I did is apply it to the jaunty package, and provided a debdiff in the hope that it would gain a sponsor and the official version would be patched. Also, I uploaded a version with my patch applied to my PPA so that others (on the same ARCHs supported by ppa) could just install my package.

Myriam Schweingruber (myriam) wrote :

@Tom: well, Amarok 2.0.2 and Amarok 2.1 are not the same version, so of course this is not possible.

@James: you need to talk to the Kubuntu packagers then, but there is no way AFAICT to get a patch into 2.0.2. Also, it wouldn't make much sense, as this version is quite old and Amarok 2.1.x is out of the door since quite some time.

The patch to 2.0.2 is right here. It's not a Kubuntu thing as it's broken in Ubuntu too.

It seems this does not work in Karmic either...

Changed in amarok (Ubuntu):
status: Fix Released → Confirmed

Did you check your Amarok last.fm settings? Apparently the credentials are dropped during the upgrade...

Works fine on Karmic.

Jonathan Thomas (echidnaman) wrote :

Most likely a different issue. Last.fm is now wanting users of external clients to have a paid subscription.

Changed in amarok (Ubuntu):
status: Confirmed → Fix Released
N7DR (doc-evans) wrote :

I don't know where you got your information, Jonathan, but I don't have a paid subscription and it's working fine here (in karmic).

Lorenzo Battistini (elbati) wrote :

Radio requires subscription for users living outside the US, the UK and Germany: http://blog.last.fm/2009/04/22/radio-subscriptions .
Every external client can access to Last.fm web services.
Scrobbling works fine in karmic.

Well, it works as long as the KDE wallet subsystem is enabled. As soon as that one is turned off, it breaks and Amarok gets Alzheimer's with regards to the last.fm credentials (even re-entering them has zero effect, the settings dialog comes up blank when invoked again immediately).

Changed in amarok (Ubuntu):
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

A completely, totally different issue than the one reported here.

Changed in amarok (Ubuntu):
status: Confirmed → Fix Released

Well, if you insist on this formalism (the symptom from a user-perspective is that scrobbling does not work): I just filed a new bug for this: bug #473611: Amarok stopped scrobbling to last.fm

Myriam Schweingruber (myriam) wrote :

Come on, Thilo-Alexander, don't be such a prick. The fix has been released upstream for the upcoming Amarok 2.2.1, just be patient to give the developers time to release it (in roughly 2 weeks) and the Kubuntu packagers to package it and put it to the PPA.

Sorry, my bad. That was not visible from the context (as the only upstream bug reference is to a 2.0 bug). Proposal: When a package maintainer knows about a pending upstream fix, document this in the bug report instead of closing it without a sensible explanation.

But I am getting off-topic...

Changed in amarok:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.