amarok 2 not play mp3's in default installation

Bug #320901 reported by Alexander Solodukhin on 2009-01-24
8
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

In default instalation of kubuntu 9.04 amarok 2 does not play mp3's. Ogg's played fine. phonon-backend-xine installed.

Description: Ubuntu jaunty (development branch)
Release: 9.04

amarok:
  Installed: 2:2.0.1.1-0ubuntu4
  Candidate: 2:2.0.1.1-0ubuntu4
  Version table:
 *** 2:2.0.1.1-0ubuntu4 0
        500 http://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

description: updated
Christian Mangold (neversfelde) wrote :

I might be wrong, but is libxine1-ffmpeg installed?

No, it's not. libxine1-ffmpeg solves the problem, maybe it must be in
depends list of kubuntu-desktop package?

Christian Mangold <email address hidden> писал(а) в своём письме Sat, 24
Jan 2009 20:34:24 +0200:

> I might be wrong, but is libxine1-ffmpeg installed?
>

--
ISP CrIS, Softwarium

Harald Sitter (apachelogger) wrote :

Hello,

Unfortunately, MP3 is a pretty patented format, and it's lega situation in free software is somewhat unclear. So we must refrain from shipping support from it by default
However, we are working on (re)implementing a feature to handle the installation of the necessary package once you try to play a MP3, that is a different bug though :)

I am closing this one as Won't Fix, while in fact it is can't fix.
Thank you for your report nonetheless.

Have a nice day.

Changed in amarok:
status: New → Won't Fix
Jonathan Thomas (echidnaman) wrote :

In the meantime you can track the return of the automatic codec installer at bug 268617.

andrew1056 (andrew-oke) wrote :

Just updated to the beta 9.04 version of Ubuntu. Amarok wouldn't play mp3's even though I had libxine1-ffmpeg installed. The problem I found was that phonon-backend-xine didn't install. After I installed everything worked perfectly.

I didn't download the live cd to update... used 'update-manager -d'.

Perhaps phonon-backend-xine isn't set to install with amarok? I don't know much about this stuff, just figured I'd share how I fixed it.

nh2 (nh2) wrote :

@Harald Sitter:

Of course, you are right concerning the MP3 patents. But as far as I know, libxine1-ffmpeg is not what installs MP3 support, but only a plugin for xine to use ffmpeg (and therefore free software which is in the main repo).

If libxine1-ffmpeg is not installed, Amarok is not able to play MP3 even if you installed ubuntu-restricted-extras, from what the user expects to make MP3 work - an unexperienced user would never get the idea of installing libxine1-ffmpeg.

Is there any reason not to recommend libxine1-ffmpeg in the Amarok package?

Adrian Wilkins (adrian-wilkins) wrote :

Or how about adding libxine1-ffmpeg to ubuntu-restricted-extras, since much of ffpmeg is probably fairly grey, patent-ly speaking.

Luis F. Lopez (luis.lopez) wrote :

Actually, libxine1-ffmpeg is included in kubuntu-restricted-extras package . A logical choice, as it is a KDE component

Jonathan Thomas (echidnaman) wrote :

libxine1-ffmpeg isn't really a KDE component. KDE just happens to use it a bit more heavily than GNOME does, which has decent gstreamer codecs for mp3s. Unfortunately Phonon's GStreamer backend currently sucks.

Terence Simpson (tsimpson) wrote :

@nh2:

Even though libxine1-ffmpeg and ffmpeg are open source, we can't distribute them by default because of possibly patient issues. That is why a user must either, explicitly install support for it, or explicitly agree to have the system install it for them.
We also can not make amarok recommend libxine1-ffmpeg as apt will now automatically install recommends, so this would be the same as automatically distributing the package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers