Amarok partially "forgets" media devices on close

Bug #207704 reported by Pichu0102 on 2008-03-27
30
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
High
Harald Sitter

Bug Description

Binary package hint: amarok

Ubuntu 8.04 beta. Recent package update has somewhat broken Amarok's media devices tab. When Amarok closes, it "forgets" all media devices and displays no devices available on next boot, and the devices are missing from the devices tab in settings. However, at the same time, it partially remembers them, as you can't give a device the same name as a "forgotten" device. However, putting in the device details again allows it to work until Amarok next closes, at which point you have to think of a new name as your previous one is now "used up".

Iain Lane (laney) wrote :

Confirming. I just upgraded to Hardy from Gutsy and am now seeing this.

Changed in amarok:
status: New → Confirmed
Iain Lane (laney) wrote :

Pichu0102, I just installed the kdebase-kio-plugins packgage as someone mentioned in bug 186384, comment #18. Can you try it and see if this fixes anything for you?

This does not fix the problem.

However, after a crash when recreating the file again, and the UI for the Media Devices tab malfunctioned and showed no details, my iPod now correctly autodetects and no longer falls off the list of devices. However, manually added devices still do not persist over sessions.

rune0077 (majrune) wrote :

I'm confirming this as well, my iPhone and both my girlfriends iPod and Nokia phone must be manually reentered every time Amarok is loaded before it is available in the "Devices" list.

Changed in amarok:
importance: Undecided → Medium
Jussi Saarinen (jms) wrote :

Me too. Hardy with mt-daap device in lan. No device is shown after amarok restart and I am not able to add it again because amarok whines:

Sorry, you cannot define two devices with the same name and mountpoint!

vaughn (vaughngrisham) wrote :

I have a Cowon iAudioF2 portable music player, which has worked well as a generic device in Amarok since Dapper. I'm having the same problem after installing Hardy. I have two computers with Hardy, one 32-bit and one 64-bit and this problem seems to have been resolved yesterday on the 32-bit box after Synaptic installed several updates. However, the problem persists on the 64-bit box.

GeekGirl1 (my-e-mail1) wrote :

Add my Creative Zen 8GB to the list, which is an MTP device. In Gutsy, I had a problem of not detecting anything, but that was solved by upgrading libmtp. In Hardy, I repeat the error of failing to auto-detect the device and also get the error to not define two devices with the same name and mountpoint. This is a 64-bit OS.

Versions via 'apt-cache policy packagename':
----------------------------------
kdebase-kio-plugins:
  Installed: 4:3.5.9-0ubuntu6
  Candidate: 4:3.5.9-0ubuntu6
  Version table:
 *** 4:3.5.9-0ubuntu6 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
--------------------------------
libmtp7:
  Installed: 0.2.6.1-1
  Candidate: 0.2.6.1-1
  Version table:
 *** 0.2.6.1-1 0
        500 http://us.archive.
---------------------------------
amarok:
  Installed: 2:1.4.8-0ubuntu5
  Candidate: 2:1.4.8-0ubuntu5
  Version table:
 *** 2:1.4.8-0ubuntu5 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
------------------------------------
OS: Release via 'lsb_release -rd':
Ubuntu hardy (development branch)
Release: 8.04

Display manager: KDE 3.5
kernel: 2.6.24-14-generic (#1 SMP Thu Apr 3 04:16:51 UTC 2008)
Platform: amd64 (64-bit OS)

vaughn (vaughngrisham) wrote :

I just upgraded to kernel 2.6.24-15-generic. Still no luck getting Amarok to play nice with my generic device in Hardy.

Harald Sitter (apachelogger) wrote :

This effects _all_ manually configured device and therefore can have great impact on all Amarok users with media devices. -> raising Importance to High

Changed in amarok:
importance: Medium → High
vaughn (vaughngrisham) wrote :

Thank you Harald.

Changed in amarok:
assignee: nobody → apachelogger
status: Confirmed → In Progress
Harald Sitter (apachelogger) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.9.1-0ubuntu2

---------------
amarok (2:1.4.9.1-0ubuntu2) hardy; urgency=low

  [ Daniel Hahler]
  * debian/patches/kubuntu_08_add_lastfm_recommended_radio.diff:
    Add lastfm recommended radio station (LP: #103227)
  * debian/patches/kubuntu_09_audio_mimetypes.diff:
    - Add mimetypes audio/flac and audio/ogg (LP: #201291)

  [ Harald Sitter ]
  * Unbreak manual media device configuration by enhancing
    kubuntu_08_luks_device_detection.diff (LP: #207704)

 -- Harald Sitter <email address hidden> Sat, 12 Apr 2008 13:47:12 +0200

Changed in amarok:
status: In Progress → Fix Released
vaughn (vaughngrisham) wrote :

How long does it usually take for these things to work themselves into the repository?

vaughn (vaughngrisham) wrote :

Thank you very much Harald. How long does it usually take for these things to work themselves into the repository?

Did the upgrade to amarok - 2:1.4.9.1-0ubuntu2 this morning it worked perfect with my ipod nano 2g,
thanks Harald

rune0077 (majrune) wrote :

Yep, it's working fine now: now I just have a long list of identical devices, one for every time I had to reconfigure it, so I guess Amarok did store those configurations somewhere - I'll just delete all the surplus ones, and things should be back to normal.

Harald Sitter (apachelogger) wrote :

Yes, Amarok did store them, it just was unable to parse them again at restart, since the parsing format changed due to the LUKS support patch we implemented for Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers