Amarok does not autodetect devices in Hardy, and in Gutsy with KDE3.5.9 and KDE4 ppa repository

Bug #186384 reported by davebv on 2008-01-27
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Richard Johnson

Bug Description

In hardy does not work at all, with the official packages in the official repository.

In gutsy, I did the following:

I followed the instructions in
http://kubuntu.org/announcements/kde-4.0.php
and added the ppa repository: "deb http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu gutsy main"

I did actually apt-get update and dist-upgrade before installing kde4-core package. And after that, some kde3 packages were upgraded. So far so good, but thet I tried to use amarok with my ipod and the following message popped up:

"No new media devices were found. If you feel this is an error, ensure that the DBUS and HAL daemons are running and KDE was built with support for them. You can test this by running "dcop kded mediamanager fullList" in a Konsole window"

And then, when I try to disconnect the ipod within amarok, it tries to eject the CD instead of disconnecting the ipod. Besides, when it does not autodetect the devices such as ipod or usb devices when I plug them in or when I push the "autodetect" button in the amarok settings.

I tried to erase the ppa repository and downgrade all the packages to the official ones, and everything went to work ok again.

I attach the output from "dcop kded mediamanager fullList"

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in amarok.

davebv (dave-bv) wrote :

I did not related to a concrete package because I don't really know what it is...

Amarok works well with the kde packages from the official repositories.

It should be one of these, since they are upgraded when adding the ppa repository:
kate kcontrol kdebase-bin kdebase-data kdebase-kio-plugins kdepasswd kdeprint kdesktop kdm kfind khelpcenter kicker klipper kmenuedit konqueror konqueror-nsplugins konsole ksmserver ksplash ksysguard ksysguardd kwin libkonq4 libsearchclient0 libstreamanalyzer0 libstreams0 libstrigihtmlgui0 libstrigiqtdbusclient0 strigi-daemon

I guess is one of kdebase or something.

Thanks for the reply

Richard Johnson (nixternal) wrote :

Can you confirm that this problem is still happening? In Hardy I am unable to reproduce this issue from within either KDE 3 nor KDE 4. Thank you!

Changed in amarok:
assignee: nobody → nixternal
status: New → Incomplete
davebv (dave-bv) wrote :

Hi, the problem still exists, but now it happens also with the upgrade to kde 3.5.9 packages from
deb http://ppa.launchpad.net/kubuntu-kde-3.5.9/ubuntu gutsy main

(http://kubuntu.org/announcements/kde-359.php)

I am using amarok from backports, the 1.4.8, but it worked OK before with the kde 3.5.8 packages from ubuntu repositories.

Thanks!!!

By the way, more people having, I would say, the same problem: http://ubuntuforums.org/showthread.php?p=4364833#post4364833

scido (domi-mailing-list) wrote :

I can confirm the problem. I resolved downgrading all the kde packages to 3.5.8 version (with some troubles...)

bye,
scido

davebv (dave-bv) wrote :

Using Hardy Alpha5 this proble also exists

Albireo (albireox) wrote :

I can also confirm the bug. Is it going to be solved in a near future? I can see that this bug has been open for more than one month and no solution has been provided yet. Without the autodetection for devices aMarok is almost unusable. If there's anything I can do or test, please, count with me. Thanks a lot.

davebv (dave-bv) on 2008-03-09
description: updated
Richard Johnson (nixternal) wrote :

I will confirm this due to response. You aren't by chance running the Amarok for KDE 4 version are you? If so, well that doesn't work at all since it is a developer's release just to attract developers.

Now if you are using the old Amarok and this isn't working, then we need to figure out why. I just sync'd my iPod and I am listening to music from my Daapd server. Let me see if I can reproduce this on my other box...Just need to find my iPod cable that is now missing :)

Changed in amarok:
status: Incomplete → Confirmed
davebv (dave-bv) wrote :

I filled a bug that happened to me when trying to fix this issue in hardy:
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/200154

The thing is when I check the checkbox in the properties of the IPod device to "Automount" the ipod when plugged in freezes the computer, not totally, because I can login in the console pressing alt+F1 and killing KDED everything goes back to normallity. (kind of, obviously no media manager is loaded then)

davebv (dave-bv) wrote :

Sorry, last comment was a little mess. I try to rewrite it.

I have the issue that amarok does not autodetect the ipod. It says "No new media devices were found. If you feel this is an error, ensure that the DBUS and HAL daemons are running and KDE was built with support for them. You can test this by running "dcop kded mediamanager fullList" in a Konsole window"

When I run "dcop kded mediamanager fullList" the result is http://launchpadlibrarian.net/12132841/result.txt

I checked the checkbox in the properties of the ipod icon (right button of the mouse, properties...) "automount device" (or something like that, when the device is just plugged in it is supposed to automount) but the computer freezes, I mean, KDE freezes, because I can press alt+F1 and login into the terminal and kill the KDED process. Then, if I go back to the X, it is not frozen but obviously, I cannot manage the media devices such as usb, etc.

Sorry if I am repeating myself too much.

Confirmed in hardy up-to-date

alesuy (alejandrosena) wrote :

I have the same problem in kubuntu 7.10 it is happening since i added the kde4 repository of launchpad and updated kde 3.x packages, as everybody else in this post but my problem is a mp3 pendrive device not an iPod, and my compter does not freeze when i press autodetect when i do amarok sends the message about hall and kded media manager

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.8-0ubuntu5

---------------
amarok (2:1.4.8-0ubuntu5) hardy; urgency=low

  * Added kubuntu_08_luks_device_detection.diff to ajust Amarok's
    media device detection to properly work with kdebase's
    LUKS patch kubuntu_9913_kiomedialuks.diff) (LP: #186384)

 -- Harald Sitter <email address hidden> Tue, 18 Mar 2008 01:10:01 +0100

Changed in amarok:
status: Confirmed → Fix Released
davebv (dave-bv) wrote :

Upgrading to the package, thanks in advance!

davebv (dave-bv) wrote :

It does work for me, Thank you very much!

Albireo (albireox) wrote :

I'm not using Hardy so I can't install the precompiled package amarok (2:1.4.8-0ubuntu5). I've tried compiling from the sources of that package but the problem persists. Is there anything I can do? I'm using Gutsy and KDE3.5.9 with ppa repositories.

Detective_Librero (carlospu) wrote :

I had this same problem and also had to install package kdebase-kio-plugins in order for Amarok to detect my iPod (in https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/66764 the package appears to have been set a dependency of Amarok, but it is not now :-S ).

Albireo (albireox) wrote :

Ok, what i've done is to install the new amarok 2:1.4.8-0ubuntu5, amarox-xine-0ubuntu5 and libgpod3-nogtk_0.6.0-3ubuntu3 using the opcion dpkg -i --force-all. So, I have amarok now installed in my Gutsy and seems to work ok. iPod and external devices are properly recognized but, of course, the solution is very inelegant and i have 3 broken packages that are messing with my system. So, as seems that the solution works ok, please, compile a package for us the Gutsy people. Greetings

mxyzptlk (mxyzptlk) wrote :

I was having a similar problem, and seem to have found a fix.

Specs: Amarok 1.4.8 on Ubuntu 8.04 Beta. Device is an iRiver T10 flashed as a generic ums device.

With Amarok closed, I went into ~/.kde/share/config/amarokrc and removed every instance of any configured device. Saved the file, then opened Amarok and manually added a generic device with the appropriate mount point, etc. Plugged in my device, made sure it mounted, then connected via Amarok, and presto, I was linked up to my device again.

Hope that helps someone.

This problem is back with Amarok 1.4.9.1-0ubuntu3 and KDE 3.5.9 packages of the date of 8.04's release.
Using 8.04 upgraded from 7.10.

Ooops, it does work indeed. I just tried removing all the devices, pluging the MP3 in and pressing autodetect. Sorry for the confusion. And thanks for the fix.

planejason (planejason) wrote :

Fixed this problem in Hardy 8.04 by installing kdebase-kio-plugins as suggested by Detective_Librero. Thanks.

JRS (joel-straus) wrote :

Another resolved by installing kdebase-kio-plugins. Thanks.

chavesnake (archivosydemas) wrote :

I had the same problem with amarok 1.4.9.1 using hardy, installing kdebase-kio-plugins worked for me as well

Tobiz (pjrobinson) wrote :

I have this or a similar problem on Mythbuntu 8.04.1 (64). Amarok won't mount cds from new external usb drive I have which seems to be scsi over usb. External drive works ok for boot, MLC media player plays the discs ok using /dev/scd0 but not /mnt/cdrom; amarok doesn't find any devices nor will it play /dev/scd0. Have added in kdebase-kio-plugins (via synaptic) but same result. What section in ~/.kde/share/config/amarokrc specifes details of configured devices?

Myriam Schweingruber (myriam) wrote :

Tobiz: I don't know which version is shipped with Mythbuntu, but you should try upgrade to 1.4.10 which is the latest stable release. Please report back if this shouldn't work.

Brian Watson (vertexoflife) wrote :

Supposedly this is still a problem, I am still having issues with iPod detection in Kubuntu 8.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers